1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

oxygen sensor failure

Discussion in '1st Gen. Tacomas (1995-2004)' started by toyotac, Oct 19, 2012.

  1. Oct 19, 2012 at 7:35 PM
    #1
    toyotac

    toyotac [OP] New Member

    Joined:
    Oct 15, 2012
    Member:
    #89079
    Messages:
    4
    Gender:
    Male
    First Name:
    jim
    lowell mass
    Vehicle:
    pre runner stepside
    cold air intake,e3 plugs, flow master exhaust,dual pipes,tint,ram induction scoop,staggered 50s,60s/15'' rims and tires,front mask,halo lights,1000 watt amp,dvd player,custom sub (painted)to match truck,ghost rider skull rear window graphic stepide bed,led ground lighting,
    can anybody tell me the denso part #.of an (upstream)oxygen sensor for a 2000 tacoma 2.4L manual transmission an calif. emmissions. i bought both sensors on ebay.the back plugged right in but on the front i had to remove the tab on the electrical connector (i knew that wasnt right)as far as the info i got from ebay they were supose to be direct fit! i forget which is which but they were denso 234 4189 an 234 4162 so i got my sticker cause the engine light stayed off but i feel like im riding a horse when in second gear!the truck ran better with the old one and the engine light on!! sorry for the lengthy post
     
  2. Oct 19, 2012 at 8:52 PM
    #2
    Grousehunter 12

    Grousehunter 12 Well-Known Member

    Joined:
    Apr 6, 2011
    Member:
    #54452
    Messages:
    100
    Gender:
    Male
    First Name:
    Ted
    Central Kentucky
    Vehicle:
    TRD 4x4 Off Road
    Tundra brakes on front
    234-4162 is upstream , 234-4189 is downstream .
     
  3. Oct 20, 2012 at 8:10 PM
    #3
    toyotac

    toyotac [OP] New Member

    Joined:
    Oct 15, 2012
    Member:
    #89079
    Messages:
    4
    Gender:
    Male
    First Name:
    jim
    lowell mass
    Vehicle:
    pre runner stepside
    cold air intake,e3 plugs, flow master exhaust,dual pipes,tint,ram induction scoop,staggered 50s,60s/15'' rims and tires,front mask,halo lights,1000 watt amp,dvd player,custom sub (painted)to match truck,ghost rider skull rear window graphic stepide bed,led ground lighting,
    well if the 234 4162 is the right one it doesnt plug right in! they are similar but i had to remove some of the plastic to join them together the wires were in the right place though and the truck bucks in 2nd gear.it didnt use to i put the broken one back in gas mileage is horrible but at least its a smoother ride! do you think they sent the wrong one? shouldnt the 2 plugs match?any ideas
     
  4. Oct 20, 2012 at 10:38 PM
    #4
    Grousehunter 12

    Grousehunter 12 Well-Known Member

    Joined:
    Apr 6, 2011
    Member:
    #54452
    Messages:
    100
    Gender:
    Male
    First Name:
    Ted
    Central Kentucky
    Vehicle:
    TRD 4x4 Off Road
    Tundra brakes on front
    Should have plugged right in . Seems they sent you the wrong one or the right one with the wrong connection installed ( I don't think Denso made this mistake ) . Call Denso at 1-888-96-DENSO and make sure that it should mate up . I hate flea bay ! It is a roll of the dice buying from them.
     
  5. Oct 21, 2012 at 7:36 PM
    #5
    toyotac

    toyotac [OP] New Member

    Joined:
    Oct 15, 2012
    Member:
    #89079
    Messages:
    4
    Gender:
    Male
    First Name:
    jim
    lowell mass
    Vehicle:
    pre runner stepside
    cold air intake,e3 plugs, flow master exhaust,dual pipes,tint,ram induction scoop,staggered 50s,60s/15'' rims and tires,front mask,halo lights,1000 watt amp,dvd player,custom sub (painted)to match truck,ghost rider skull rear window graphic stepide bed,led ground lighting,
    thanks for the # i will call them tomorrow. i'm going to get this crap over with already! gas costs to much to waste!! thanks jim
     

Products Discussed in

To Top