1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Oxygen Sensor

Discussion in '1st Gen. Tacomas (1995-2004)' started by mshane06, Jun 1, 2011.

  1. Jun 1, 2011 at 1:19 PM
    #1
    mshane06

    mshane06 [OP] Member

    Joined:
    May 23, 2011
    Member:
    #57129
    Messages:
    21
    Gender:
    Male
    First Name:
    Shane
    El Centro, CA
    Vehicle:
    96 Tacoma LX
    On my 96 Tacoma my check engine light came on. I checked the code and it was a power train 171 which is bank 1. I changed my #1 O2 sensor before the cat and cleared the code. a couple days later the code appeared again. I went ahead and changed the #2 O2 just to take that variable out of the equation and cleared the code. about a week later it came back on again. I dont know what else to do. i checked all the hoses thinking i might have a vacuum leak but there were no leaks. I have a pinhole leak in my headers that i have had on there for about 6 years but im not sure if that small leak would create the code. the hole is located where all four pipes become one. Any help would be greatly appreciated. The code is affecting my gas mileage and how my truck starts at certain times. Thanx:confused:
     
  2. Jun 1, 2011 at 4:06 PM
    #2
    DblCabMN

    DblCabMN Well-Known Member

    Joined:
    Mar 22, 2011
    Member:
    #53498
    Messages:
    693
    Gender:
    Male
    Mpls, Minnesota
    Vehicle:
    03 DC TRD/LTD
    Bilstein 5100's all around - Toytec/Eibach 112-620 Coils, Wheelers 5-Pack+Wheelers 2"AAL. 33x10.5x15 KM2s - Siped on Summit Racing 84-5883 rims with 3.750 BS. 4.88s. Demello HD round sliders. Home built full skids. Home built front bumper. Plasti'd badges. Energy Susp. steering rack bushings. Sway bar delete. Deck plate mod. aFe Pro-Dry. Gibson exhaust.
    uhhh specific code # please. Looks like it's a '96. Mileage? have you cleaned your MAF?
     
  3. Jun 1, 2011 at 4:27 PM
    #3
    01Tac0ma

    01Tac0ma Bash Fabriction & Off-Road

    Joined:
    Jun 11, 2010
    Member:
    #38782
    Messages:
    6,260
    Gender:
    Male
    First Name:
    Chad
    West Columbia, SC
    Vehicle:
    SAS 01 TRD 4x4
    Look at build!
    Bad cat?
     
  4. Jun 2, 2011 at 3:23 PM
    #4
    mshane06

    mshane06 [OP] Member

    Joined:
    May 23, 2011
    Member:
    #57129
    Messages:
    21
    Gender:
    Male
    First Name:
    Shane
    El Centro, CA
    Vehicle:
    96 Tacoma LX
    The code is a #171. I have already cleaned the MAF also. The Cat is still good.
     
To Top