1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

P0171 and P0174 TRD Supercharger

Discussion in 'Technical Chat' started by ktmrider, May 8, 2011.

  1. May 8, 2011 at 7:02 PM
    #1
    ktmrider

    ktmrider [OP] Senior Member

    Joined:
    Jul 20, 2009
    Member:
    #19933
    Messages:
    5,102
    Gender:
    Male
    Vehicle:
    07 DCLB 4x4 Sport S/C
    Junk
    This is on my parents truck. It is a 2008 4.0 with 36k miles and a TRD supercharger. I installed the supercharger 26 days and 750 miles ago and it hasn't had a problem, but on friday when it was started the light came on and even when it was warm it was idling at 1200 and fluctuating between 1600 and 1200 like somebody was tapping the petal.

    P0171:System too Lean (Bank 1)
    P0174:System too Lean (Bank 2)

    I had it reflashed the day I installed it. Anybody have any ideas what to check or replace? I can interchange parts with my truck if needed.


    EDIT: I already cleaned the MAF and checked for leaks, so im at a loss.
     
  2. May 8, 2011 at 8:37 PM
    #2
    ktmrider

    ktmrider [OP] Senior Member

    Joined:
    Jul 20, 2009
    Member:
    #19933
    Messages:
    5,102
    Gender:
    Male
    Vehicle:
    07 DCLB 4x4 Sport S/C
    Junk
  3. May 11, 2011 at 8:10 PM
    #3
    ktmrider

    ktmrider [OP] Senior Member

    Joined:
    Jul 20, 2009
    Member:
    #19933
    Messages:
    5,102
    Gender:
    Male
    Vehicle:
    07 DCLB 4x4 Sport S/C
    Junk
    so the codes went away for a day and i thought the truck was running well, but today on inspection the codes are back and it started to misfire, blinking check engine light, so IDK. Im getting it towed to the dealership tomorrow.
     
  4. May 14, 2011 at 2:18 PM
    #4
    ktmrider

    ktmrider [OP] Senior Member

    Joined:
    Jul 20, 2009
    Member:
    #19933
    Messages:
    5,102
    Gender:
    Male
    Vehicle:
    07 DCLB 4x4 Sport S/C
    Junk
    Well if anybody searches for this the problem was a cracked injector seal.
     
To Top