1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

p0325 & p0330 woes.. again

Discussion in '1st Gen. Tacomas (1995-2004)' started by jacky_bubbles, Jun 12, 2013.

  1. Jun 12, 2013 at 9:07 PM
    #1
    jacky_bubbles

    jacky_bubbles [OP] Senior Lurker

    Joined:
    Apr 12, 2010
    Member:
    #35101
    Messages:
    77
    Gender:
    Male
    Victoria
    Vehicle:
    Supercharged 1997 Tacoma
    Hey TW

    About a month after dropping the Supercharger on my 3.4 I started getting the infamous p0330 code.. I went all out and replaced BOTH sensors AND the harness only to have the codes p0330 AND p0325 now come in pairs simultaneously immediately after...

    Should I...

    1. Install the URD 7th kit?

    2. Do the GM knock sensor mod?

    3. Hook up my Methanol Injection?

    4. Other

    I'd appreciate any input. I know this issue has many threads, but hopefully over the years we now have a surefire way to rid this amber CEL for good

    -Bubs
     
  2. Jun 12, 2013 at 9:18 PM
    #2
    cjimenRR

    cjimenRR Be Good or Be Good At It

    Joined:
    Jul 13, 2009
    Member:
    #19648
    Messages:
    811
    Gender:
    Male
    North Hollywood, Ca
    Vehicle:
    12' Sport DC,LB, 4x4
    Definitely start off by running a colder t-sat and maybe colder plugs. My 2nd step would be to invest into the 7th injector setup. You've obviously eliminated the sensors being the issue since the codes still come up
     
  3. Jun 12, 2013 at 9:19 PM
    #3
    cjimenRR

    cjimenRR Be Good or Be Good At It

    Joined:
    Jul 13, 2009
    Member:
    #19648
    Messages:
    811
    Gender:
    Male
    North Hollywood, Ca
    Vehicle:
    12' Sport DC,LB, 4x4
  4. Jun 12, 2013 at 10:00 PM
    #4
    jacky_bubbles

    jacky_bubbles [OP] Senior Lurker

    Joined:
    Apr 12, 2010
    Member:
    #35101
    Messages:
    77
    Gender:
    Male
    Victoria
    Vehicle:
    Supercharged 1997 Tacoma
    I should have mentioned I'm running the colder plugs and the cooler T-stat already. The 7th with it's ecu piggyback and larger fuel pump are not installed yet though.. think it'll do the trick?!

    thanks RR for the sale link and info

    -Bubs
     
  5. Jun 14, 2013 at 10:43 AM
    #5
    jacky_bubbles

    jacky_bubbles [OP] Senior Lurker

    Joined:
    Apr 12, 2010
    Member:
    #35101
    Messages:
    77
    Gender:
    Male
    Victoria
    Vehicle:
    Supercharged 1997 Tacoma
    bump for another opinion or two
     
  6. Jul 13, 2013 at 11:27 AM
    #6
    jacky_bubbles

    jacky_bubbles [OP] Senior Lurker

    Joined:
    Apr 12, 2010
    Member:
    #35101
    Messages:
    77
    Gender:
    Male
    Victoria
    Vehicle:
    Supercharged 1997 Tacoma
    Anyone done the GM knock sensor mod in this case?!
     
  7. Dec 10, 2014 at 8:05 AM
    #7
    crisbert

    crisbert New Member

    Joined:
    Dec 10, 2014
    Member:
    #144009
    Messages:
    2
    Gender:
    Male
    Hey I am having this exact same problem with my Toyota. Shortly after I installed my supercharger I threw the knock code. I replaced both of the knock sensors and the harness going to the wires. Needless to say, after all that work the code came back, but this time with a companion, the p0300 code. I am at a loss for what to do now and was wondering if you where able to get your code fixed, and if so how.
    Thanks
     
  8. Feb 1, 2015 at 3:42 PM
    #8
    bigbird05

    bigbird05 New Member

    Joined:
    Feb 1, 2015
    Member:
    #147674
    Messages:
    1
    Gender:
    Male
    Chattanooga
    Vehicle:
    97 SR5 Supercharged
    I am having a similar problem. I have replaced the knock sensor and the harness's but then the dreaded p0330 code came on again after about a month. It seems like the code only wants to trip in overdrive at low rpm's any help on what to check/do, Im all out of thoughts. O and I already have the 7th injector from urd and colder denso plugs and the upgraded fuel pump.
     
  9. Mar 12, 2015 at 9:26 PM
    #9
    mikenblue

    mikenblue Member

    Joined:
    Dec 1, 2014
    Member:
    #143469
    Messages:
    20
    Gender:
    Male
    First Name:
    Mike
    College Station, TX
    Thrush Muffler Doug Thorley Headers Deckplate Mod w/ Airaid intake tube and AFE filter OME Lift kit
    bump i have a similar issue. replace both sensors and harness but still have p0330 code. i have the supercharger in with supra injectors, 250lph fuel pump, no piggyback yet
     
  10. Aug 27, 2015 at 12:39 PM
    #10
    GioGuitarDude

    GioGuitarDude Well-Known Member

    Joined:
    Jun 18, 2013
    Member:
    #106509
    Messages:
    739
    Gender:
    Male
    First Name:
    Gio
    Vehicle:
    96 TURBOCHARGED 5 speed X-cab 3.4 DLX tacoma
    Cold air intake
    Lol guys... does anyone have an answer to this problem? I'm about two fits of rage away from hooking both sensor leads to a single GM sensor screwed to the head somewhere and call it good.
    I replaced both sensors and the pigtail and was EXTREMELY careful not to damage or pinch the wires in any way and I STILL got the codes after I put it together.
    "Help, I need somebody! Help, not just anybody!" :)
     
  11. Sep 20, 2015 at 7:45 PM
    #11
    RAT PRODUCTS

    RAT PRODUCTS RAT Products

    Joined:
    Apr 12, 2010
    Member:
    #35140
    Messages:
    13,699
    Gender:
    Male
    First Name:
    Ryan
    Farmington, MN
    Vehicle:
    01 CUMTOY and 16 Sierra Denali
    View the build. Too much to list.
    My truck does this too after getting supercharged. I tried new sensors, wiring harness, and even an ecu. Nothing has helped. I'm not sure what else to do without dropping lots of money on spare parts.
     
  12. Oct 13, 2015 at 10:44 AM
    #12
    Dixin

    Dixin New Member

    Joined:
    Oct 13, 2015
    Member:
    #166562
    Messages:
    1
    Gender:
    Male
    Knock sensors issue... I have replaced both sensors and the wiring harness twice, I ran all the tests from sensors connections to the ECU which all checked out good. I have ordered a second ECU to see if that is the problem.(will repost once i try new ecu) The supercharger has been on for about 89,000km however i have only been owned it for the last 10,000km and this is the first time i have seen P0325 & P0330.

    I had a second wiring harness and 2 extra knock sensors so I plugged them in and had them strapped over to the side of the engine bay so they could not touch anything and i got the exact same 2 codes...

    Anyone have a fix yet?
     
  13. Oct 13, 2015 at 7:27 PM
    #13
    RAT PRODUCTS

    RAT PRODUCTS RAT Products

    Joined:
    Apr 12, 2010
    Member:
    #35140
    Messages:
    13,699
    Gender:
    Male
    First Name:
    Ryan
    Farmington, MN
    Vehicle:
    01 CUMTOY and 16 Sierra Denali
    View the build. Too much to list.
    Someone suggested I try a new mass airflow sensor, but I don't know why that would help. New spark plugs didn't help either.
     
  14. Apr 10, 2016 at 10:07 AM
    #14
    1997tacomav6

    1997tacomav6 Well-Known Member

    Joined:
    Oct 5, 2013
    Member:
    #113940
    Messages:
    235
    Gender:
    Male
    First Name:
    John
    Denver
    Vehicle:
    97 regcabv6 300hp supercharged 500,000 plus miles
    V6 5sp,RegCab,TRD Supercharger, Aftermarket AC, TRD supercharger,(MUST DO) rebuilt 3 times over 500,000 miles, every 150,000 needs rebuild Hella H4 German Rated Headlights HID 55 watt bulbs (MUST DO) 5 speed manual Amsoil for all drive train Smaller 2.1" supergrip pulley,(300hp) (MUST DO) 2004 DESNO fuel injectors, zero ping ping, 2004 side door mirrors Dick Cepek Rims, Michelin tires LTX, ( that last 100,000 miles) KN cold air intake Cat back exhaust with ss exhaust tip, Raised exhaust tail pipe to 2" below body line Optima*dry cell battery,red top Alpine sirius radio, 200 watt amp, focal is165 split pod speakers Focal door speakers Subwoffer behind seat Viper alarm, Electric Locks Dark tinted windows, 4 runner bucket seats, Tacoma Rubber floor mats TRD fender extenders, Bilstien shocks Bed liner chrome push bar, chrome nerf bars, add a leaf for rear springs trailer iv hitch, electric brake control, Drilled slotted brakes, 3500 Grade steel(MUST DO) EBS green stuff 7000 series pads(MUST DO) TRD engine oil cap TRD stick shift, Rear sliding window 2002 4Runner functional hood scoop cut into Tacoma hood, coming soon!
    So I'm having same problem after the supercharger was rebuilt and installed, anyone have a link, or photos, for the GM swap knock sensor installation? Or part number for GM sensor??
     
  15. May 17, 2016 at 6:18 AM
    #15
    1997tacomav6

    1997tacomav6 Well-Known Member

    Joined:
    Oct 5, 2013
    Member:
    #113940
    Messages:
    235
    Gender:
    Male
    First Name:
    John
    Denver
    Vehicle:
    97 regcabv6 300hp supercharged 500,000 plus miles
    V6 5sp,RegCab,TRD Supercharger, Aftermarket AC, TRD supercharger,(MUST DO) rebuilt 3 times over 500,000 miles, every 150,000 needs rebuild Hella H4 German Rated Headlights HID 55 watt bulbs (MUST DO) 5 speed manual Amsoil for all drive train Smaller 2.1" supergrip pulley,(300hp) (MUST DO) 2004 DESNO fuel injectors, zero ping ping, 2004 side door mirrors Dick Cepek Rims, Michelin tires LTX, ( that last 100,000 miles) KN cold air intake Cat back exhaust with ss exhaust tip, Raised exhaust tail pipe to 2" below body line Optima*dry cell battery,red top Alpine sirius radio, 200 watt amp, focal is165 split pod speakers Focal door speakers Subwoffer behind seat Viper alarm, Electric Locks Dark tinted windows, 4 runner bucket seats, Tacoma Rubber floor mats TRD fender extenders, Bilstien shocks Bed liner chrome push bar, chrome nerf bars, add a leaf for rear springs trailer iv hitch, electric brake control, Drilled slotted brakes, 3500 Grade steel(MUST DO) EBS green stuff 7000 series pads(MUST DO) TRD engine oil cap TRD stick shift, Rear sliding window 2002 4Runner functional hood scoop cut into Tacoma hood, coming soon!
    Well got the new DESNO knock sensors off eBay for 85.00 for the pair
    and installed and running great again, the dealer wanted 250 each,
     
To Top