1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

p0325 & p0330 woes.. again

Discussion in '1st Gen. Tacomas' started by jacky_bubbles, Jun 12, 2013.

  1. jacky_bubbles

    jacky_bubbles [OP] Senior Lurker

    Joined:
    Apr 12, 2010
    Member:
    #35101
    Messages:
    77
    Gender:
    Male
    Victoria
    Vehicle:
    Supercharged 1997 Tacoma
    Hey TW

    About a month after dropping the Supercharger on my 3.4 I started getting the infamous p0330 code.. I went all out and replaced BOTH sensors AND the harness only to have the codes p0330 AND p0325 now come in pairs simultaneously immediately after...

    Should I...

    1. Install the URD 7th kit?

    2. Do the GM knock sensor mod?

    3. Hook up my Methanol Injection?

    4. Other

    I'd appreciate any input. I know this issue has many threads, but hopefully over the years we now have a surefire way to rid this amber CEL for good

    -Bubs
     
  2. cjimenRR

    cjimenRR Be Good or Be Good At It

    Joined:
    Jul 13, 2009
    Member:
    #19648
    Messages:
    816
    Gender:
    Male
    North Hollywood, Ca
    Vehicle:
    12' Sport DC,LB, 4x4
    Definitely start off by running a colder t-sat and maybe colder plugs. My 2nd step would be to invest into the 7th injector setup. You've obviously eliminated the sensors being the issue since the codes still come up
     
  3. cjimenRR

    cjimenRR Be Good or Be Good At It

    Joined:
    Jul 13, 2009
    Member:
    #19648
    Messages:
    816
    Gender:
    Male
    North Hollywood, Ca
    Vehicle:
    12' Sport DC,LB, 4x4
  4. jacky_bubbles

    jacky_bubbles [OP] Senior Lurker

    Joined:
    Apr 12, 2010
    Member:
    #35101
    Messages:
    77
    Gender:
    Male
    Victoria
    Vehicle:
    Supercharged 1997 Tacoma
    I should have mentioned I'm running the colder plugs and the cooler T-stat already. The 7th with it's ecu piggyback and larger fuel pump are not installed yet though.. think it'll do the trick?!

    thanks RR for the sale link and info

    -Bubs
     
  5. jacky_bubbles

    jacky_bubbles [OP] Senior Lurker

    Joined:
    Apr 12, 2010
    Member:
    #35101
    Messages:
    77
    Gender:
    Male
    Victoria
    Vehicle:
    Supercharged 1997 Tacoma
    bump for another opinion or two
     
  6. jacky_bubbles

    jacky_bubbles [OP] Senior Lurker

    Joined:
    Apr 12, 2010
    Member:
    #35101
    Messages:
    77
    Gender:
    Male
    Victoria
    Vehicle:
    Supercharged 1997 Tacoma
    Anyone done the GM knock sensor mod in this case?!
     
  7. crisbert

    crisbert New Member

    Joined:
    Dec 10, 2014
    Member:
    #144009
    Messages:
    1
    Gender:
    Male
    Hey I am having this exact same problem with my Toyota. Shortly after I installed my supercharger I threw the knock code. I replaced both of the knock sensors and the harness going to the wires. Needless to say, after all that work the code came back, but this time with a companion, the p0300 code. I am at a loss for what to do now and was wondering if you where able to get your code fixed, and if so how.
    Thanks
     
  8. bigbird05

    bigbird05 New Member

    Joined:
    Feb 1, 2015
    Member:
    #147674
    Messages:
    1
    Gender:
    Male
    Chattanooga
    Vehicle:
    97 SR5 Supercharged
    I am having a similar problem. I have replaced the knock sensor and the harness's but then the dreaded p0330 code came on again after about a month. It seems like the code only wants to trip in overdrive at low rpm's any help on what to check/do, Im all out of thoughts. O and I already have the 7th injector from urd and colder denso plugs and the upgraded fuel pump.
     
  9. mikenblue

    mikenblue Member

    Joined:
    Dec 1, 2014
    Member:
    #143469
    Messages:
    20
    Gender:
    Male
    First Name:
    Mike
    College Station, TX
    Thrush Muffler Doug Thorley Headers Deckplate Mod w/ Airaid intake tube and AFE filter OME Lift kit
    bump i have a similar issue. replace both sensors and harness but still have p0330 code. i have the supercharger in with supra injectors, 250lph fuel pump, no piggyback yet
     
To Top