1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

P3 brake controller?

Discussion in 'Towing' started by Kelly6773, Sep 4, 2018.

  1. Sep 4, 2018 at 4:16 PM
    #1
    Kelly6773

    Kelly6773 [OP] Well-Known Member

    Joined:
    Mar 27, 2017
    Member:
    #214543
    Messages:
    301
    Gender:
    Male
    First Name:
    Bob
    SC
    Vehicle:
    18 TRD sport DCLB
    i just installed it in my 18 sport. Hooked everything up but noticed the screen stays lite up. Truck off and locked. Nothing hooked up. Is this normal? I would of guessed the screen went dark with the truck off. I used the adaptor wiring harness to connect it to the truck.
    I went back out to the truck about an hour later and it was off. Assuming the truck killed power to it. Not sure. Thought it would have went off with ignition.
     
    Last edited: Sep 4, 2018
  2. Sep 4, 2018 at 10:52 PM
    #2
    locster

    locster Well-Known Member

    Joined:
    Jul 10, 2014
    Member:
    #133656
    Messages:
    951
    Gender:
    Male
    First Name:
    Luke
    Orange County, CA
    Vehicle:
    2014 DCSB 4x4
    Mine does the same.
     
  3. Sep 5, 2018 at 2:43 AM
    #3
    Kelly6773

    Kelly6773 [OP] Well-Known Member

    Joined:
    Mar 27, 2017
    Member:
    #214543
    Messages:
    301
    Gender:
    Male
    First Name:
    Bob
    SC
    Vehicle:
    18 TRD sport DCLB
    Thanks. Just wanted varification that some one else’s did the same!
     
  4. Sep 15, 2018 at 6:11 PM
    #4
    Steve721

    Steve721 Well-Known Member

    Joined:
    Oct 11, 2016
    Member:
    #199520
    Messages:
    71
    Gender:
    Male
    First Name:
    Steve
    Boston
    Vehicle:
    2009 Speedway Blue, TRD Sport
    I also have the P3. In the manual, it says it will shut off after 15 minutes. Mine shuts off in about that time frame.
     
  5. Oct 8, 2018 at 11:00 AM
    #5
    RedRover2

    RedRover2 New Member

    Joined:
    Sep 5, 2018
    Member:
    #265312
    Messages:
    3
    Gender:
    Male
    Vehicle:
    Barcelona Red 2018 SR5
    None
    New to Tacoma World. I tried to make a new thread but was unsuccessful so am tagging onto yours. Please forgive.

    2018 Tacoma SR5 4x4 with the 'Tow Package'. My Tacoma window sticker does not show 'Tow Package' but does have all the items that equal a 'Tow Package'.

    I have completed installing my Tekonsha P3 90195 into the coin pocket location, left of steering wheel, using the using the Electric Trailer Brake Control Wiring Adapter, Tekonsha 'OEM Wiring Harness' 3031-P.

    I have read on this forum and on You Tube that with the Tow Package and the items above is 'Plug and Play' but my P3 does not power up. There is no voltage at the Toyota installed harness connector behind the LH kick panel.
    I have searched for fuses and found the towing related fuses to be good. I have powered my P3 up by connecting it directly to battery using a harness 3017-P I have, so it does power up.

    I have just returned from dealer and been told that just because the truck has the Tow Package wire harness does not mean there should be power at the connector because the Tacoma's do not have Electric Brake Controller's installed so no power is required at the connector and the truck is as designed. Make appointment and we will troubleshoot it.

    Has anyone else encountered this problem with their 2018 and how is it corrected? What have I missed?
     
  6. Oct 8, 2018 at 2:29 PM
    #6
    Ck1010

    Ck1010 Well-Known Member

    Joined:
    Jul 27, 2018
    Member:
    #260764
    Messages:
    341
    Gender:
    Male
    Ohio
    Vehicle:
    ‘18 TRD Sport 4x4 M6
    Did you have it grounded correctly?
     
  7. Oct 8, 2018 at 3:29 PM
    #7
    Indy

    Indy Master of all I survey.

    Joined:
    Sep 15, 2013
    Member:
    #112518
    Messages:
    2,578
    Gender:
    Male
    No direct taco help but the last truck i had with factory trailer wiring still required a couple pieces to be functional. There was a pigtail to attach the controller to the truck and then a relay or fuse that had to go into the fuse box to get power to the plug.

    I don't recall if it was a fuse or relay but they were bagged up and not installed by the factory, just came with the truck.

    Regardless, your first box should have at least 1 dedicated circuit they should have a fuse in it.
     
    Last edited: Oct 8, 2018
  8. Oct 8, 2018 at 6:16 PM
    #8
    RedRover2

    RedRover2 New Member

    Joined:
    Sep 5, 2018
    Member:
    #265312
    Messages:
    3
    Gender:
    Male
    Vehicle:
    Barcelona Red 2018 SR5
    None
    C-1011: All the grounding I am responsible for per the controller install instructions are complete and tested by my multi-meter as good.

    Indy: I have not seen an included bag of fuses or relays at delivery. But since you spoke 'dedicated fuse' I checked again and found the engine compartment has a fuse box with one 40 AMP named TOW BRK No 1 and found it burned out. I replaced it, checked the voltage with my multi-meter and found 12 volts. The P3 controller powered up immediately when attached even though the ignition key was removed and remains on. Others have mentioned it remains on when key is removed but turns itself off after approximately 15 minutes. I am waiting and watching.

    I am the original owner and never towed with truck or messed with electrical system. Begs the question, why was this fuse burned out.

    Just checked and the P3 controller has powered down. Next thing to do is program it for a medium sized camp trailer and find one.

    Thanks for your replies.
     
  9. Oct 8, 2018 at 7:01 PM
    #9
    Steve721

    Steve721 Well-Known Member

    Joined:
    Oct 11, 2016
    Member:
    #199520
    Messages:
    71
    Gender:
    Male
    First Name:
    Steve
    Boston
    Vehicle:
    2009 Speedway Blue, TRD Sport
    You're doing fine. The hardest thing I had was finding the plug. Bloodied hand, but I got it. It was live from the moment I found it. Guess I had the relay/fuse in place.
     

Products Discussed in

To Top