1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Part Number A/F sensor and O2 sensor

Discussion in '1st Gen. Tacomas' started by derekp, Apr 6, 2010.

  1. Apr 6, 2010 at 4:07 PM
    #1
    derekp

    derekp [OP] giddy up!

    Joined:
    May 16, 2009
    Member:
    #17281
    Messages:
    439
    Gender:
    Male
    First Name:
    Derek
    Grand Forks, ND
    Vehicle:
    2001 X-Cab 4x4 TRD V6 5Spd
    Deck plate, Flowmaster Delta-Flow 40 series, 265/75-16 Wrangler TDs, more to come...
    I have scanned the threads related to P1135 and have figured out that my issue is the A/F sensor (aka front O2 sensor) located in front of the cat. The threads also cover how to change the sensor, it looks fairly easy except finding the end of the wire. The one thing I couldn't find was the part numbers to order the correct sensors! I have a 2001 V6 4wd. I am not sure if I need Denso 234-9002 or 234-9003 for the front sensor. The back is 234-4189, I think. Does anyone know for sure? The 9003 is $130.21 at Amazon, the 9002 is $135.08 and the 4189 is $73.49. I want to make sure I am getting the right parts since I am buying over $200 worth of parts online. Thanks y'all!
     
  2. Apr 7, 2010 at 4:24 AM
    #2
    derekp

    derekp [OP] giddy up!

    Joined:
    May 16, 2009
    Member:
    #17281
    Messages:
    439
    Gender:
    Male
    First Name:
    Derek
    Grand Forks, ND
    Vehicle:
    2001 X-Cab 4x4 TRD V6 5Spd
    Deck plate, Flowmaster Delta-Flow 40 series, 265/75-16 Wrangler TDs, more to come...
    Anyone changed the sensors on a 2001 and up???
     
  3. Apr 7, 2010 at 5:29 AM
    #3
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,248
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
  4. Apr 7, 2010 at 10:23 AM
    #4
    derekp

    derekp [OP] giddy up!

    Joined:
    May 16, 2009
    Member:
    #17281
    Messages:
    439
    Gender:
    Male
    First Name:
    Derek
    Grand Forks, ND
    Vehicle:
    2001 X-Cab 4x4 TRD V6 5Spd
    Deck plate, Flowmaster Delta-Flow 40 series, 265/75-16 Wrangler TDs, more to come...
    Thanks dude!!! I need the manual version and can get both on Amazon for $203.70. Hope it fixes my P1135. The check engine light is on sometimes and off sometimes. Makes me wonder if it is a loose wire but after 123k miles I might need to replace them anyway. Thoughts?
     
  5. Apr 7, 2010 at 10:34 AM
    #5
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,248
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
To Top