1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

pinging noise on new dc

Discussion in '2nd Gen. Tacomas (2005-2015)' started by snowtaco2, Oct 22, 2011.

  1. Oct 22, 2011 at 12:50 PM
    #1
    snowtaco2

    snowtaco2 [OP] Member

    Joined:
    Sep 26, 2011
    Member:
    #64172
    Messages:
    20
    Gender:
    Male
    First Name:
    Nobody
    Middle Of USA
    Vehicle:
    2011 T|X pro
    Billies, 885x, alcans, custom highlift mount
    I have a new dc 3600 miles on it and at lower rpm's it sounds like its pinging my 08 never sounded like this ive tried prem no diffrance. dose anybody else have this problem? I asked the dealer thay said it just sounds diffrent because of my trd exhaust I think there full of bs any advise would be great.
     
  2. Oct 22, 2011 at 1:44 PM
    #2
    west467

    west467 Well-Known Member

    Joined:
    Jan 7, 2009
    Member:
    #12340
    Messages:
    45
    Gender:
    Male
    Vehicle:
    Two Black Tacos..03 and 09
    My 2009 DC v6 had a pinging noise when new. I have 45,000 miles now, I think it's gone now, or I have gotten used to it. I would not worry about it.

    My truck would also pings on acceleration, EXXON 87 gas solved that.

    Enjoy your truck, they are great!
     
To Top