1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Pioneer Carplay

Discussion in 'Audio & Video' started by jv_74, Feb 22, 2018.

  1. Feb 22, 2018 at 5:49 AM
    #1
    jv_74

    jv_74 [OP] Well-Known Member

    Joined:
    Dec 7, 2016
    Member:
    #204258
    Messages:
    360
    Gender:
    Male
    First Name:
    Jesse
    Filthadelphia
    Vehicle:
    2015 DCSB Silver Sky Metallic
    I've always had good experiences with Pioneer stuff, but this carplay crap is really making me hate them. I have a AVH-1330 installed and carplay functionality just sucks. The connectivity is always an issue and sometimes it even drops off in the middle of doing something. And I'm just talking about the Carplay portion, don't get me started on Pioneer's Appradio crap. That literally has not worked once through my phone since the day I installed the HU.

    Seems to be iOS updates are the big issue as Pioneer has no indication they want to update their firmware.

    I can't find anything on the internet related to Pioneer's carplay compatability with the new iOS since September of 17. Even that article just says "they vow to work on the compatability issues"

    Anyone else having trouble with Pioneer/iOS/Carplay? Am I missing something here?

    I've had the 1330 for about 5 months and have been waiting for these firmware updates since then. I want to throw this thing out the window. Should have gone Kenwood!!!
     
  2. Feb 22, 2018 at 12:10 PM
    #2
    Do58

    Do58 Well-Known Member

    Joined:
    Oct 11, 2015
    Member:
    #166373
    Messages:
    587
    Gender:
    Male
    Vehicle:
    2015 white tacoma limited
    if your going to throw it out, then ill take it. granted that is the entry level unit that supports carplay, but its a great stereo. before people chime in and say its bad or yeah kenwwod is great blah blah, you need to know that you could be an isolated case. ALL brands have their problems. I have been installing professionally for 23 yrs and have seen it EVERYWHERE. I have installed hundreds of that particular model alone. as for the carplay functionality being "crap".... what does that mean? carplay is carplay.... be thankful your not android trying to use AA.
    why are you mad when it didn't work from day 1 that you thought it was good to keep the unit?
    not being a dick but just trying to understand what your problems are to maybe try to help.
    what version is your stereo? don't say most current.... give me a number
    what cable are you using from usb to the phone
    what cable do you have installed and using between the stereo and the phone ( are you using fact usb or pioneer usb extension etc. )
    try a reset on phone
    these are some questions that maybe I can help you with
     
  3. Feb 22, 2018 at 12:37 PM
    #3
    jv_74

    jv_74 [OP] Well-Known Member

    Joined:
    Dec 7, 2016
    Member:
    #204258
    Messages:
    360
    Gender:
    Male
    First Name:
    Jesse
    Filthadelphia
    Vehicle:
    2015 DCSB Silver Sky Metallic
    I certainly don't take this as being a dick, I appreciate the response! I have also installed about a dozen HU's in a dozen different vehicles, so while I may not have 23 years of pro experience I'd hope I know more than the average person by now... I will say this was one of the more complicated installs I've done, getting factory steering wheel and backup camera working was trickier than a lot of other vehicles. Some answers to your questions:

    -I was just referring to the AppRadio not working since day 1. I read that Pioneer was working on the issue and that it was just with the new iOS, that's why I've kept it. You're right, the stereo is AWESOME sound wise. I've got it hooked up to a kicker 2ch driving kicker component front speakers, and a JL mono driving a kicker sub behind the seats. I don't know that I've had a better stereo in any of my previous vehicles sound-wise.
    -Cable from phone is standard Apple lightening, not some cheapo knock off.
    -Used the metra cable to link the stereo's USB and the taco's factory USB port.
    -I have reset the phone and stereo several times.
    -Worth noting, I have the Maestro RR installed with the TO1 harness.

    I've always preferred Pioneer to Kenwood. This is my first bad Pioneer experience.

    I will update with the version next time I'm out in the truck. Thanks again!
     
  4. Feb 22, 2018 at 3:39 PM
    #4
    Purpleman

    Purpleman Well-Known Member

    Joined:
    Aug 13, 2014
    Member:
    #136093
    Messages:
    490
    Gender:
    Male
    Anaheim
    Vehicle:
    15 PreRunner
    FYI Kenwoods also having issues with Carplay.
     
  5. Feb 22, 2018 at 7:23 PM
    #5
    Do58

    Do58 Well-Known Member

    Joined:
    Oct 11, 2015
    Member:
    #166373
    Messages:
    587
    Gender:
    Male
    Vehicle:
    2015 white tacoma limited
    Looks like a lot of it has to do with iPhone iOS 11.2.5. I have seen intermittent problems on some units that are with current nex units 8.26. Opened up a new unit that had 8.28 firmware and worked. Could have been a fluke it worked but then was surprised of the firmware version. Looked on pioneers website and that version didn’t exist. Don’t know
     
    jv_74 [OP] likes this.
  6. Feb 22, 2018 at 9:16 PM
    #6
    Raincity

    Raincity Half man, half amazing.

    Joined:
    Feb 4, 2015
    Member:
    #147924
    Messages:
    187
    Gender:
    Male
    Lowermainland, B.C.
    Vehicle:
    '13 Mica Spruce DC.
    '12 DC TRD-RIP
    Disappointing to hear and looking to see if you sort the issues out. I too like Pioneer HU's and have always had them in the past. I also like CarPlay features when I had it in my OEM VW HU, the integration between phone and HU was great.
     
  7. Feb 23, 2018 at 5:15 AM
    #7
    Do58

    Do58 Well-Known Member

    Joined:
    Oct 11, 2015
    Member:
    #166373
    Messages:
    587
    Gender:
    Male
    Vehicle:
    2015 white tacoma limited
    Just saw where there is an iOS update that is now 11.2.6
    1 thing it says is “fixes an issue where some third party apps could fail to connect to external accessories”
    Don’t know if this could help BUT I was rocking 11.2.5 and having trouble sometimes with my display units and also customers new units. Worth the try as it can’t get worse. Off today so I’ll try tomorrow unless someone sees that MAYBE it would help.
     
  8. Feb 23, 2018 at 10:02 AM
    #8
    jv_74

    jv_74 [OP] Well-Known Member

    Joined:
    Dec 7, 2016
    Member:
    #204258
    Messages:
    360
    Gender:
    Male
    First Name:
    Jesse
    Filthadelphia
    Vehicle:
    2015 DCSB Silver Sky Metallic
    Just got this on my phone as well...here's to hoping.

    This seems to be par for the course with Pioneer regarding iOS and compatibility. None of it makes any sense!!! They just say "we're working on it".

    Is there an actual way to update the firmware on these HU's if needed? I forgot to look at what version I have yesterday...
     
  9. Feb 23, 2018 at 10:20 AM
    #9
    Do58

    Do58 Well-Known Member

    Joined:
    Oct 11, 2015
    Member:
    #166373
    Messages:
    587
    Gender:
    Male
    Vehicle:
    2015 white tacoma limited
    Yes via usb. Go to pioneers website, click on support, type in model number and then there will be instructions for how to load and install. As of 2 days ago the proper firmware was 8.26. You can look on your hd unit by going to the gears then wrench then scroll to the bottom for system information.

    You have to remember yes you need to be current BUT the hd unit doesn’t change it’s usually 9/10 times the app ( Spotify pandora etc. ) or the iOS. They have to correct it not the manufacture
     
  10. Feb 23, 2018 at 11:12 AM
    #10
    jv_74

    jv_74 [OP] Well-Known Member

    Joined:
    Dec 7, 2016
    Member:
    #204258
    Messages:
    360
    Gender:
    Male
    First Name:
    Jesse
    Filthadelphia
    Vehicle:
    2015 DCSB Silver Sky Metallic
    Understood, and the info is appreciated @Do58
     
  11. Mar 3, 2018 at 7:03 AM
    #11
    Do58

    Do58 Well-Known Member

    Joined:
    Oct 11, 2015
    Member:
    #166373
    Messages:
    587
    Gender:
    Male
    Vehicle:
    2015 white tacoma limited
    if you have ANY of the new NEX models... ( 1300 1330 2300 2330 3300 ect. ) there IS a new update to fix issues with carplay and eq. 8.32 is the current version
     
  12. Mar 6, 2018 at 5:18 AM
    #12
    jv_74

    jv_74 [OP] Well-Known Member

    Joined:
    Dec 7, 2016
    Member:
    #204258
    Messages:
    360
    Gender:
    Male
    First Name:
    Jesse
    Filthadelphia
    Vehicle:
    2015 DCSB Silver Sky Metallic
    Thank you! Good news!
     

Products Discussed in

To Top