1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

poor engine performance

Discussion in 'Performance and Tuning' started by nikita23, Feb 4, 2011.

  1. Feb 4, 2011 at 4:02 PM
    #1
    nikita23

    nikita23 [OP] Member

    Joined:
    Jul 13, 2007
    Member:
    #2078
    Messages:
    8
    Gender:
    Male
    California
    Vehicle:
    07 PreRunner SR5
    I wonder if anyone can help me to determine what's going on with my 07 taco. It feels like can't accelerate quick enough and it takes longer time to reach the 65mph. I replaced the spark plugs, the engine oil, the air filter, and still the same. Any suggestions?

    Thank you so much.

    Nikita 23
     
  2. Feb 14, 2011 at 3:03 AM
    #2
    nikita23

    nikita23 [OP] Member

    Joined:
    Jul 13, 2007
    Member:
    #2078
    Messages:
    8
    Gender:
    Male
    California
    Vehicle:
    07 PreRunner SR5
    Thank you for Pogiboy, Did you have your truck serviced at a dealer, or you did it yourself? I just don't want to be ripped knowing nothing about the costs.

    Thank you.


    Nikita23
     
  3. Feb 25, 2011 at 8:58 PM
    #3
    buickregal1987

    buickregal1987 Member

    Joined:
    Sep 26, 2010
    Member:
    #43844
    Messages:
    11
    Gender:
    Male
    thousand oaks ca
    Vehicle:
    08 prerunner sr5 sport
    do u use 91 octane gas? try use only gas from 76 is the best
     
To Top