1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Power steering fluid compatibility...

Discussion in '2nd Gen. Tacomas (2005-2015)' started by ashjwilliams, Dec 16, 2011.

  1. Dec 16, 2011 at 2:13 PM
    #1
    ashjwilliams

    ashjwilliams [OP] Well-Known Member

    Joined:
    Oct 9, 2009
    Member:
    #24028
    Messages:
    168
    Gender:
    Male
    So my power steering fluid is way low on a 2010 standard bed, dbl cab, 4x4, 4.0 Liter V6, 5 speed auto Tacoma with 30,000 miles.

    First any insight regarding why this would be? I have put 100,000's of miles on other vehicles and never had any appreciable power steering fluid consumption/loss.

    Haynes manual states my 2010 Tacoma takes DEXRON II or DEXRON III ATF for power steering fluid. Is this what it comes with from the factory though? I just happened to notice that the fluid is tan/brown versus the typical ATF red...wondering if the DEXRON III ATF I picked is compatible with the existing fluid. Don't really want to flush/replace entirely...
     
  2. Dec 16, 2011 at 2:14 PM
    #2
    ashjwilliams

    ashjwilliams [OP] Well-Known Member

    Joined:
    Oct 9, 2009
    Member:
    #24028
    Messages:
    168
    Gender:
    Male
    Thanks for any insight.
     
  3. Dec 18, 2011 at 8:40 AM
    #3
    ashjwilliams

    ashjwilliams [OP] Well-Known Member

    Joined:
    Oct 9, 2009
    Member:
    #24028
    Messages:
    168
    Gender:
    Male
  4. Dec 18, 2011 at 12:06 PM
    #4
    MassTaco

    MassTaco Well-Known Member

    Joined:
    Apr 24, 2009
    Member:
    #16384
    Messages:
    177
    Gender:
    Male
    Massachusetts
    Vehicle:
    V6 4x4 SR5 DC AT5
    If it's low, you've got a leak. As simple as that. As far as compatibility the ATF will mix with whatever Toyota puts in there (most likely ATF without red dye).

    Since you're at 30k Toyota should fix any power steering leaks under warranty.

    Good luck!
     
  5. Dec 19, 2011 at 1:04 AM
    #5
    Texoma

    Texoma Well-Known Member

    Joined:
    Feb 1, 2011
    Member:
    #50374
    Messages:
    5,425
    Gender:
    Male
    First Name:
    Chris(Topher)
    Lago Vista, TX
    Vehicle:
    10 Taco 4x4
    Poweraid TB spacer, a bunch a cool stickers, a bada ass MetalMiller Tx Longhorns grill emblem painted Hemi Orange, JBA 2035s headers and dey are perty, Diff breather mod, Red LED interior lights, Fancy head unit that plays ipod n movies, Also DIY install factory stuff like, factory cruise control, factory intermittent wipers, OME nitro struts with 886x springs and toy tec top plate, LR UCA's for better alignmnet and dey beefier too, Old Man Emu Dakar leaf springs in da rear with the gear, U bolt flipper, 5 factory 16" steels wit Pep Boys special Dakota Definity MT's in 285/75/16, some bad ass weather tech floor liners so I don't muck up my interior, an ATO shackle flipper for mo travel in da rear wit the gear, also super shiny Fox 2.0 shocks back there too, all sorts of steal armor for bouncing off of the rocks like demello sliders, AP front skid, trans skid, n transfer skid, demello gas tank skid, and a tough as nails ARB bumper with warn 8k winch, I'm sure there's more but it's alre
    Use dexron III or better in your P/S resovoir. Should say that on the P/S cap and also in the owners manual. Check the suction and discharge lines for leaks and also around the rack. If no leaks, it may be because it is colder out and the fluid isn't expanding like in warmer temps. Just make sure that when the truck has been sitting cold, that the level is within the cold range lines in the resovoir so that the pump will have positive suction head. Ya don't want to get air in the system.
     
  6. Dec 19, 2011 at 3:20 PM
    #6
    ashjwilliams

    ashjwilliams [OP] Well-Known Member

    Joined:
    Oct 9, 2009
    Member:
    #24028
    Messages:
    168
    Gender:
    Male
    I put some ATF Dexron III in it today. It was so low that in the hot condition the level was at the cold low line.

    Thanks for the insight. I will keep an eye on it. Oddly enough I noticed it was low about 2 weeks ago but haven't observed it getting any lower. Now that I have established a known level I will keep an eye on it.
     
To Top