1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Problems with 08s

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Grey Jay, Oct 11, 2010.

  1. Oct 11, 2010 at 1:40 PM
    #1
    Grey Jay

    Grey Jay [OP] Well-Known Member

    Joined:
    Aug 6, 2009
    Member:
    #20735
    Messages:
    70
    Gender:
    Male
    Sudbury ON Canada
    Vehicle:
    08 TRD
    Hi,

    Just bought a Canadian 2008 DC TRD for $31K plus tax. Yikes! It has 42000 km on it so far. Upon close inspection (after the fact), it looks like it was used hard. Maybe not as hard as I would have used if for the first few years, but definately hard.

    Does anyone have a list of known problems for this model year? Nothing is obvious yet, aside from some jitters and vibration taking off from a light but I think I read something about that on here once.

    Thanks a lot,

    Kris
     
  2. Oct 11, 2010 at 2:24 PM
    #2
    Dadic 78

    Dadic 78 Well-Known Member

    Joined:
    Sep 16, 2010
    Member:
    #43373
    Messages:
    453
    Gender:
    Male
    First Name:
    Fil
    Edmonton, AB CANADA
    Vehicle:
    08 Double cab TRD
    Just check the TSB's on this site, and you'll find lots of useful info for your '08. Problems seem to be "hit or miss" with these rigs. Some guys have rear suspension issues, I've had none. My clutch pedal squeaks like a bastard, but my friend's '08 does not... It's all about what issues (if any) your particular rig has.

    Check the TSB's for your car to help identify potential issues.
     
  3. Oct 12, 2010 at 3:46 PM
    #3
    newtaco2008

    newtaco2008 Well-Known Member

    Joined:
    Mar 29, 2010
    Member:
    #34196
    Messages:
    90
    Gender:
    Male
    Fort Mill, SC
    Vehicle:
    08 prerunner indigo ink pearl
    I bought a used 2008 prerunner in March 2010 with 15,000 miles. Since then I have had it in the dealership for the following:

    1. tsb suspension

    2. new door seals and they had to install a whole new sliding glass rear window

    3. The infamous gas pedal recall and reflash..the reflash cured the rough shifting.

    4. New door latch on drivers side access door.

    Taking the truck in tomorrow for rattling on left side by front tire. I also have a shimmy around 20 mph but mine doesnt qualify for the tsb on it. Some of these issues may have been caused by the previous owner but some were not. I really think its a good truck once these issues are all resolved.....
     
  4. Oct 12, 2010 at 5:15 PM
    #4
    S.B.

    S.B. Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18838
    Messages:
    3,566
    Gender:
    Male
    First Name:
    Sean
    SD, CA Now in Colorado Springs, CO
    Vehicle:
    08 Taco 4x4 TRD OffRoad Rugged Trail
    SAW 2.0s, Wheeler's 3-leaf AAL, On Board Air, 255/85/16 Cooper Discover S/T, CBI Sliders, Built right UCAs, 6" Harbor Freight Lights (converted to HIDs), KC Slim Lights.
    I have this problem also and its shakes pretty bad going in reverse. Toyota is going to use the TSB for vibration between 15-25mph. All it is, is that they are going to replace the transmission mount. The parts on back order so I'm waiting for the parts to see if it works.
     
  5. Oct 12, 2010 at 5:45 PM
    #5
    Grey Jay

    Grey Jay [OP] Well-Known Member

    Joined:
    Aug 6, 2009
    Member:
    #20735
    Messages:
    70
    Gender:
    Male
    Sudbury ON Canada
    Vehicle:
    08 TRD
    Thanks for all the info, this is the first chance I had to answer back.

    I did a bit of troubleshooting today. When this happens, the engine RPMs don't take a dive or race, they just build at a normal rate, the truck has a slight but noticable shudder that I can feel in my bum ( though the seat I mean) and then it goes away as the speed increases. It does not happen when I am coasting to a stop, or driving a slow speed, just on moderate acceleration from a stop, like how you would normally leave on a green light. I will give the dealership a call in the morning.
     
To Top