1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Problems with my Kenwood HU

Discussion in 'Audio & Video' started by Banchi94, Aug 4, 2008.

  1. Aug 4, 2008 at 8:18 AM
    #1
    Banchi94

    Banchi94 [OP] Well-Known Member

    Joined:
    May 13, 2008
    Member:
    #6599
    Messages:
    471
    Gender:
    Male
    First Name:
    Ron
    Parker, CO
    Vehicle:
    2008 Indigo Blue TRD Sport DCSB 4x4
    ToyTec 3" basic lift
    I just installed a Kenwood DDX812 - it's exactly like the DNX8120 less the NAV. I've got two issues that I'm hoping y'all might be able to help me with.

    1. I have the Scosche kit and it seems to fit really crappy. The plastic mounting brackets that mount on the side of the HU and to the dash are two flexible and doesn't really keep the unit stable. Also, the actual dash portion doesn't snap in very wll either...it bulges out a bit on the sides. Anyone have this issue? Can I use the metal mounts from the stock unit?

    2. When I try to load a DVD or CD by pressing the eject button, the faceplate of the HU lowers, but immediately goes back up covering the CD opening. Then it stays at an angle that is much greater than the one a programmed it for. The angle gets set to 4, but I have it set to 1. Not sure why this is happening. I can't even get a CD/DVD in. Anyone have any ideas?

    Thanks y'all!
     
  2. Aug 4, 2008 at 8:30 AM
    #2
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    if it is like other head units I've had, you adjust the angle of the display by holding the eject button. Try a quick press to get it to open up.
     
  3. Aug 4, 2008 at 10:31 AM
    #3
    Banchi94

    Banchi94 [OP] Well-Known Member

    Joined:
    May 13, 2008
    Member:
    #6599
    Messages:
    471
    Gender:
    Male
    First Name:
    Ron
    Parker, CO
    Vehicle:
    2008 Indigo Blue TRD Sport DCSB 4x4
    ToyTec 3" basic lift
    Ya, I tried that and it opens the display then immediately covers up the CD/DVD slot. The display angle then gets stuck at the higher angle. With the Kenwood, there is a user menu to select the angle of the display. I don't think you can do it using the eject button.

    Thanks for the input!
     
  4. Aug 4, 2008 at 10:38 AM
    #4
    billybobsgoat

    billybobsgoat Member of the Goat Army

    Joined:
    Jun 8, 2008
    Member:
    #7170
    Messages:
    89
    Gender:
    Male
    Vehicle:
    08 PR silver 4.0 manual TRD O R
    Original metal brackets wont work, as far as the bulging goes make sure all your wiring is tucked back and secure as to clear the backside of the radio, I had the same issue and this fixed it, also I had an issue with it sqeaking on hot days I put this putty called "dum dum" on all the clips and this resolved the squeak sound. Hope this helps, Oh also put washers on the 4 10mm bolts under the radio as I found the scosche holes are almost the same size as the bolt head.
     
  5. Aug 4, 2008 at 9:09 PM
    #5
    Banchi94

    Banchi94 [OP] Well-Known Member

    Joined:
    May 13, 2008
    Member:
    #6599
    Messages:
    471
    Gender:
    Male
    First Name:
    Ron
    Parker, CO
    Vehicle:
    2008 Indigo Blue TRD Sport DCSB 4x4
    ToyTec 3" basic lift
    I figured out the problem! I didn't mount the dash kit very well...I guess the mounts on the side of the unit were supposed to "lock" into the dash portion of the Scosche kit. I didn't do that the first time I installed it and the dash kit was bulging out a little. This caused the Kenwood display to hit the bottom portion of the dash kit when I tried to put a CD in. The interference caused the display to catch and not open/close all the way.

    Thanks for the feedback in trying to help me figure this out!
     
To Top