1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

pw steering fluid leak, bad rack?

Discussion in '1st Gen. Tacomas (1995-2004)' started by fellon, Jun 11, 2007.

  1. Jun 11, 2007 at 11:59 AM
    #1
    fellon

    fellon [OP] New Member

    Joined:
    May 6, 2007
    Member:
    #1515
    Messages:
    1
    I have an 04 tacoma that has a body lift and large tires, I recently noticed a pw steering leak and thought it was my pump, a mechanic told me today that my rack might be bad and if it's not then it's the seals hoses? Anyone else have a issue like this? Any suggestions? Also my drivers side door make a hiss when I have the air on high or when I'm on the freeway. I think the door needs to latch tigher but there doesn't seem to be any way to tighten it. Once again any help will be much appriciated!

    Thank you!
     
  2. Jun 11, 2007 at 7:03 PM
    #2
    ForeRunner

    ForeRunner Hello, nice to meet you. Moderator

    Joined:
    Sep 9, 2006
    Member:
    #7
    Messages:
    11,579
    Gender:
    Male
    First Name:
    Drunken Sailor
    Somewhere between Maine and Florida
    Vehicle:
    2016 Subaru WRX STI Limited (no wing)
    Extra PSI
    My Dad has an 04 Prerunner (5VZ-FE)that had a steering fluid leak, turned out to be the hose had gone bad. He's got 45k on it and had the hose replaced twice. Have them check that.
     
To Top