1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Question about a cel

Discussion in '1st Gen. Tacomas' started by emglishe30, Jul 9, 2009.

  1. Jul 9, 2009 at 7:18 PM
    #1
    emglishe30

    emglishe30 [OP] Well-Known Member

    Joined:
    Jul 10, 2008
    Member:
    #7863
    Messages:
    95
    Gender:
    Male
    NJ
    Vehicle:
    01 2WD Taco 2.4
    Debadged to TACO, Kenwood reciever, pioneer 6 X 8's, sunpro 3" tach, assorted led lights, sirrius, gps...
    So I stopped by advance auto to have my check engine light code red...The guy said its either A. My catalytic converter or B. The sensor on my cat. Are there any good aftermarket catalytic converters out there that I could get and still keep it legal? If it turns out to be just the sensor how much do they run? And how do I tell if its one or the other causing the the cel to pop up? Thanks
     
  2. Jul 9, 2009 at 7:26 PM
    #2
    wildjerseyfirefighter

    wildjerseyfirefighter I sell fishing and fishing accessories

    Joined:
    Dec 17, 2008
    Member:
    #11677
    Messages:
    7,975
    Gender:
    Male
    First Name:
    Joe
    NJ
    Vehicle:
    05 Tacoma TRD Sport
    stock, for now
    sensor is about $70 from URD.

    Magnaflow makes a nice flow throu cat also.
     
  3. Jul 10, 2009 at 7:49 AM
    #3
    emglishe30

    emglishe30 [OP] Well-Known Member

    Joined:
    Jul 10, 2008
    Member:
    #7863
    Messages:
    95
    Gender:
    Male
    NJ
    Vehicle:
    01 2WD Taco 2.4
    Debadged to TACO, Kenwood reciever, pioneer 6 X 8's, sunpro 3" tach, assorted led lights, sirrius, gps...
    I see, I am hoping its just a sensor...Cats are expensive...
     
  4. Jul 10, 2009 at 7:52 AM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    104,126
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    What was the code he pulled?
     
  5. Jul 10, 2009 at 11:04 AM
    #5
    emglishe30

    emglishe30 [OP] Well-Known Member

    Joined:
    Jul 10, 2008
    Member:
    #7863
    Messages:
    95
    Gender:
    Male
    NJ
    Vehicle:
    01 2WD Taco 2.4
    Debadged to TACO, Kenwood reciever, pioneer 6 X 8's, sunpro 3" tach, assorted led lights, sirrius, gps...
    not sure exactly, the guy just said it was related to the catalytic converter....
     
  6. Jul 10, 2009 at 12:24 PM
    #6
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,248
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    Sounds like a P0136 or P0420. The 136 would be for the sensor malfunctioning and the 420 is the CAT.

    I am betting on the 136. But try getting the code read again at a different location and see exactly what it is.
     
  7. Jul 10, 2009 at 2:34 PM
    #7
    emglishe30

    emglishe30 [OP] Well-Known Member

    Joined:
    Jul 10, 2008
    Member:
    #7863
    Messages:
    95
    Gender:
    Male
    NJ
    Vehicle:
    01 2WD Taco 2.4
    Debadged to TACO, Kenwood reciever, pioneer 6 X 8's, sunpro 3" tach, assorted led lights, sirrius, gps...
    yeah I should have asked...I was in a rush at the time. I'll go to another location and have them check it...Should I tip the guy for doing it?
     
  8. Jul 10, 2009 at 3:09 PM
    #8
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,248
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    Hell no. LOL
     
  9. Jul 10, 2009 at 4:17 PM
    #9
    ChrisYoTaCoMa

    ChrisYoTaCoMa Chrome's for Harleys and old farts

    Joined:
    May 31, 2009
    Member:
    #17828
    Messages:
    581
    Gender:
    Male
    First Name:
    Chris
    Estero, Floriduh
    Vehicle:
    00 Taco 4x4 Ex cab 2.7 sr5 AT
    New Pioneer stereo, and all 4 speakers with Infinity components. Sirius satellite radio. Deckplate mod done. Door buzzer silenced forever thank God, tinted windows, vent visors, hood protector(bug guard), ceramic pads and new rotors, dechromed EVERYTHING. 2" Lift front 3" rear. Skyjacker AAL's and replacement leafs(and front spacers) from Fatbobsgarage.com. Skyjacker 7000 Hydro rear shocks, those Bilstein 5100 fronts are coming soon!
    Mine did the same codes, when I replaced my O2 sensor all the codes went bye-bye... And never returned.
     
  10. Jul 10, 2009 at 5:53 PM
    #10
    emglishe30

    emglishe30 [OP] Well-Known Member

    Joined:
    Jul 10, 2008
    Member:
    #7863
    Messages:
    95
    Gender:
    Male
    NJ
    Vehicle:
    01 2WD Taco 2.4
    Debadged to TACO, Kenwood reciever, pioneer 6 X 8's, sunpro 3" tach, assorted led lights, sirrius, gps...
    well I didn't want to seem like a dick haha. I have a hard enough time tipping a waiter..
     
  11. Jul 24, 2009 at 12:00 PM
    #11
    emglishe30

    emglishe30 [OP] Well-Known Member

    Joined:
    Jul 10, 2008
    Member:
    #7863
    Messages:
    95
    Gender:
    Male
    NJ
    Vehicle:
    01 2WD Taco 2.4
    Debadged to TACO, Kenwood reciever, pioneer 6 X 8's, sunpro 3" tach, assorted led lights, sirrius, gps...
    well I got the code red and it was a p0420..So I guess its time for a new cat. I was looking into a magnaflow cat. Are there any benefits with these or should I just try and find a factory replacement?
     
  12. Jul 24, 2009 at 1:25 PM
    #12
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,248
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    I have heard stories that taco's don't like aftermarket CAT's. Whether or not this is true, I don't know. You have three options; find an aftermarket, go with oem, or just get an O2 simulator. One major deciding factor is emissions. If your state "sniffs", then the OEM would be the way to go. If they don't, you could just go with the simulator.
     
  13. Jul 25, 2009 at 5:56 PM
    #13
    emglishe30

    emglishe30 [OP] Well-Known Member

    Joined:
    Jul 10, 2008
    Member:
    #7863
    Messages:
    95
    Gender:
    Male
    NJ
    Vehicle:
    01 2WD Taco 2.4
    Debadged to TACO, Kenwood reciever, pioneer 6 X 8's, sunpro 3" tach, assorted led lights, sirrius, gps...
    thanks for the input..I would like to hear more about this magnaflow issue..
     
  14. Jul 25, 2009 at 6:09 PM
    #14
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,248
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    I can't help you with the Magnaflow. Maybe someone will chime in who can.
     
To Top