1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Question for 2012 TRD DCSB owners

Discussion in '2nd Gen. Tacomas (2005-2015)' started by LizellaFella, Jul 2, 2012.

  1. Jul 2, 2012 at 4:23 AM
    #1
    LizellaFella

    LizellaFella [OP] Well-Known Member

    Joined:
    May 10, 2010
    Member:
    #36867
    Messages:
    151
    Gender:
    Male
    First Name:
    Eddie
    Lizella Georgia
    Vehicle:
    2016 4 Runner SR5
    I've got a shade over 3K miles on my 2012 TRD DCSB Off-road and have noticed a "squish" sound coming from under the dash every time I apply the brakes.

    Sounds like it might be a vacuum leak at the brake booster. I've heard this many times on older cars where the rear seal of the booster goes bad.

    Those of you who have a 2012, have you experienced this same issue, by chance? My 2010 Sport did not do this and the brakes just felt better.

    TIA LF
     
  2. Jul 2, 2012 at 7:43 AM
    #2
    newphoto

    newphoto Well-Known Member

    Joined:
    Apr 20, 2012
    Member:
    #77297
    Messages:
    61
    Gender:
    Male
    First Name:
    Colin
    Oklahoma
    Vehicle:
    2012 V6 4WD Double Cab
    My 2012 V6 SR5 4WD also has 3000 miles on it and there is no noise when applying the brakes. I would let the dealer check it out.
     
  3. Jul 2, 2012 at 7:45 AM
    #3
    PaintDrinkingPete

    PaintDrinkingPete Well-Known Member

    Joined:
    Jun 2, 2012
    Member:
    #79931
    Messages:
    280
    Gender:
    Male
    NoVA
    Vehicle:
    2012 4x4 TRD Sport DCSB
    Only have about 1K on mine, but do not notice that at all...nor did I on my 2005 that had ~110K on it.
     
  4. Jul 2, 2012 at 7:47 AM
    #4
    kristjl8

    kristjl8 Member

    Joined:
    May 30, 2012
    Member:
    #79740
    Messages:
    5
    Gender:
    Male
    First Name:
    Jesse
    Boston, MA
    Vehicle:
    '12 Double Cab TRD 4x4 MT
    I just got the same truck a few weeks ago and now has 600+ miles on it. It's been doing the same thing, so i'm gonna get in touch with the dealer and see whats up. Braking is fine, but the noise is annoying and worrisome.
     
  5. Jul 2, 2012 at 8:21 AM
    #5
    greenrustic

    greenrustic Well-Known Member

    Joined:
    Jan 16, 2012
    Member:
    #70776
    Messages:
    676
    Gender:
    Male
    NY
    Vehicle:
    2012 DCLB 4x4 TRD SPORT
    Access LTD Tonneau Cover, Weather Tech Digital Fit Mats, Weather Tech Rain Guards, 35% Tint up Front, AFE Dry Power Intake Filter, Debadged, GrilleCraft, OME 884x, OME 9000 NitroChargers, Icon 3 Leaf Progressive AAL
    No noise here 14,000miles. I think the breaks are great.
     
  6. Jul 2, 2012 at 8:27 AM
    #6
    lj973gm

    lj973gm Sold it, dont miss it yet.

    Joined:
    Sep 16, 2011
    Member:
    #63618
    Messages:
    852
    Gender:
    Male
    Ohio
    Vehicle:
    06 DCSB 4wd
    It is a variation of a hyroboost brake system. Completely normal.
     
  7. Jul 2, 2012 at 8:29 AM
    #7
    GP3

    GP3 Well-Known Member

    Joined:
    Apr 11, 2011
    Member:
    #54719
    Messages:
    1,102
    Gender:
    Male
    California
    Vehicle:
    4X4 TRD Off Road
    Front: stock suspension, 12" wide fiberglass fenders Rear: stock suspension, 10" wide fiberglass fenders
    This.
     
  8. Jul 2, 2012 at 8:56 AM
    #8
    LizellaFella

    LizellaFella [OP] Well-Known Member

    Joined:
    May 10, 2010
    Member:
    #36867
    Messages:
    151
    Gender:
    Male
    First Name:
    Eddie
    Lizella Georgia
    Vehicle:
    2016 4 Runner SR5
    Thanks for the input folks.
     
  9. Jul 2, 2012 at 12:07 PM
    #9
    Enzo

    Enzo Well-Known Member

    Joined:
    Sep 6, 2010
    Member:
    #42815
    Messages:
    1,372
    Gender:
    Male
    First Name:
    Opie
    Bedford, Va
    Vehicle:
    2012 FJ Cruiser
    2012 FJ Cruiser Maggiolina Medium Grand Tour w/winter hood National Luna dual battery split charging system ABR Sidewinder Aux battery tray ARB 50qt Fridge w/Transit Bag Bajarack flat rack w/ladder Crawlarado flat black hood blackout TRD exhaust Trasharoo Outback FJ roof console
    It's normal.
     
  10. Jul 2, 2012 at 1:33 PM
    #10
    Nacp

    Nacp Member

    Joined:
    Mar 30, 2012
    Member:
    #75934
    Messages:
    5
    Gender:
    Male
    Nor-Cal
    Vehicle:
    06 4Runner 4X4, 12 Taco-Prerunner DCSB TRD-OR
    My 06 4Runner, makes this sound (squishing) since day1, quite normal, has over 156,XXX trouble-free miles on it now. On the other hand my 2012 TRD-OR Tacoma made a clanging-sound on releasing the brakes, needed lubing of the pedal once, is at 3,7XX miles now and sound has not come back.
     
  11. Jul 2, 2012 at 5:27 PM
    #11
    jtgroce

    jtgroce Got R Did

    Joined:
    Feb 9, 2012
    Member:
    #72490
    Messages:
    789
    Gender:
    Male
    In the Foothills, NC
    Vehicle:
    '12 Taco MGM TRD Off Road
    K&N Air Filter Husky Floor Liners Weathertech Vent Visors LED Map/Dome Light Mod Chrome Door Handles AVS Bugshield Bed Mat Fog Light Anytime Mod DTRL LED's Flowmaster Super 40
    Mine does it too......like everyone said it's normal
     
  12. Jul 3, 2012 at 7:52 PM
    #12
    TeamLombardo

    TeamLombardo WE'VE LANDED ON THE MOON!

    Joined:
    May 20, 2012
    Member:
    #79227
    Messages:
    642
    Gender:
    Male
    First Name:
    Tony
    El Paso
    Vehicle:
    '12 DCSB TRD Off-Road 4x4
    OME 886x, OME Trim Packer, OME Shocks, Dakars, Toytec Shims, LR UCAs, CB Drop, Demello Sliders, Pelfreybilt Plate Bumper, Warn VR8000-s, RI 20" LED, RI Duallys, TRD Exhaust, Weathertech Liners, SS Brake Lines Front/Back, BHLM, Anytime Fogs, CV Boot Mod, 20% Tint, Stubby Antenna, Salex Console Organizer, Derped Grill/Badges
    Just adding the same thing others have been saying......it's totally normal. :yawn:
     

Products Discussed in

To Top