1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Questions on my setup

Discussion in 'Audio & Video' started by Quasar, Oct 6, 2009.

  1. Oct 6, 2009 at 7:15 PM

    Quasar [OP] New Member

    Sep 27, 2009
    Tempe, AZ
    2010 Base 4X2 SR5
    Hey all...I have decided to change out the factory HU and speakers. I am going with the Alpine CDA-105 and the Alpine KTP-445 power pack. I am still up in the air about the two speaker models I am looking at. Both are Polk Audio..models MM6501 and DB6501. Anyone have this set up or something similar who can give me some feedback on either model of speakers?

    Also, I am new to doing auto speaker installs. It's a 2010 Tacoma access cab. After looking at the factory speakers, it's look like they are component speakers with the crossover attached to the tweeter (can anyone verify?). Am I going to have to run new wires for either of the component systems I listed above? Is there no way to use the existing speaker wires to hook them up? Also, for the amp, is there a way to get it to sit behind the HU or in that area? I don't really want to put it in the glove box if I don't have to. Lastly, I know I will need speaker brackets for both the woofers and tweeters. Anyone know where the best deal for these would be? Anything else I am forgetting? Thanks for any info!!
To Top