1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

quick filter question

Discussion in 'Performance and Tuning' started by bcass77, Apr 15, 2008.

  1. Apr 15, 2008 at 5:47 PM
    #1
    bcass77

    bcass77 [OP] Member

    Joined:
    Mar 24, 2008
    Member:
    #5482
    Messages:
    12
    Ft. Collins, CO
    Vehicle:
    06 SR5 4x4 2.7
    the UPS man just dropped off my aFe pro-dry s filter today. do I just have to drop it in and go, or do I have to disconnect the battery and then reconnect it to allow the computer to reset? thanks!
     
  2. Apr 15, 2008 at 5:50 PM
    #2
    rick

    rick `

    Joined:
    Mar 1, 2007
    Member:
    #993
    Messages:
    2,475
    Gender:
    Male
    just drop it in. and good choice by the way
     
  3. Apr 15, 2008 at 6:05 PM
    #3
    bcass77

    bcass77 [OP] Member

    Joined:
    Mar 24, 2008
    Member:
    #5482
    Messages:
    12
    Ft. Collins, CO
    Vehicle:
    06 SR5 4x4 2.7
    cool, thanks!
     
  4. Apr 15, 2008 at 6:41 PM
    #4
    bcass77

    bcass77 [OP] Member

    Joined:
    Mar 24, 2008
    Member:
    #5482
    Messages:
    12
    Ft. Collins, CO
    Vehicle:
    06 SR5 4x4 2.7
    hmmm... just went to remove the secondary air filter and put in the aFe and turns out the previous owner had already removed the secondary. Oh well, less work for me. Got the aFe in there, so good to go.
     
  5. Apr 15, 2008 at 7:22 PM
    #5
    Roland

    Roland My other ride has sails

    Joined:
    Jan 8, 2008
    Member:
    #4149
    Messages:
    2,406
    Gender:
    Male
    Rhode Island
    Vehicle:
    06 Impulse Red I4 2WD Access Cab
    UnderCover Tonneau, Bed mat, Bug Deflector, aFe Pro Dry S, Secondary Air Filter removed, Synthetic 5W-30 oil, Scanguage II with blendmount, WeatherTech floorliners, Toyota seat covers, Installed OEM intermittent wipers, TacomaWorld sticker, Defrost without AC mod, Hidden Hitch
  6. Apr 16, 2008 at 2:09 AM
    #6
    surfsupl

    surfsupl Well-Known Member

    Joined:
    Jan 8, 2008
    Member:
    #4161
    Messages:
    8,568
    Gender:
    Male
    First Name:
    Gregg
    WestCoast
    Vehicle:
    I DONT CARE IF IT'S A RE-POST
    Rear Diff Breather~ 5100's ~Fog Light Anytime~Tint~TRD Seat Covers~Weather Tech's~Pioneer H.U.~Lift~Eibach Springs~LED's......blah...blah...blah
    What was the cost on this?
     
  7. Apr 16, 2008 at 5:18 AM
    #7
    Roland

    Roland My other ride has sails

    Joined:
    Jan 8, 2008
    Member:
    #4149
    Messages:
    2,406
    Gender:
    Male
    Rhode Island
    Vehicle:
    06 Impulse Red I4 2WD Access Cab
    UnderCover Tonneau, Bed mat, Bug Deflector, aFe Pro Dry S, Secondary Air Filter removed, Synthetic 5W-30 oil, Scanguage II with blendmount, WeatherTech floorliners, Toyota seat covers, Installed OEM intermittent wipers, TacomaWorld sticker, Defrost without AC mod, Hidden Hitch
    If you shop around you can find it for as low as $27. Do NOT pay more than $40 including taxes and shipping.
     
  8. Apr 16, 2008 at 8:08 AM
    #8
    flavalk

    flavalk 2-Broke 2-Care

    Joined:
    Jan 15, 2007
    Member:
    #729
    Messages:
    148
    Orlando, Florida via Huntsville, Alabama
    Vehicle:
    '07 PreRunner SR5 Double Cab 2WD - Short Bed - Automatic- Silver Mica
    Not much. Toyota bed mat, Toyota step bars, tinted windows, Toyota seat covers, Toyota all-weather mats, quart of Wild Turkey in the glove box, KelTec PT3AT in the center console, backseat full of old speeding tickets
    where can I get this filter. I have checked several sites and cannot find one for the 4.0 V6. Anybody have a link?

    THX!
     
  9. Apr 16, 2008 at 8:21 AM
    #9
    Roland

    Roland My other ride has sails

    Joined:
    Jan 8, 2008
    Member:
    #4149
    Messages:
    2,406
    Gender:
    Male
    Rhode Island
    Vehicle:
    06 Impulse Red I4 2WD Access Cab
    UnderCover Tonneau, Bed mat, Bug Deflector, aFe Pro Dry S, Secondary Air Filter removed, Synthetic 5W-30 oil, Scanguage II with blendmount, WeatherTech floorliners, Toyota seat covers, Installed OEM intermittent wipers, TacomaWorld sticker, Defrost without AC mod, Hidden Hitch
    I have to be a bit more careful with my answers. The filter for the 4.0 is more expensive. I think the aFe part number is 30-10114 but Maverick knows for sure... :cool:
     
To Top