1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Rear Diff lock + ABS Light wont turn off (lock disengaged)

Discussion in 'Technical Chat' started by ugly, Jan 15, 2011.

  1. Jan 15, 2011 at 9:28 PM
    #1
    ugly

    ugly [OP] New Member

    Joined:
    Jan 15, 2011
    Member:
    #49316
    Messages:
    4
    Gender:
    Male
    hi Guys,

    Im new to the forums so go easy on me. I did try searching around using google and search in these forums as well, with no such luck.

    My Rear Diff lock + ABS Light wont turn off. I put the rear diff lock on, do some S turns to feel that its actually on, stop, release the lock, do some S turns, then the rear diff lock + abs light turn OFF once i hear the lock disengage... BUT, as soon I drive a few more feet, the rear diff light will slowly start to turn on, takes about 10-15 seconds for it to completely light up, and once it does the ABS lights up as well (as it should if the rear diff light is on). Ive reached under and made sure the wireing harness on the diff is secure, and have tried toggling on and off the lock as i said above, but not really sure what else could be going on. Id think if it was a fuse, the light wouldnt slowly light up like it is, but could be wrong. i had the diff oil changed at 30k (i have about 38k on it now). so im not really sure what could be going on. any help would be much appreciated.

    thanks,
    sean
     
  2. Jan 17, 2011 at 12:09 PM
    #2
    ugly

    ugly [OP] New Member

    Joined:
    Jan 15, 2011
    Member:
    #49316
    Messages:
    4
    Gender:
    Male
    bump
     
  3. Jan 17, 2011 at 12:52 PM
    #3
    Yoytoda

    Yoytoda The Little Truck That Could

    Joined:
    Oct 2, 2009
    Member:
    #23690
    Messages:
    4,949
    Gender:
    Male
    First Name:
    Roland
    Big Bear,CA / Upstate NY(Saratoga)
    Vehicle:
    2010 Tacoma Regular Cab 4x4
    completely stock
    that should be under the 5/60 warranty... take it into the dealer?
     
  4. Jan 17, 2011 at 9:19 PM
    #4
    Jason'sLawnCare

    Jason'sLawnCare Prepared for Bambi

    Joined:
    Apr 12, 2009
    Member:
    #15878
    Messages:
    12,365
    Gender:
    Male
    First Name:
    Jason
    Jacksonville Florida
    Vehicle:
    08 4x4 Double Cab TRD Rugged Trail
    CBI Moab 2.0, CBI Trail Rider 2.0, CBI sliders w/kickout, Superwinch EPi9.0S, OME sport shocks w/886 coils, OME n182, 1.5" aal, JasonBuilt 3/16th full belly skid, BuiltRight uca, Body Mount Chop, 285/75/16 km2's, Rear cat delete, exhaust crossover rerouted, Fog light anytime, Locker mod, Rear leaf tsb, Debadged, Uws Tool Box, Electric Exhaust Cutout, AFE Pro Dry S, Kiwi Wifi, Diff Breather Relocated, Grom Ipod Adapter, Dual Diehard platinum batteries isolated by BlueSea marine switch
    Try resetting it by pulling the negative on the battery for a couple minutes. If that doesn't do it check fuses. If that doesn't work bring it to the dealer assuming it's under warranty.
     
  5. Jan 18, 2011 at 1:17 AM
    #5
    ugly

    ugly [OP] New Member

    Joined:
    Jan 15, 2011
    Member:
    #49316
    Messages:
    4
    Gender:
    Male
    thanks for the advice

    pulled the battery and checked the fuses, no luck, guess im going to the dealer tomorrow
     
  6. Jan 19, 2011 at 12:22 AM
    #6
    ugly

    ugly [OP] New Member

    Joined:
    Jan 15, 2011
    Member:
    #49316
    Messages:
    4
    Gender:
    Male
    "faulty RR diff lock switch" ding ding

    since the dealership says switches arent covered under the drivetrain warranty, im eating $350
     
  7. Jun 20, 2011 at 7:28 PM
    #7
    PJDOGM

    PJDOGM New Member

    Joined:
    Jun 20, 2011
    Member:
    #58589
    Messages:
    4
    Gender:
    Male
    New York
    Vehicle:
    04 SR5 TRD
    Hi

    I'm a brand new member... found you when I was searching for an answer to this very problem. I drive a 04 4WD SR5 TACO 140,000 mi. My RR diff light came on yesterday as I was driving about 60 shortly after my ABS light came on. Since then it acts exactly as Sean's the lights are off when I first start the truck but come on shortly after. I tested the RR Diff today on a dirt road and it seems to be working OK but the light stays on.
    Did you replace the switch? How hard was it? Did the ABS light go away with the new switch as well. My truck is going in for the frame replacement soon and I don't want to give the dealer anything else to soak me for.

    Thanks,

    Steve
     
  8. Jun 21, 2011 at 8:38 AM
    #8
    BlueT

    BlueT Well-Known Member

    Joined:
    Mar 30, 2009
    Member:
    #15341
    Messages:
    5,645
    Gender:
    Male
    NorthEast
    Vehicle:
    07 Dbl Cab LB with LSD
    I moded 1999 Taco so much it had turned to Land Cruiser
    Takes 5 min to replace this switch :D with one wrench
     
  9. Jun 21, 2011 at 4:52 PM
    #9
    PJDOGM

    PJDOGM New Member

    Joined:
    Jun 20, 2011
    Member:
    #58589
    Messages:
    4
    Gender:
    Male
    New York
    Vehicle:
    04 SR5 TRD
    Thanks for the reply. I was thinking there was some type of switch on the differental itself. the switch on the dash is working as far turning on and off the RR Diff, but there could be another contact for the light I guess.

    Here's what I tried tonight and it appears to have worked but I need to drive more to be sure. Since I have only used the RR Diff once or twice in 6 1/2 years the diff itself and may be partially stuck (even though it feels like its working) I put the truck in 4 WD Low and engaged the RR Diff. I drove back and forth about 5 minutes. I disengaged the RR Diff and took it out of 4 WD and the light went off and stayed off so far. I'll update when I'm sure it's OK
     
  10. Jun 21, 2011 at 6:16 PM
    #10
    BlueT

    BlueT Well-Known Member

    Joined:
    Mar 30, 2009
    Member:
    #15341
    Messages:
    5,645
    Gender:
    Male
    NorthEast
    Vehicle:
    07 Dbl Cab LB with LSD
    I moded 1999 Taco so much it had turned to Land Cruiser
    Yep right above motor actuator for RR lock. Thats what tells light on the dash if locker is on or off. Those switches tend to freezup and loose small ball that rides on the mechanism that locks. Those switches are fairly inexpensive and it does take like 5 minutes to replace one. If you still have a problem I would just remove switch and see if it needs spray with WD40;)
     
  11. Jun 22, 2011 at 6:05 AM
    #11
    PJDOGM

    PJDOGM New Member

    Joined:
    Jun 20, 2011
    Member:
    #58589
    Messages:
    4
    Gender:
    Male
    New York
    Vehicle:
    04 SR5 TRD
    I'll do that, thanks for your help
     
  12. Oct 18, 2011 at 8:49 PM
    #12
    Russellzilla

    Russellzilla Member

    Joined:
    Oct 20, 2009
    Member:
    #24635
    Messages:
    20
    Gender:
    Male
    First Name:
    Russell
    Oregon
    Vehicle:
    05 tacoma TRD off road
    6" Fabtech lift Sliders (Elite Off Road) 4.56 gears (ECG)
    My truck is doing the exact same thing where the light slowly comes on after you turn the Diff lock off. I'd like to fix without being raped at the dealership

    is this "center diff. lock switch" the one your saying I need to replace?

    Center diff lock switch.jpg
     
  13. Oct 21, 2011 at 3:54 AM
    #13
    Russellzilla

    Russellzilla Member

    Joined:
    Oct 20, 2009
    Member:
    #24635
    Messages:
    20
    Gender:
    Male
    First Name:
    Russell
    Oregon
    Vehicle:
    05 tacoma TRD off road
    6" Fabtech lift Sliders (Elite Off Road) 4.56 gears (ECG)
    Thanks man. That sucks I have to buy at the dealer though. gd that thing is probably gonna be like a hundred or something stupid.
     
  14. Jul 27, 2013 at 7:11 PM
    #14
    Alexhaubi27

    Alexhaubi27 New Member

    Joined:
    Jul 27, 2013
    Member:
    #109194
    Messages:
    1
    Gender:
    Male
    Vehicle:
    05 prerunner sr5
    Lift
    Hey guys I'm in the middle of buying an 05' prerunner sr5 and I test drove it today and I noticed the air bag light and the diff lock won't turn off....I hit the diff lock button and it still didn't turn off...my dad isn't happy with that...anyone know any reasons for this? Help me ASAP.
     
  15. Nov 16, 2013 at 11:13 PM
    #15
    SWCCBEE

    SWCCBEE So Cal Edition

    Joined:
    May 23, 2013
    Member:
    #104789
    Messages:
    439
    Gender:
    Male
    First Name:
    Greg
    Santa Rita, GU
    Vehicle:
    2010 PreRunner, SR5, TRD Sport
    WeatherTech floor liners, In process of Debadge, Leveling kit, Tires, Limo tint, Custom TRD SPORT Decal, "ImMrYo" Rear view lifting bar, Ultra gauge, relocated horn.
    I just put on a 20" LED bar. Once we reconnected the battery my ABS and traction control? Light are on. My ultra gauge also reset. Any thoughts?
     
To Top