1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Removing camshaft position sensor from timing belt cover

Discussion in '1st Gen. Tacomas (1995-2004)' started by white3911, Oct 22, 2011.

  1. Oct 22, 2011 at 5:58 PM
    #1
    white3911

    white3911 [OP] New Member

    Joined:
    Oct 22, 2011
    Member:
    #65673
    Messages:
    2
    Gender:
    Male
    Indianapolis, IN
    Vehicle:
    1996 XtraCab V6
    How do I disconnect the sensor connector shown in the picture from the timing belt cover? I need to remove it in order to remove the valve covers and replace the gaskets.

    I read somewhere to "pinch the locking tabs" to release it from the cover. I've been stuck on this one connector for over an hour now and appreciate any input. Thanks!

    CIMG0040.jpg
     
  2. Oct 22, 2011 at 6:10 PM
    #2
    jberry813

    jberry813 The Mad Scientist

    Joined:
    Jan 21, 2011
    Member:
    #49636
    Messages:
    16,592
    Gender:
    Male
    First Name:
    Jason
    Lake Tahoe
    Vehicle:
    2012 DCSB Sport
    ...too much shit to list.
    Remove the bolts of the cover with sensor still attached.
    You'll be able to stick some pliers on the inside of the cover to release the tabs.



    Oh and welcome to TW.
     
  3. Oct 22, 2011 at 6:20 PM
    #3
    white3911

    white3911 [OP] New Member

    Joined:
    Oct 22, 2011
    Member:
    #65673
    Messages:
    2
    Gender:
    Male
    Indianapolis, IN
    Vehicle:
    1996 XtraCab V6
    Thanks for the quick response! Long time reader, first time poster.
     
To Top