1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Replaced Fuel filter now 2.7l wont idle?, EGR or IAC?

Discussion in '1st Gen. Tacomas (1995-2004)' started by wolfgang123, Dec 22, 2011.

  1. Dec 22, 2011 at 2:57 PM
    #1
    wolfgang123

    wolfgang123 [OP] Well-Known Member

    Joined:
    Jul 7, 2009
    Member:
    #19369
    Messages:
    1,427
    Gender:
    Male
    First Name:
    Skyler
    Statesboro, GA
    Vehicle:
    1997 TACOMA - 4x4
    So i removed my intake mani and cleaned it really good got all the carbon out! i replaced my fuel filter, cleaned injectors, cleaning throttlew body and now she is all back together but wont idle smooth? she holds at about 900-1000rpm and down to 680-750rpm sporatically. the motor seems to be loping like a diesel motor. After i carfully apply gas (she stutters when i acclerate too fyi...) the motor seems to level out and run 1000 times better than before all the work. After some searching i think it might be the EGR or IAC any advice on these two and how i should go about cleaning them?
     
  2. Dec 22, 2011 at 3:13 PM
    #2
    misterdmac

    misterdmac Well-Known Member

    Joined:
    Aug 10, 2011
    Member:
    #61478
    Messages:
    185
    First Name:
    Doostin
    In or around the truck
    Vehicle:
    '97 2.7L DLX
    You should be able to spray some electronic parts cleaner (zero residue kind) into both to clean 'em out. Make sure you let it all dry out before reinstalling. While you're at it, pull the MAF and give that a few sprays, too.

    Not saying that's the root cause but it's the cheapest possible solution, so that's where you start.
     
To Top