1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Ride Quality Suddenly Worse?

Discussion in 'Technical Chat' started by BurritoJimmyFan, Oct 12, 2010.

  1. Oct 12, 2010 at 6:02 PM
    #1
    BurritoJimmyFan

    BurritoJimmyFan [OP] Well-Known Member

    Joined:
    Aug 30, 2009
    Member:
    #21983
    Messages:
    130
    Gender:
    Male
    First Name:
    Matt
    Frisco, TX
    Vehicle:
    04 Ext Cab TRD
    Gray Wire Mod, DRL Mod, Deckplate Mod
    I bought my truck with 60k miles and it had the factory yellow shocks. The ride was okay but needed improvement. So, I upgraded to the Bilstien 5100 (stock height) and the ride was much better. However, after about 12k miles, the ride suddenly seems very rough.

    Do you have any ideas what is wrong? I'm hoping its not the shocks. What other parts would cause a poor ride quality?

    I have about 80k miles with all original suspension parts, except for shocks.

    Please help :confused:
     
  2. Oct 13, 2010 at 6:53 PM
    #2
    BurritoJimmyFan

    BurritoJimmyFan [OP] Well-Known Member

    Joined:
    Aug 30, 2009
    Member:
    #21983
    Messages:
    130
    Gender:
    Male
    First Name:
    Matt
    Frisco, TX
    Vehicle:
    04 Ext Cab TRD
    Gray Wire Mod, DRL Mod, Deckplate Mod
    Hopefully, I'm not just talking to myself here. :)

    I had a 98 taco and drove around for about six months with a broken leaf spring (just one leaf not the whole pack) until a mechanic pointed it out to me. So, I know that is not the problem.

    Any ideas?
     
  3. Oct 13, 2010 at 6:56 PM
    #3
    ktmrider

    ktmrider Senior Member

    Joined:
    Jul 20, 2009
    Member:
    #19933
    Messages:
    4,969
    Gender:
    Male
    Vehicle:
    07 DCLB 4x4 Sport S/C
    Junk
    have you looked at the shocks busted a seal?
     
To Top