1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Right Turn signal on constantly after Battery replacement w/Braking

Discussion in 'Technical Chat' started by Tollster, Sep 6, 2009.

  1. Sep 6, 2009 at 6:30 AM

    Tollster [OP] New Member

    Sep 6, 2009
    01 4Runner/ 02 Tacoma
    Hi ya'll, first post here, so it goes to show you how good these trucks are. Mines a 2002 Tacoma, Xcab, V6, 4x4. I had to replace the battery from the stock one friday (7 years isn't that bad) and decided to get an Optima Red top. After installation, or soon after, I noticed that when I apply the brakes, the right turn signal comes on, it does not blink, but rather on constant until the brake is released. This is evident on all right side turn indicators.
    I checked the fuses, bulbs, and unhooked the positve terminal, but still the same.
    Any ideas? I moved the harness around figuring it may have been a ground. But still the same.
    I doubt it the Battery, I did check all light filiments on the right side brakes/turn signals, and it does have a trailer harness and electric trailer brake module.
    Thanks and Happy Labor Day to you!
To Top