1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Rough Idle?

Discussion in 'Technical Chat' started by BOLLINGERTACO, Apr 17, 2008.

  1. Apr 17, 2008 at 8:41 PM
    #1
    BOLLINGERTACO

    BOLLINGERTACO [OP] Member

    Joined:
    Apr 11, 2008
    Member:
    #5910
    Messages:
    13
    noho
    Vehicle:
    08 4x4 4door long bed SR5
    2.5" front lift, debadged
    iv got an 08 4.0L 4x4. every so often, once every day or two, i get a weird rough idle. not something that would make you think wow, something is wrong. but definetly noticeable. anyone else experience the same thing? iv got almost 5k miles and threw fresh Mobil 1 in at 3500. it seems a little rougher if iv got the a/c on. i just expected perfection from toyota...am i being too critical?
     
  2. Apr 17, 2008 at 8:47 PM
    #2
    415tacoma

    415tacoma Well-Known Member

    Joined:
    Mar 24, 2008
    Member:
    #5501
    Messages:
    102
    Gender:
    Male
    Woodacre, ca
    Vehicle:
    08 TRD Sport Debadged
    ive noticed it when i turn my A/c on
     
  3. Dec 13, 2008 at 9:57 PM
    #3
    crytesy

    crytesy Weekend Warrior

    Joined:
    Mar 30, 2008
    Member:
    #5617
    Messages:
    24
    Alberta
    Vehicle:
    2006 SR5 Tacoma
    Skid Plate, Undercover Tonneau Cover, PIAA FogLights, AIR RAID CAI
    I was actually looking to post the same observation. The idle is most definitely rougher than I expected for a Toyota......

    I only notice it on occasion....it's not a steady issue.

    Part of me is glad that others are experiencing the same issue....I know that it's a quirky Toyota issue.
     
  4. Dec 14, 2008 at 6:15 AM
    #4
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    13,623
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2007 4.0L 4x4 TRD Sport Access Cab A
    Advantage Torza top (tri-fold), Husky floor mats, RuffTuff seat covers, C2C hood struts, Homelink mirror, USA Spec PA15-Toy (120gig Classic & 8gig nano), Garmin Nuvi 660, Protecta Bed mat, Pop-n-lock, TSB Springs, Scangauge II, Heated drivers seat, Fumoto drain valve, Aries pushbar, PIAA 540 fog lights, Hood scoop grahics, Flowmaster 50 series dual catback exhaust, RainX Latitude windshield wipers, Husky rear floor liner (ontop of folded down seats). Console Vault.
    Not that its rough....

    But if I'm sitting somewhere (stop light, drive-thru or whatever), the truck ramps up to 650ish for like 10 seconds, then drops down to 540ish for a few seconds then back up, down, up, down.... (I have a scangauge and exhaust and can 'hear it').

    I don't consider it anything wrong. Just weird.....no accessories on except maybe the heat/fans. And other times just turning fans on - it'll ramp up in rpm's.
     
  5. Jan 19, 2009 at 3:20 PM
    #5
    Rustystp

    Rustystp Member

    Joined:
    Jan 18, 2009
    Member:
    #12698
    Messages:
    6
    Gender:
    Male
    KY
    Vehicle:
    2007 4x4 Taco
    Just had my 07 in the dealer for rough idle. It seems there is a problem with the cam timing position switch. They ordered me a new one. Hope this fixes the problem
     
  6. Jan 19, 2009 at 3:24 PM
    #6
    tacomaman06

    tacomaman06 Carolina Alliance: Lead, follow, or get the hell o Thor

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,351
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '13 Silverado ext cab
    when i had my 06, and took out the secondary air filter.......my idle was smoother. most will say that removing the 2nd filter doesnt do anything, but i know for a fact that my idle seemed smoother.
     
  7. Jan 2, 2011 at 10:44 AM
    #7
    streetlightning

    streetlightning Member

    Joined:
    Jan 1, 2011
    Member:
    #48568
    Messages:
    19
    Gender:
    Male
    Denver, CO
    Vehicle:
    '12 Tacoma TRD T/X Pro
    Did they replace your cam position timing switch? I'm curious as the dealer can't find what's wrong with my 2011 Tacoma as its underpowered and idles rough. Its not throwing any codes so they don't know where to start looking.
     
  8. Jan 2, 2011 at 10:56 AM
    #8
    Tacomanator

    Tacomanator Boiling denim and bangin whores

    Joined:
    Jul 25, 2010
    Member:
    #40746
    Messages:
    4,581
    Gender:
    Male
    First Name:
    Clam Slammer
    Here
    King 2.5" extended travel coilovers with compression adjusters, Camburg UCA's, King 2.5" rear shocks, Volant cold air intake with ram air scoop.
    mine also seems to run a little rough at times, but i'm also over do for a spark plug change :eek:
     
  9. Feb 8, 2012 at 1:09 PM
    #9
    Jonniebb

    Jonniebb Member

    Joined:
    Oct 8, 2009
    Member:
    #23974
    Messages:
    6
    Gender:
    Male
    First Name:
    Jon
    Mesa, AZ
    Vehicle:
    07 4D SB 4x4 Off Rd 6 SP
    I am curious about the cam timing switch. My 07 has idled rough for a while now. My mechanic noticed it when we were getting ready to replace plugs so I hoped the plugs would do it. No difference.

    I just put new, more aggressive tires on and gas mileage has dipped. Wondered if it was all the tires or some efficiency issue coupled with the rough idle.
     
  10. Mar 2, 2012 at 9:59 AM
    #10
    rondog

    rondog your TW web developer!

    Joined:
    Nov 2, 2010
    Member:
    #45618
    Messages:
    2,032
    Gender:
    Male
    First Name:
    Ronnie
    Escondido/San Diego
    Vehicle:
    pewp
    Total Chaos LT, 2.5x8" Fox coilover, 2.5x8" Fox triple bypass, GIANT SUA rear LT, 2.5x18" Fox triple bypass, 285/70/17 Toyo AT2, Glassworks all around, 4x Eagle Eye HIDs
    mine has started doing this more often now. Its weird because half the time it is happening, I can turn my vent blower all the way up and the idle is a lot rougher and then I turn it down and it almost goes away. The other half the truck is idling weird, the vent blower has no effect on it.
     
To Top