1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Running/ headlights auto shut off not working?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by hondarider215, Apr 13, 2012.

  1. Apr 13, 2012 at 6:40 PM
    #1
    hondarider215

    hondarider215 [OP] Well-Known Member

    Joined:
    Feb 2, 2012
    Member:
    #71969
    Messages:
    317
    Gender:
    Male
    First Name:
    Wes
    Socal
    Vehicle:
    KR Tacoma
    KR Fabrication front and rear bumper ICON 2.5 c/o's All pro leafs Maxtrac Fox rear resi shocks Lr uca 17" methods
    I have had my tacoma for about 2 months now with no probelms. I always drive around with my running lights on and never turn them off. I know they are suppose to auto shut off when i turn the truck off and remove the key and open the door. I noticed the other day that when i was walking to my truck the running lights were still on and when i got into my truck my guage lights were on also. I put my key in and started it than took the key out again and opened the door trying to make them auto turn off. They didnt auto turn off till about my 4th attempt. Im worried because i dont want my lights to stay on and my battery die. I know i can just toggle them off but i like the fact that they auto turn off. Is there a problem with the wiring somewhere? Could i fix this? Anybody else have this problem?
     
  2. Apr 13, 2012 at 9:16 PM
    #2
    hondarider215

    hondarider215 [OP] Well-Known Member

    Joined:
    Feb 2, 2012
    Member:
    #71969
    Messages:
    317
    Gender:
    Male
    First Name:
    Wes
    Socal
    Vehicle:
    KR Tacoma
    KR Fabrication front and rear bumper ICON 2.5 c/o's All pro leafs Maxtrac Fox rear resi shocks Lr uca 17" methods
    Bump..Anyone know what could possibly be causing this?
     
  3. Apr 14, 2012 at 5:29 PM
    #3
    hondarider215

    hondarider215 [OP] Well-Known Member

    Joined:
    Feb 2, 2012
    Member:
    #71969
    Messages:
    317
    Gender:
    Male
    First Name:
    Wes
    Socal
    Vehicle:
    KR Tacoma
    KR Fabrication front and rear bumper ICON 2.5 c/o's All pro leafs Maxtrac Fox rear resi shocks Lr uca 17" methods
    Thanks man. I have driven my truck around today with no problems hopefully it was just something i was doing that was disabling it
     
  4. Apr 14, 2012 at 6:10 PM
    #4
    Rich91710

    Rich91710 Well-Known Member

    Joined:
    Feb 23, 2012
    Member:
    #73470
    Messages:
    16,404
    Gender:
    Male
    First Name:
    Rich
    Los Angeles
    Vehicle:
    08 Base
    Satoshi with FJ badge, factory cruise, factory intermittent wipers, Redline Tuning hood-lift struts, Hellwig Swaybar, Rosen DVD-Nav
    Tails or headlights.

    If I shut my lights off, open the door, then turn them back on, they remain on no matter what I do with the door until I turn the ignition on and back off.

    Likewise, leave them on, open the door, then turn them off and back on, they remain on no matter what I do with the door until I turn the ignition on and back off.


    It could be an intermittent connection in the turn signal stalk or the wiring between the stalk and BCM/relay box that is sending a momentary "off/on" command to the BCM.
     
  5. Apr 14, 2012 at 8:30 PM
    #5
    muisejt

    muisejt Well-Known Member

    Joined:
    Nov 12, 2011
    Member:
    #66923
    Messages:
    222
    Gender:
    Male
    YMM
    Vehicle:
    08 TRD Sport DC LB
    Katzkin, Bi-xenon Morimoto Mini Stage III Kit (D2S), 4Runner Mirrors, Complete Stereo Upgrade with Backup Camera, Pop&Lock PL5400, Extang Solid Fold Tonneau, TRD OR Tow Hook, rcbs204 4x4 Illuminated Switch, Grillcraft, 10" Rigid light bar behind grill, relocated horns, Redline Tuning hood struts, 5100's with 883 and Wheeler 5 leaf, OME carrier barring drop kit, ECGS Bushing, MarionB2B front hubs
    check the door switch, this may not be your problem as mine only sticks when it's like -30C out, but real easy to checks as it's right there when you open the door
     
  6. Apr 14, 2012 at 11:23 PM
    #6
    hondarider215

    hondarider215 [OP] Well-Known Member

    Joined:
    Feb 2, 2012
    Member:
    #71969
    Messages:
    317
    Gender:
    Male
    First Name:
    Wes
    Socal
    Vehicle:
    KR Tacoma
    KR Fabrication front and rear bumper ICON 2.5 c/o's All pro leafs Maxtrac Fox rear resi shocks Lr uca 17" methods

    If you have your key in the ignition in the on position with your lights on and with your door shut and you put key to ignition off and pull key out than open your door do your lights turn off automatically? This is where im having my problem where the lights on the gauge and headlights/running lights dont shut off when i have ignition off and key out and door open
     
  7. Apr 14, 2012 at 11:24 PM
    #7
    hondarider215

    hondarider215 [OP] Well-Known Member

    Joined:
    Feb 2, 2012
    Member:
    #71969
    Messages:
    317
    Gender:
    Male
    First Name:
    Wes
    Socal
    Vehicle:
    KR Tacoma
    KR Fabrication front and rear bumper ICON 2.5 c/o's All pro leafs Maxtrac Fox rear resi shocks Lr uca 17" methods

    It might be sticking ill have to check it out in the morning
     
  8. Apr 14, 2012 at 11:25 PM
    #8
    4x4jeep

    4x4jeep Well-Known Member

    Joined:
    Jan 11, 2010
    Member:
    #29180
    Messages:
    1,031
    Gender:
    Male
    First Name:
    Kyle
    Destin FL.
    I have the same problem. I have to bump the access cab door before getting out for the lights to turn off
     
  9. Apr 14, 2012 at 11:27 PM
    #9
    hondarider215

    hondarider215 [OP] Well-Known Member

    Joined:
    Feb 2, 2012
    Member:
    #71969
    Messages:
    317
    Gender:
    Male
    First Name:
    Wes
    Socal
    Vehicle:
    KR Tacoma
    KR Fabrication front and rear bumper ICON 2.5 c/o's All pro leafs Maxtrac Fox rear resi shocks Lr uca 17" methods

    bump it shut?
     
  10. Apr 14, 2012 at 11:36 PM
    #10
    4x4jeep

    4x4jeep Well-Known Member

    Joined:
    Jan 11, 2010
    Member:
    #29180
    Messages:
    1,031
    Gender:
    Male
    First Name:
    Kyle
    Destin FL.
    No bump it with my elbow on the way out of the truck haha
     
  11. Apr 14, 2012 at 11:45 PM
    #11
    hondarider215

    hondarider215 [OP] Well-Known Member

    Joined:
    Feb 2, 2012
    Member:
    #71969
    Messages:
    317
    Gender:
    Male
    First Name:
    Wes
    Socal
    Vehicle:
    KR Tacoma
    KR Fabrication front and rear bumper ICON 2.5 c/o's All pro leafs Maxtrac Fox rear resi shocks Lr uca 17" methods
    oh okay lol. So you have to bump your access cab door. Im a double cab. So its probably the door switch not working right.
     
  12. Apr 14, 2012 at 11:46 PM
    #12
    Rich91710

    Rich91710 Well-Known Member

    Joined:
    Feb 23, 2012
    Member:
    #73470
    Messages:
    16,404
    Gender:
    Male
    First Name:
    Rich
    Los Angeles
    Vehicle:
    08 Base
    Satoshi with FJ badge, factory cruise, factory intermittent wipers, Redline Tuning hood-lift struts, Hellwig Swaybar, Rosen DVD-Nav
    Ya, when I shut the door, the lights shut off.

    But once I manually turn the lights off, if I turn them back on, they remain on until I cycle the ignition and then open the door again.
     
  13. Apr 14, 2012 at 11:47 PM
    #13
    hondarider215

    hondarider215 [OP] Well-Known Member

    Joined:
    Feb 2, 2012
    Member:
    #71969
    Messages:
    317
    Gender:
    Male
    First Name:
    Wes
    Socal
    Vehicle:
    KR Tacoma
    KR Fabrication front and rear bumper ICON 2.5 c/o's All pro leafs Maxtrac Fox rear resi shocks Lr uca 17" methods

    oh okay thats all normal than. Thats how my truck works when all is well.
     
To Top