1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Rust on Steel wheels and Stock chrome bumper...

Discussion in 'Wheels & Tires' started by swendling12, Mar 7, 2010.

  1. Mar 7, 2010 at 4:25 PM
    #1
    swendling12

    swendling12 [OP] Well-Known Member

    Joined:
    Dec 30, 2009
    Member:
    #28486
    Messages:
    403
    Gender:
    Male
    First Name:
    Sean
    Nebraska
    Vehicle:
    09 Reg Cab SR5 4 cyl 5spd 4x4
    Went to the dealer on Saturday to have them check out the rust pitting that is coming out on my stock SR5 steel wheels. When i washed my truck today i noticed that my chrome rear bumper is rust pitting also. They are having someone from Toyota Corporate come out to look at them to decide what actions to take... The truck is only 11 months old, with 14k miles...


    Anyways, anyone else having this happen? No pics, since i would have to have a macro lens...
     
  2. Mar 7, 2010 at 4:34 PM
    #2
    madcatter

    madcatter Well-Known Member

    Joined:
    Feb 14, 2010
    Member:
    #31350
    Messages:
    109
    Gender:
    Male
    western pa
    Vehicle:
    2010 tacoma
    jl audio stealthbox jl audio slash g2-500/1v2 good year dura-tracs jl audio g-class 50wattX2amp mb quart 5 1/4" rear matted mb quart 6.5 comp.set lotsa dynamat 4ga amp kit 16 gauge wire kit control knob on dash pioneer avic-x910bt in dash navigation dvd playback sirus tuner/bus interface built in blue tooth toyota environmental package leaf tsb weather tech floor liners yellow wire mod gray wire mod compartment bed lights added tie down d rings
    my 2010 has chrome bumper and at 1800 miles looks like this,i requested a all black bumper and they are doing it this friday
    here are the pics again
    you are gonna get alot of guys bitchin cuase you aint happy with your stuff,get ready for it.
    [​IMG]
    [​IMG]
    [​IMG]

    they are gonna say you are lazy for not wanting to spend 1 hour every 5 days tpo rub rust off a piece of shit rim/bumper....sounds like some cost cutting measures or a bad batch of chrome
    the dealer ship didnt even say anything but---aww man thats a problem,we will replace it.
     
  3. Mar 7, 2010 at 4:40 PM
    #3
    ColtsTRD

    ColtsTRD .....

    Joined:
    May 13, 2009
    Member:
    #17177
    Messages:
    17,826
    Gender:
    Male
    First Name:
    Scott
    AZ
    Vehicle:
    2005 TRD DCSB
    Damn guys...i'm sorry about your luck. The midwest and eastern states weather is rough on metals eh? :(
     
  4. Mar 7, 2010 at 4:44 PM
    #4
    madcatter

    madcatter Well-Known Member

    Joined:
    Feb 14, 2010
    Member:
    #31350
    Messages:
    109
    Gender:
    Male
    western pa
    Vehicle:
    2010 tacoma
    jl audio stealthbox jl audio slash g2-500/1v2 good year dura-tracs jl audio g-class 50wattX2amp mb quart 5 1/4" rear matted mb quart 6.5 comp.set lotsa dynamat 4ga amp kit 16 gauge wire kit control knob on dash pioneer avic-x910bt in dash navigation dvd playback sirus tuner/bus interface built in blue tooth toyota environmental package leaf tsb weather tech floor liners yellow wire mod gray wire mod compartment bed lights added tie down d rings
    i dont think its the area,seems that everyone elses chrome is just fine,just some from toyota and also some aftermarket product.i spent about 10 hours last week at aftermarket shop and overheard alot of rust problems on several different brands of bumpers,bars,sliders
    seems someone has a bad chrome batch out there,when its done and they mix up a new batch the problem will probably be over,
    just some also,not every toyota in the snow belts has this problem,but i have to say mine looks like a problem
     
  5. Mar 7, 2010 at 4:59 PM
    #5
    Simon's Mom

    Simon's Mom Wag More Bark Less

    Joined:
    Apr 12, 2007
    Member:
    #1297
    Messages:
    9,323
    Gender:
    Female
    First Name:
    Judy or Jude :)
    SBurl Vermont
    Vehicle:
    13 TRD OR DC MGM
    Stock for now
    My 2006 Chrome bumper looks nothing like the pics above after 3 salty winter seasons. Not a spot of rust on the chrome. The steel wheels on the other hand have some spots, but they are my winter wheels now anyway.
     
  6. Mar 7, 2010 at 5:08 PM
    #6
    Tsenekos

    Tsenekos Well-Known Member

    Joined:
    Aug 17, 2009
    Member:
    #21319
    Messages:
    1,046
    Gender:
    Male
    First Name:
    Greg
    Edmonton, CANADA
    Vehicle:
    2005 DC 4WD trd offroad
    Toytec 3" lift w coils,1.5 AAL,5100's all around,diff drop kit, axel shims,N-Fab nerf bars,bestop supertop,fog mod, weathertech mats
    wow my chrome bumper is 5 yrs old in canada on salt winter roads and looks new still whats toyota doing differnently these days ?????
     
  7. Mar 7, 2010 at 5:40 PM
    #7
    dexterdog

    dexterdog My pee parts itch

    Joined:
    Jul 12, 2009
    Member:
    #19571
    Messages:
    4,276
    Gender:
    Male
    Oly WA
    Vehicle:
    2012 F150
    The OEM rear bumper on my truck does not look to have a very good chrome finish which may be by design to avoid blinding drivers in the rear. Good thing I plan to paint it, though.
     
  8. Mar 7, 2010 at 7:14 PM
    #8
    swendling12

    swendling12 [OP] Well-Known Member

    Joined:
    Dec 30, 2009
    Member:
    #28486
    Messages:
    403
    Gender:
    Male
    First Name:
    Sean
    Nebraska
    Vehicle:
    09 Reg Cab SR5 4 cyl 5spd 4x4
    imo the chrome on the bumper seems to be very thin. if anything ill get f^d because i dont have my mud flaps on. they got broken off driving im snow this winter. as far as the wheels go, theres no owner error, purely a bad paint job.
     
  9. Mar 7, 2010 at 7:24 PM
    #9
    Razorecko

    Razorecko Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18125
    Messages:
    1,447
    Gender:
    Male
    Vehicle:
    '09 Pyrite DCLB TRD Supercharged
    ....chrome from china.
     
  10. Mar 7, 2010 at 9:14 PM
    #10
    WilsonTheDog

    WilsonTheDog Kylie's dad

    Joined:
    Nov 17, 2007
    Member:
    #3496
    Messages:
    4,837
    Gender:
    Male
    First Name:
    Eric
    Myrtle Beach SC
    Vehicle:
    07 Prerunner SR5 DC/SB V6
    Magnaflow 12576 muffler & chrome tip, Westin step bars, 27% tint, Pop N Lock, AFE ProdryS, bed mat, Husky liners, D-rings added, Access Literider tonneau, Pioneer 4-ways all around, GY Wrangler Duratracs 265/75/16, 5100's @ 1.75", 1.5" AAL
    Just from what I've noticed on the forums here, seems like '09-'10's have this issue. I can't comment on mine because I have a replacement (rear ended a month after I bought it).
     
  11. Mar 7, 2010 at 9:45 PM
    #11
    swendling12

    swendling12 [OP] Well-Known Member

    Joined:
    Dec 30, 2009
    Member:
    #28486
    Messages:
    403
    Gender:
    Male
    First Name:
    Sean
    Nebraska
    Vehicle:
    09 Reg Cab SR5 4 cyl 5spd 4x4
    Honestly,after reading some of the posts elsewhere on the forum, i just want people to know that I'm not posting to bitch about it. I've gone to my Toyota dealer to have them look at it. I'm merely inquiring if my situation is similar to anyone else. After seeing your bumper madcatter and isthatahemi's bumper on this thread,
    http://www.tacomaworld.com/forum/2nd-gen-tacomas/78083-toyota-rust-quality-issues-rant.html, i can say that i was over reacting to my bumper.
     
  12. Mar 7, 2010 at 9:48 PM
    #12
    WilsonTheDog

    WilsonTheDog Kylie's dad

    Joined:
    Nov 17, 2007
    Member:
    #3496
    Messages:
    4,837
    Gender:
    Male
    First Name:
    Eric
    Myrtle Beach SC
    Vehicle:
    07 Prerunner SR5 DC/SB V6
    Magnaflow 12576 muffler & chrome tip, Westin step bars, 27% tint, Pop N Lock, AFE ProdryS, bed mat, Husky liners, D-rings added, Access Literider tonneau, Pioneer 4-ways all around, GY Wrangler Duratracs 265/75/16, 5100's @ 1.75", 1.5" AAL
    Nah, you're not bitching. You have a legitimate complaint because there should be absolutely no rust on a bumper as new as yours.
     
To Top