1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Screeching sound when I turn steering wheel...

Discussion in 'Technical Chat' started by acmair, Apr 12, 2010.

  1. Apr 12, 2010 at 8:53 PM
    #1
    acmair

    acmair [OP] Well-Known Member

    Joined:
    Dec 7, 2009
    Member:
    #27179
    Messages:
    2,463
    Gender:
    Male
    First Name:
    Andrew
    Vehicle:
    '10 BSP PreRunner Dbl Cab Short Bed SR5
    I have two Corollas, with 108K and 190K miles. They both make horribly annoying screeching sounds when I turn the steering wheel. I added power steering fluid and it made it a little better temporarily. I know its not a Tacoma, but maybe the reason might be the same.

    Anyone know what the problem might be, or what the easiest way to fix it is?

    Thanks
     
  2. Apr 12, 2010 at 8:55 PM
    #2
    WhatThePho?

    WhatThePho? Greg Graffin 2016

    Joined:
    Jun 30, 2009
    Member:
    #19096
    Messages:
    5,396
    Gender:
    Male
    First Name:
    Andre
    HCMC, VN
    Vehicle:
    2006 STi
    The things required to pull bitches
    is it a belt screech? tighten up the belt or replace it.
     
  3. Apr 12, 2010 at 8:57 PM
    #3
    acmair

    acmair [OP] Well-Known Member

    Joined:
    Dec 7, 2009
    Member:
    #27179
    Messages:
    2,463
    Gender:
    Male
    First Name:
    Andrew
    Vehicle:
    '10 BSP PreRunner Dbl Cab Short Bed SR5
    It only happens when I turn the steering wheel. What connection does that have to any belt? I think the power steering pump is powered by the serpantine belt, but how would that matter?

    Could be though. I'll check it out! Any other suggestions?
     
  4. Apr 12, 2010 at 9:01 PM
    #4
    WhatThePho?

    WhatThePho? Greg Graffin 2016

    Joined:
    Jun 30, 2009
    Member:
    #19096
    Messages:
    5,396
    Gender:
    Male
    First Name:
    Andre
    HCMC, VN
    Vehicle:
    2006 STi
    The things required to pull bitches
    My belt screech when I go full lock on turning. Tightened it and it stopped. Now it screech when I start up.
     
  5. Apr 12, 2010 at 9:03 PM
    #5
    acmair

    acmair [OP] Well-Known Member

    Joined:
    Dec 7, 2009
    Member:
    #27179
    Messages:
    2,463
    Gender:
    Male
    First Name:
    Andrew
    Vehicle:
    '10 BSP PreRunner Dbl Cab Short Bed SR5
    Lol same! It used to screech when I turned all the way, now it screeches all the time. So I should check the tensioner i guess...
     
  6. Apr 12, 2010 at 10:36 PM
    #6
    PnoyBOS5

    PnoyBOS5 Well-Known Member

    Joined:
    Jan 10, 2010
    Member:
    #29087
    Messages:
    709
    Gender:
    Male
    First Name:
    kevin
    CA
    Vehicle:
    2013 PRERUNNER
    Maxtrac 4'' Spindes -Bilsteins 5100 @ 1.75" - All Pro Expo Leaf Pack - Extended Rear Shocks - PC 5001 wheels - 285/70/17 Goodyear Duratracs - Debadged -Red emblem - AFE Pro Dry-S Filter
    your powersteering is possibly leaking, have you checked if your powersteering fluid has decreased when you added more?

    i know because my 04 accord had that problem, air getting into the ps hose
     
  7. Apr 12, 2010 at 10:37 PM
    #7
    Krazie Sj

    Krazie Sj Resident Jackass

    Joined:
    Oct 9, 2008
    Member:
    #9849
    Messages:
    13,686
    Gender:
    Male
    First Name:
    Power Serge
    LV-426 (Acheron)
    Vehicle:
    07 TRD Off Road 4x4
    Borla Catback Exhaust, Airaid Short Ram Intake, 285x75R16 Mickey Thompson MTZs, 16" Konig Countersteer rims, ARB Bumper, All Pro LT w/Walker Evan Shocks front and back, All Pro expedition leaf pack, 10,000lb Superwinch, Intake Manifold Spacer, Bed Rack with ARB RTT, Rotopack and Hi Lift mounted, Husky Liner mats and an air freshener from 1995.
    Belt issue. Had a 91 corolla. Sometimes did it at full lock. Always did it on start up when cold.
     
  8. Apr 14, 2010 at 4:29 PM
    #8
    Isthatahemi

    Isthatahemi Well-Known Member

    Joined:
    Apr 29, 2009
    Member:
    #16582
    Messages:
    1,156
    Gender:
    Male
    Vehicle:
    TRD OFF ROAD
    BFG AT's, Weathertechs, Hoppy's brake controller.
    X2 on it being a loose belt.
     
To Top