1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

shitty stock head unit

Discussion in 'Audio & Video' started by jhodge83, Jun 4, 2008.

  1. Jun 4, 2008 at 2:00 PM
    #1
    jhodge83

    jhodge83 [OP] Any dog under 50# is a cat and cats are useless... Moderator

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    28,119
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?
    I had forgotten just how crappy the stock unit is until i had to put it back in yesterday to get my pioneer worked on. that thing blows in sound quality and looks. i only had my stock one in for like 2 months and been driving w/ the pioneer nav for over a year and the difference is crazy....and i havent even swapped out the speakers yet. craziness for sure!!
     
  2. Jun 5, 2008 at 11:10 AM
    #2
    06TRDbama

    06TRDbama Well-Known Member

    Joined:
    Sep 24, 2007
    Member:
    #2784
    Messages:
    51
    Maryville, TN
    Vehicle:
    06 Prerunner TRD Sport
    lol yep. i just sold my eclipse navi/dvd unit and am waiting for my single din kenwood to come in..not very much fun
     
To Top