1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Sloppy Steering Questions

Discussion in 'Suspension' started by THROUGHITALLDUDE, Oct 12, 2010.

  1. Oct 12, 2010 at 12:39 PM
    #1
    THROUGHITALLDUDE

    THROUGHITALLDUDE [OP] Someone didnt put the tailgate down!

    Joined:
    Aug 2, 2009
    Member:
    #20562
    Messages:
    1,515
    Gender:
    Male
    First Name:
    Jeff
    Southern California
    Vehicle:
    2005 Silver Tacoma
    285-75-17 Definity ATs - 16'' Chrome Moto Metal 951s - 4'' Maxtrac spindles - Rear Icon Progressive Leaf Pack - Magnaflow exhaust - Aftermarket LED Taillights - BHLM - Custom Wet Okle Seat Covers - Moog Tire Rods - US Spec Ipod - K&N High Flow Filter - Daytime Running Lights - TRD Skid Plate - Grillcraft - Hellas Mounted behind the grill
    Ok so just recently my truck has started to get a little sloppy when it comes to steering I have a 2.75'' lift and I know i need to get new UCA but i have had the lift for a good 7 months now and the steering seems to just started as a problem... so the steering feels really loose and i get the floating feeling very bad now in comparison to before. Is It possible this floating could start 7 months after my lift or is there something else causing this feeling. Also I started noticing it alot after my tires got rotated and I sat and watched the guy do it so nothing couldve been done that I wouldnt know about.....any ideas??:confused:
     
  2. Oct 12, 2010 at 1:02 PM
    #2
    THROUGHITALLDUDE

    THROUGHITALLDUDE [OP] Someone didnt put the tailgate down!

    Joined:
    Aug 2, 2009
    Member:
    #20562
    Messages:
    1,515
    Gender:
    Male
    First Name:
    Jeff
    Southern California
    Vehicle:
    2005 Silver Tacoma
    285-75-17 Definity ATs - 16'' Chrome Moto Metal 951s - 4'' Maxtrac spindles - Rear Icon Progressive Leaf Pack - Magnaflow exhaust - Aftermarket LED Taillights - BHLM - Custom Wet Okle Seat Covers - Moog Tire Rods - US Spec Ipod - K&N High Flow Filter - Daytime Running Lights - TRD Skid Plate - Grillcraft - Hellas Mounted behind the grill
  3. Oct 12, 2010 at 2:50 PM
    #3
    THROUGHITALLDUDE

    THROUGHITALLDUDE [OP] Someone didnt put the tailgate down!

    Joined:
    Aug 2, 2009
    Member:
    #20562
    Messages:
    1,515
    Gender:
    Male
    First Name:
    Jeff
    Southern California
    Vehicle:
    2005 Silver Tacoma
    285-75-17 Definity ATs - 16'' Chrome Moto Metal 951s - 4'' Maxtrac spindles - Rear Icon Progressive Leaf Pack - Magnaflow exhaust - Aftermarket LED Taillights - BHLM - Custom Wet Okle Seat Covers - Moog Tire Rods - US Spec Ipod - K&N High Flow Filter - Daytime Running Lights - TRD Skid Plate - Grillcraft - Hellas Mounted behind the grill
  4. Oct 12, 2010 at 2:57 PM
    #4
    YotaDan

    YotaDan Dan Vendor

    Joined:
    Apr 1, 2009
    Member:
    #15461
    Messages:
    2,232
    Gender:
    Male
    First Name:
    Dan
    Oregon
    Make sure the alignment hasn't gotten out of whack.
     
  5. Oct 12, 2010 at 3:01 PM
    #5
    THROUGHITALLDUDE

    THROUGHITALLDUDE [OP] Someone didnt put the tailgate down!

    Joined:
    Aug 2, 2009
    Member:
    #20562
    Messages:
    1,515
    Gender:
    Male
    First Name:
    Jeff
    Southern California
    Vehicle:
    2005 Silver Tacoma
    285-75-17 Definity ATs - 16'' Chrome Moto Metal 951s - 4'' Maxtrac spindles - Rear Icon Progressive Leaf Pack - Magnaflow exhaust - Aftermarket LED Taillights - BHLM - Custom Wet Okle Seat Covers - Moog Tire Rods - US Spec Ipod - K&N High Flow Filter - Daytime Running Lights - TRD Skid Plate - Grillcraft - Hellas Mounted behind the grill
    well when he rotated my wheels he had to use a torque on the front due to the fact that i have spidertrax and you cant use a impact gun can using a torque throw it out of whack ?
     
  6. Oct 12, 2010 at 3:06 PM
    #6
    08pretaco

    08pretaco Almost there

    Joined:
    Sep 26, 2008
    Member:
    #9502
    Messages:
    9,059
    Gender:
    Male
    First Name:
    Oliver
    az
    Vehicle:
    2014 Tundra 4x4 CM 5.7L SR5
    AFE pro dry s, Husky X-act Contour
    no using a torque wrench will not do anything bad. lugs do have a "required" torque for install...
     
  7. Oct 12, 2010 at 3:16 PM
    #7
    THROUGHITALLDUDE

    THROUGHITALLDUDE [OP] Someone didnt put the tailgate down!

    Joined:
    Aug 2, 2009
    Member:
    #20562
    Messages:
    1,515
    Gender:
    Male
    First Name:
    Jeff
    Southern California
    Vehicle:
    2005 Silver Tacoma
    285-75-17 Definity ATs - 16'' Chrome Moto Metal 951s - 4'' Maxtrac spindles - Rear Icon Progressive Leaf Pack - Magnaflow exhaust - Aftermarket LED Taillights - BHLM - Custom Wet Okle Seat Covers - Moog Tire Rods - US Spec Ipod - K&N High Flow Filter - Daytime Running Lights - TRD Skid Plate - Grillcraft - Hellas Mounted behind the grill
    right i was think like maybe he was just jerking the wrench around at the wrong angle and it maybe threw it off I don know i wouldnt imagine he did anything to it by rotating them but it just feels like my steering is kinda wild i am thinking i just need to buy some UCA
     
  8. Oct 12, 2010 at 3:17 PM
    #8
    08pretaco

    08pretaco Almost there

    Joined:
    Sep 26, 2008
    Member:
    #9502
    Messages:
    9,059
    Gender:
    Male
    First Name:
    Oliver
    az
    Vehicle:
    2014 Tundra 4x4 CM 5.7L SR5
    AFE pro dry s, Husky X-act Contour
    most of the time a place will do a free alignment check for you. maybe go and get it checked out at least!
     
  9. Oct 12, 2010 at 3:24 PM
    #9
    YotaDan

    YotaDan Dan Vendor

    Joined:
    Apr 1, 2009
    Member:
    #15461
    Messages:
    2,232
    Gender:
    Male
    First Name:
    Dan
    Oregon
    It's odd that it drove good and then started getting sloppy feeling. Makes me think the cams shifted or something.
     
  10. Oct 12, 2010 at 6:54 PM
    #10
    jr114

    jr114 Well-Known Member

    Joined:
    Nov 18, 2009
    Member:
    #26147
    Messages:
    1,176
    Gender:
    Male
    First Name:
    Jon
    SoCal
    Vehicle:
    Truck
    Icon Ext travel CO, Icon tubular uniball UCAs, Maxtrac Spindles, Icon RR rear w 2"aal.
    sounds like somehow your alignment may have gotten out of whack. id recheck it.
     
  11. Oct 12, 2010 at 9:26 PM
    #11
    OZ-T

    OZ-T Quite an experience to live in fear , isn't it ?

    Joined:
    Dec 15, 2009
    Member:
    #27584
    Messages:
    38,720
    Gender:
    Male
    First Name:
    Peter North
    British Columbia
    Vehicle:
    Mag Grey 09 Trd Sport DCLB 4x4
    OME 885x , OME shocks and Dakars , Wheelers SuperBumps front and rear , 275/70/17 Hankook ATm , OEM bed mat , Weathertech digifit floor liners , Weathertech in-channel vents , headache rack , Leer 100RCC commercial canopy , TRD bedside decals removed , Devil Horns by Andres , HomerTaco Satoshi
    Have you jumped it ?
     
To Top