1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Speedometer Issue

Discussion in '3rd Gen. Tacomas (2016+)' started by elduder, Jun 30, 2016.

  1. Jun 30, 2016 at 6:25 PM
    #1
    elduder

    elduder [OP] Well-Known Member

    Joined:
    Oct 15, 2015
    Member:
    #166771
    Messages:
    1,801
    Gender:
    Male
    Van WA
    Vehicle:
    2019 Voodoo Blue Tundra TRD Pro
    Has anyone noticed either that their needle speedometer is not accurate, or is moving erratically?

    I noticed today that mine looked like it was twitching while I was accelerating and decelerating. Also at times my digital would read 40 and the analog needle would be showing around 35 or so. It was actually off at just about any speed but not in a consistent way that might suggest a calibration issue. Seems like it is sticking while its moving and resulting in it being off and having a jerking motion rather than a smooth one.
     
  2. Jun 30, 2016 at 7:00 PM
    #2
    Lawfarin

    Lawfarin Well-Known Member

    Joined:
    Oct 25, 2015
    Member:
    #167659
    Messages:
    6,744
    Gender:
    Male
    First Name:
    Larry
    NY
    Vehicle:
    2017 Tacoma OR DCSB 4x4
    Been a few people here with that issue
     
  3. Jun 30, 2016 at 8:36 PM
    #3
    BrettsMac08

    BrettsMac08 Well-Known Member

    Joined:
    Dec 16, 2015
    Member:
    #172372
    Messages:
    418
    Kansas
    Vehicle:
    2016 DCSB TRD Sport | 2002 Camaro SS
    OVTuned | MagnaFlow Exhaust | OEM Audio Plus Reference 450Q | TRD Pro Wheels | AT Tires | LED Interior Lighting
    If it bothers you enough you can have the gauge cluster replaced under warranty. Mine didn't tick and I think all of them are slightly off with the digital vs analog readings. But mine did have the random resetting trip meter and MPG stats. So it got replaced
     
  4. Jun 30, 2016 at 10:15 PM
    #4
    elduder

    elduder [OP] Well-Known Member

    Joined:
    Oct 15, 2015
    Member:
    #166771
    Messages:
    1,801
    Gender:
    Male
    Van WA
    Vehicle:
    2019 Voodoo Blue Tundra TRD Pro
    I found some others with similar issues. I had noticed its always off by maybe 1 mph, but this was like it was getting stuck and it would stay showing one speed while the digital kept working normally. I'll try to catch it on video before wasting my time with the dealership.
     
  5. Jul 5, 2016 at 10:55 PM
    #5
    cctk2

    cctk2 GLACIERBIRD

    Joined:
    Jun 18, 2010
    Member:
    #39136
    Messages:
    932
    Gender:
    Male
    First Name:
    Chip
    NorCal and Alaska
    Vehicle:
    '68 FJ40, '16 TRD AC OR A/T WHITE
    Accessories: SnugTop Rebel canopy AVS Window Rain Deflectors TACOMA 6' Bed Mat Weathertech Mud Guards (4) Scanguage (re-installed from the '02) Tekonsha Voyager Brake controller (Chalet A frame pop-up.) Vinyl letter insets for tailgate. Garmin CS60 GPS mounting. Other misc décor in the form of decals.
    You got the trip meter cluster replaced? the issue with random resetting? This is turning into a major Toyota FUBAR.
     
  6. Jul 5, 2016 at 11:23 PM
    #6
    treehugger

    treehugger Well-Known Member

    Joined:
    Oct 11, 2015
    Member:
    #166436
    Messages:
    130
    Oregon
    Vehicle:
    2016 Tacoma TRD OR DC 4x4
    265/75/16 BFG AT2 Bilstein 5100 @ 1.75
    I have had this issue on and off. Twitches a lot and gets stuck. Thought I was losing my mind.
     
  7. Jul 6, 2016 at 3:50 PM
    #7
    zflyz

    zflyz Member

    Joined:
    Mar 28, 2016
    Member:
    #182649
    Messages:
    6
    Gender:
    Male
    Kent Ohio
    I noticed this the other day on a long road trip. After driving for about 4 hours on the highway and slowing down for traffic the speedometer began to act like it was skipping around when the speed got below 40. I also noticed a 6mph difference between digital readout and the needle at speeds below 50. The error went away as speed increased.
     
  8. Jul 6, 2016 at 4:01 PM
    #8
    damnfingers

    damnfingers Well-Known Member

    Joined:
    Apr 4, 2011
    Member:
    #54324
    Messages:
    592
    Gender:
    Male
    First Name:
    Gene
    Mississippi
    Vehicle:
    2016 Limited 2x4 DCSB
    :annoyed::facepalm:
     
  9. Jul 23, 2016 at 1:23 PM
    #9
    sandspike

    sandspike Member

    Joined:
    May 30, 2009
    Member:
    #17806
    Messages:
    11
    Gender:
    Male
    First Name:
    Don
    Florida
    Vehicle:
    16 Blazing Blue Pearl TRD OR 4x4 DCLB
    Bed extender, dual Supertone horn kit, Hitchsafe, Husky floor mats, Undercover hard tonneau, Rhino side steps
    I had my master meter replaced under warranty because the trip and fuel meters were randomly resetting, and now the new meter's speedometer is "jumping". After about 20 minutes at highway speed, it would move like a quartz watch second hand either up or down with my speed changes (2 to 3 mph per each jump), until I reached 40 mph. Below that it was smooth again. Until I was back out on the highway. Took a video to the dealer, they agreed it was an issue. They contacted Toyota, sent the video, and were told Toyota "currently considers this to be normal." Contacting Toyota on Monday.
     
  10. Jul 23, 2016 at 1:33 PM
    #10
    smitty99

    smitty99 I also bought a 4Runner

    Joined:
    Sep 10, 2015
    Member:
    #163923
    Messages:
    12,979
    Gender:
    Male
    Scottsdale
    Vehicle:
    16 TRDORDCSB 4x4 A/T (loaded w/ JBL)
    6112s/5160s & 3-leaf AAL;ubolt flip kit;Superbumps
    YGBFSM..... :frusty:

    My speedo needle ticks occasionally too. With the list of issues I have on my truck it is of the lowest priority and nearly impossible to replicate. I notice it on the freeway after driving for awhile (over an hour) maybe between 65 to 75mph. It will tick erratically up and down rather than smooth normal sweeping motion. It does not always happen so like I said it would be very hard to replicate. But if it's another "normal" abnormality well.... fuck it then I guess.:bananadead:
     
    mvusa and George1441 like this.
  11. Jul 23, 2016 at 3:03 PM
    #11
    Pistol Pete

    Pistol Pete Go Pokes!

    Joined:
    May 29, 2013
    Member:
    #105142
    Messages:
    4,011
    Gender:
    Male
    First Name:
    Eric
    Oklahoma
    Vehicle:
    2016 MGM DCSB OR 4x4
    Clazzio leather seat covers, CBI T3 front, SOS sliders, SCS Ray10s, 285/75/16 Duratracs, debadged, extra bed D-ring tiedowns, Advantage TorzaTop, OEM bed mat, custom center console organizer, Husky liners, remote start.
    I've been noticing the twitch as well. I thought I was seeing things lol
     
  12. Jul 23, 2016 at 4:00 PM
    #12
    bluelinetacoma

    bluelinetacoma Active Member

    Joined:
    Jul 15, 2016
    Member:
    #192105
    Messages:
    39
    Gender:
    Male
    I've noticed this too. Mine doesn't stick or jump but the digital speedometer is off of the needle by 1-2 mph at all times. Kind of annoying.
     
  13. Jul 23, 2016 at 4:57 PM
    #13
    cctk2

    cctk2 GLACIERBIRD

    Joined:
    Jun 18, 2010
    Member:
    #39136
    Messages:
    932
    Gender:
    Male
    First Name:
    Chip
    NorCal and Alaska
    Vehicle:
    '68 FJ40, '16 TRD AC OR A/T WHITE
    Accessories: SnugTop Rebel canopy AVS Window Rain Deflectors TACOMA 6' Bed Mat Weathertech Mud Guards (4) Scanguage (re-installed from the '02) Tekonsha Voyager Brake controller (Chalet A frame pop-up.) Vinyl letter insets for tailgate. Garmin CS60 GPS mounting. Other misc décor in the form of decals.
    Let me see if I'm getting this straight.
    1). The speedo odometer cluster is being replaced to correct the trip meter failure glitch.
    2). The trip meter glitch is solved at the expense of a failing speedometer.

    I'm in the throws of the trip meter failure problem (15 failures to date). Though I'm running a test operation with a operational error being the theory. 600 miles without a failure so far.
    =======
    By the way, on the subject of throbbing speedometer needles; my '02 SR5Taco would pulse quite a bit between 0 and about 40mph, but as I recollect it was when it was cold. Wild swings.
     
    Last edited: Jul 23, 2016
  14. Jul 23, 2016 at 5:57 PM
    #14
    beyer075

    beyer075 Rock Licker

    Joined:
    Jun 5, 2011
    Member:
    #57776
    Messages:
    230
    Gender:
    Male
    Northern Nevada
    Vehicle:
    2016 White TRDOR
    What do you think would cause the speedo to stick after a period of time? Mine has done it once and am not able to reproduce it.
     
  15. Jul 23, 2016 at 8:13 PM
    #15
    sxe4533

    sxe4533 Well-Known Member

    Joined:
    Sep 12, 2015
    Member:
    #164074
    Messages:
    590
    Gender:
    Male
    Edmond, OK
    Vehicle:
    2016 TRDORDCSBAT
    2015 TRD PRO suspension
    Mine did it once before my 5k service someone on here said low ATF could cause that checked mine was 1.2 quarts low now at 16k haven't done that since don't know if that was the fix for it but never happened again
     
  16. Jul 23, 2016 at 8:14 PM
    #16
    sxe4533

    sxe4533 Well-Known Member

    Joined:
    Sep 12, 2015
    Member:
    #164074
    Messages:
    590
    Gender:
    Male
    Edmond, OK
    Vehicle:
    2016 TRDORDCSBAT
    2015 TRD PRO suspension
    There is a thread about this with a video of it u could maybe serch for it
     
  17. Jul 23, 2016 at 8:23 PM
    #17
    beyer075

    beyer075 Rock Licker

    Joined:
    Jun 5, 2011
    Member:
    #57776
    Messages:
    230
    Gender:
    Male
    Northern Nevada
    Vehicle:
    2016 White TRDOR
    I've seen the threads and videos but nobody has figured out what the cause is. Just curious as to if anything new has come out.
     
  18. Jul 24, 2016 at 5:18 PM
    #18
    sandspike

    sandspike Member

    Joined:
    May 30, 2009
    Member:
    #17806
    Messages:
    11
    Gender:
    Male
    First Name:
    Don
    Florida
    Vehicle:
    16 Blazing Blue Pearl TRD OR 4x4 DCLB
    Bed extender, dual Supertone horn kit, Hitchsafe, Husky floor mats, Undercover hard tonneau, Rhino side steps
    I can recreate the needle jump at will: High, steady speed running for about 20 miles, then it will do it every time (both up and down) until I go below 40. Toyota thinks it is limited to when cruise is used, but I have never used cruise when it happens. And the trip meter reset issue was random - only happened 3 times in 5k miles, but Toyota said that was a problem (and the jumping speedometer isn't!?). My ATF fluid level was fine from the factory (I made the dealer check it at 10k miles).
     
    smitty99 likes this.
  19. Jul 24, 2016 at 6:50 PM
    #19
    beyer075

    beyer075 Rock Licker

    Joined:
    Jun 5, 2011
    Member:
    #57776
    Messages:
    230
    Gender:
    Male
    Northern Nevada
    Vehicle:
    2016 White TRDOR
    When you say high speed you talking 65-75mph? The one time I had it happen I was doing 75 for a couple hours prior. Unable to reproduce it.
     
  20. Jul 25, 2016 at 6:52 AM
    #20
    sandspike

    sandspike Member

    Joined:
    May 30, 2009
    Member:
    #17806
    Messages:
    11
    Gender:
    Male
    First Name:
    Don
    Florida
    Vehicle:
    16 Blazing Blue Pearl TRD OR 4x4 DCLB
    Bed extender, dual Supertone horn kit, Hitchsafe, Husky floor mats, Undercover hard tonneau, Rhino side steps
    On my truck, above 60 mph. Does it every time.
     

Products Discussed in

To Top