1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

speedometer issues

Discussion in 'Technical Chat' started by Stout890, May 12, 2011.

  1. May 12, 2011 at 12:09 AM
    #1
    Stout890

    Stout890 [OP] Well-Known Member

    Joined:
    May 8, 2011
    Member:
    #56287
    Messages:
    511
    Gender:
    Male
    First Name:
    Jason
    Rosamond ca
    Vehicle:
    99 prerunner sr5
    HID head lights, fagtech coil overs and an AAL, gay ass 2 inch body lift (soon to be removed) taneau cover, k&n intake, soon to have an axle swap with a E locker
    well guys i have a 99 ext cab that i picked up a week ago, it has some odd issues. one being that it has a dang ol spedo issue. so basically its 20mph off...

    i have 31x10.5 tires on it with a 2 inch body lift...so as far as i can think it should read a few miles to slow right...since i am covering more ground per revolution?

    but my trucks spedo problem seems to be the opposite way im about 20 miles off the other direction. so when im doing 70 it reads 90??? and the governor kicks in early at 80 mph now because it thinks its doing 100mph

    also the trip meter reads wrong it calculates milage way to fast when in reality it should be under calculating...wtf guys?

    anyone have this issue and how can i start to try and correct this?

    any ways thanks in advance for any input.:confused:
     
  2. May 12, 2011 at 2:59 AM
    #2
    daggertats

    daggertats Well-Known Member

    Joined:
    Jul 2, 2010
    Member:
    #39720
    Messages:
    544
    Gender:
    Male
    arden nc
    Vehicle:
    2010 tacoma 4x4 reg cab
    undercover tonneau ,bug deflector, removal of all tacoma emblems added a set of component speakers behind the rear seat egr in channel window visors
    there is a thread on here someplace that gives tire sizes and itll show how much that size will effect speedo readings.
     
  3. May 12, 2011 at 3:11 AM
    #3
    WhatThePho?

    WhatThePho? Greg Graffin 2016

    Joined:
    Jun 30, 2009
    Member:
    #19096
    Messages:
    5,488
    Gender:
    Male
    First Name:
    Andre
    HCMC, VN
    Vehicle:
    2006 STi
    The things required to pull bitches
    Sounds like the truck has been regeared. I'm having that problem right now since i have regeared my truck.

    To fix it you need a new speedo gear. It goes in the transmission output where the drive shaft meets the tranny.
     
  4. May 12, 2011 at 3:14 AM
    #4
    WhatThePho?

    WhatThePho? Greg Graffin 2016

    Joined:
    Jun 30, 2009
    Member:
    #19096
    Messages:
    5,488
    Gender:
    Male
    First Name:
    Andre
    HCMC, VN
    Vehicle:
    2006 STi
    The things required to pull bitches
To Top