1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Squeaky Window

Discussion in '2nd Gen. Tacomas (2005-2015)' started by no_werries, Sep 5, 2008.

  1. Sep 5, 2008 at 9:03 PM
    #1
    no_werries

    no_werries [OP] Well-Known Member

    Joined:
    Mar 15, 2008
    Member:
    #5302
    Messages:
    248
    Gender:
    Male
    Simcoe County, Ontario, Canada
    Vehicle:
    2005 4x4 reg cab Indigo Ink 5 speed
    CAI, 2 1/2" rear lift AAL, Ready Lift strut ext. & diff drop = 2 1/2" front lift, tweaked clutch, Magnaflo Muffler & Custom exhaust 265/75/16lt Nitto Terra Grappler 8ply on stock rims. Huskyliners
    My Driver side window of the 05 reg cab taco 4x4 is squeaking when it is all the way down, so i drive around always trying to get it to a good spot, its not a power window, and tips on a fix would be appreciated!
     
  2. Apr 9, 2012 at 3:50 PM
    #2
    Trowbocop

    Trowbocop Adventurer

    Joined:
    Apr 3, 2012
    Member:
    #76190
    Messages:
    1,208
    Gender:
    Male
    First Name:
    Mike
    So Cal
    Vehicle:
    03 Tacoma SR5
    Volant Cold Air Intake, 3" JBA Catback Exhaust, JBA Headers, rock sliders, Kobalt toolbox, bedlined rocker panels, derped grill, rims and emblems, custom rear bumper, OME Nitrocharger Sport Suspension 881s & Dakars +aal, 265-75-16 duratracs, Herculined bed, weathertech digital cut floormats, cb & external speaker, dumped exhaust after axle, FourWheelCamper
    I have the same problem with my 03 ex Cab! I am not sure why, but when it is all the way down it squeaks like crazy. But when I have it rolled 1-2 inches up- just uncomfortable enough not to put your arm out...the squeaking stops.

    I guess it's just from vibrations in the cab from driving fast on dirt...

    I haven't been able to figure out how to fix it yet, but I'll definitely post an update if I do!
     
To Top