1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Stock radio is malfunctioning... help!

Discussion in 'Audio & Video' started by 15tacoma615, Feb 6, 2020.

  1. Feb 6, 2020 at 8:02 AM
    #1
    15tacoma615

    15tacoma615 [OP] Active Member

    Joined:
    Apr 1, 2016
    Member:
    #182993
    Messages:
    27
    Gender:
    Male
    Franklin, TN
    Vehicle:
    2016 White Tacoma SR5, 2002 Gold Tacoma 5-lug
    I have a 2016 Tacoma 4door SR5. Stock head unit, I've only upgraded the tweeters (like everyone else). Bought the truck used. The stock radio has started to turn off and on about every minute while I'm driving. Is this a common issue? I don't have the extra money to buy a new head unit currently. I'd like to see if anyone has suggestions or knows if this is a common issue among third gen models with stock head units (non-JBL).


    Oh, I do have a CaliRaised behind the grill lightbar added but it in no way is connected to audio. (adding this just in case its important information)


    Thanks in advance!
     
    Last edited: Feb 6, 2020
    PennSilverTaco likes this.
  2. Feb 6, 2020 at 8:06 AM
    #2
    PennSilverTaco

    PennSilverTaco On the spectrum...

    Joined:
    Jul 15, 2014
    Member:
    #134007
    Messages:
    27,469
    Gender:
    Male
    First Name:
    Charlie
    Central Bucks, PA
    Vehicle:
    2010 RC auto 5-lug
    My best advice would be to check the fuse box, or pull the head unit and check the connections in the back; If you can't find the problem and/or it persists, then I would advise buying an aftermarket head unit instead of another stock head unit once you get the money to do so.
     
    15tacoma615 [OP] likes this.
  3. Feb 6, 2020 at 8:13 AM
    #3
    PennSilverTaco

    PennSilverTaco On the spectrum...

    Joined:
    Jul 15, 2014
    Member:
    #134007
    Messages:
    27,469
    Gender:
    Male
    First Name:
    Charlie
    Central Bucks, PA
    Vehicle:
    2010 RC auto 5-lug
    And my bad; For some reason I thought the gold 1st Gen in your avatar pic was the one with the stereo issue...

    :facepalm:

    I'm guessing your 3rd Gen is no longer under warranty? This is one of the reasons I generally hate factory radios!
     
  4. Feb 6, 2020 at 10:53 PM
    #4
    httuner

    httuner Well-Known Member

    Joined:
    Nov 17, 2015
    Member:
    #169871
    Messages:
    353
    Gender:
    Male
    Vehicle:
    2015 Tacoma TRD-OffroadPckg
    Completely normal with these radios; it plague the second gens too which has the exact same radio you got in your third gen.

    mine just quit on me a few weeks back; ended up spending 650 dollars to get a new radio; Pioneer nex4500 with Maestro RR harness and module to retain steering wheel control.

    hit the APP button and turn the key to the On position; hold down the button; turn your headlights on and off 3 times. The diagnostic mode will show up. See if there are any errors? Press INIT something like that; hold it and reset personalized data. See if that helps.
     
    15tacoma615 [OP] likes this.
  5. Feb 7, 2020 at 1:04 PM
    #5
    2017_TACOMA_LIMITED

    2017_TACOMA_LIMITED Well-Known Member

    Joined:
    Sep 14, 2018
    Member:
    #266228
    Messages:
    83
    Gender:
    Male
    First Name:
    Chris
    Vehicle:
    2019 Pro/2017 Limited/2014 Limited
    My wife had a similar issue. The radio in her 2014 Tacoma would go out and then reboot itself after hitting a bump. She took it to the nearest Toyota dealership and they did a radio update. It has been fine now for three years.
     

Products Discussed in

To Top