1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Strange problem with engine

Discussion in '1st Gen. Tacomas (1995-2004)' started by Austiegarrett94, Jun 10, 2014.

  1. Jun 10, 2014 at 4:56 PM
    #1
    Austiegarrett94

    Austiegarrett94 [OP] Member

    Joined:
    Jun 9, 2014
    Member:
    #131650
    Messages:
    7
    Gender:
    Male
    St george utah
    Vehicle:
    98 v6 extra cab
    Stock
    Hey guys I have a 98 Tacoma with 190 thousand on it it's all stock the problem I'm having is when I step on the throttle after a light or so fourth and the rpms are abt between 3500 and 4 it feels like it's cutting out in between shifts like it feels like it's lack of fuel pressure or something has anyone had this happen to them it started doing this abt 2 weeks ago and today i turned my over drive off while I was entering the freeway and I got on it and it was really bad started chugging and cutting out between 45 and 75 mph and the check engine light kicked on and started to blink for a few seconds and kick off ? Does anyone have a solution to what could be wrong thank you I think it could be a cylinder miss-firing but at an idle it sounds good? And now at a stop light with the ac on.... my idle flexuats between rpms like it'll shake is that common I do live in 100+ weather
     
    Last edited: Jun 10, 2014
  2. Jun 10, 2014 at 4:58 PM
    #2
    mwc273

    mwc273 Nothing is as it seems.

    Joined:
    May 10, 2013
    Member:
    #103900
    Messages:
    4,836
    Check your fuel filter...
     
  3. Jun 11, 2014 at 11:33 AM
    #3
    VintageFast

    VintageFast Well-Known Member

    Joined:
    May 17, 2012
    Member:
    #79017
    Messages:
    275
    Gender:
    Male
    First Name:
    Jim
    DFW, Texas
    Vehicle:
    02 Prerunner 3.4
    That was one heluva long sentence.
     
  4. Jun 11, 2014 at 12:10 PM
    #4
    tan4x4

    tan4x4 Well-Known Member

    Joined:
    Nov 30, 2011
    Member:
    #67982
    Messages:
    3,804
    Gender:
    Male
    First Name:
    Rick
    Folsom, CA
    Vehicle:
    99 Tacoma EC 4x4 2.7L Auto
    Bilsteins, OME 881's, 3-leaf AAL, Detroit TruTrac, Tundra brake swap, Michelin LTX AT2, Tranny skidplate, TC skidplate, CBI rear bumper, TG sliders, UltraGauge, PowerTank, Reverse Camera
    Must be pregnant .... missed a few periods :D
     
  5. Jun 11, 2014 at 12:18 PM
    #5
    se7enine

    se7enine MCMLXXIX

    Joined:
    Apr 18, 2013
    Member:
    #102322
    Messages:
    17,302
    Gender:
    Male
    Reno, NV
    Vehicle:
    98 Tacoma SR5 Xtra Cab 3.4L
    How long since you replaced your plugs?
     
    Last edited: Jun 11, 2014
  6. Jun 11, 2014 at 2:26 PM
    #6
    Timdj112

    Timdj112 Member

    Joined:
    Jun 5, 2014
    Member:
    #131304
    Messages:
    9
    Gender:
    Male
    First Name:
    Tim
    Tillamook, Oregon
    Vehicle:
    04 3.4L V6 SR5 Offroad Pkg
    There could be many reasons why your truck is doing all of these things. It does sound like a dirty fuel filter though. If you have the cash I would start with a simple tune up. Is it a 4 Cyl or V6? either way, a tune up should include a new air/fuel filter, new plugs/wires and an oil change at the very least.

    You may want to include new belts in there as well since you have so many miles, especially if they have not been replaced lately. Many places sell "Tune up kits" that have all of these things. You can buy them separately if you want certain brands though. Here is an example: http://www.ebay.com/itm/NGK-Wire-Sp...1998|Model:Tacoma&hash=item5d38028bd0&vxp=mtr

    If you do not get a kit I would definitely start with the fuel filter. It is a likely culprit and can cause all of these things. Plus, they are a very cheap guess.
     
  7. Jun 11, 2014 at 2:41 PM
    #7
    chowwwww

    chowwwww Well-Known Member

    Joined:
    Jun 9, 2014
    Member:
    #131583
    Messages:
    1,646
    Gender:
    Male
    Orange County
    Vehicle:
    03 Doublecab 4x4
    Billys 5100/Eibach and Wheelers Progressive 1.5 AAL with overload in
    My truck has a similar problem. it mainly happens at a light right when i am about to take off and a once in a while on the freeway but not to the point where it seems like its dying. it just dips a bit for a a second or 2 then back to normal. It feels like the fuel cuts out a bit. Im buying new air/fuel filters and spark plugs today. And Maybe Seafoam to clean the injectors before i switch out everything.
     
  8. Jun 11, 2014 at 3:01 PM
    #8
    Austiegarrett94

    Austiegarrett94 [OP] Member

    Joined:
    Jun 9, 2014
    Member:
    #131650
    Messages:
    7
    Gender:
    Male
    St george utah
    Vehicle:
    98 v6 extra cab
    Stock
    I put in a brand new fuel filter and still happening and it's a v6. And I haven't replaced the plugs yet I've only had the truck for any a year. I'll try a tune up and see what's happens from their thanks guys .
     
  9. Jun 11, 2014 at 3:05 PM
    #9
    chowwwww

    chowwwww Well-Known Member

    Joined:
    Jun 9, 2014
    Member:
    #131583
    Messages:
    1,646
    Gender:
    Male
    Orange County
    Vehicle:
    03 Doublecab 4x4
    Billys 5100/Eibach and Wheelers Progressive 1.5 AAL with overload in
    Im hoping changing those things on my truck will fix it. Also, might try to clean out the MAF with the spray cleaners.
     
  10. Jun 11, 2014 at 5:54 PM
    #10
    Timdj112

    Timdj112 Member

    Joined:
    Jun 5, 2014
    Member:
    #131304
    Messages:
    9
    Gender:
    Male
    First Name:
    Tim
    Tillamook, Oregon
    Vehicle:
    04 3.4L V6 SR5 Offroad Pkg
    Yea this can get far more expensive depending on how many parts you want to change. Let us know what the tuneup does!
     
  11. Jun 11, 2014 at 6:05 PM
    #11
    welterbf123

    welterbf123 Well-Known Member

    Joined:
    Jan 9, 2014
    Member:
    #120272
    Messages:
    420
    Gender:
    Male
    Columbus, OH
    Vehicle:
    2017 TRD Off Road
    12voltsolutions.com plug-n-play remote start system. OVTuned OEM Bed lights Underhood and footwell lights Garmin dash-cam Weathertech side vents, bug shield, mud flaps and floor mats Extang Encore tonnau cover OME BP51 Suspension Front & Back / Dakar Leaf Springs Light Racing UCA's XD Holeshot 17" x 9" Wheels Nitto Trail Grapplers 265/70/R17 TRD Pro Grille Raptor Lights iJDMToy 30" LED Hidden Bar Light Toyota Bed Step
    Throttle position sensor?...
     
  12. Jun 12, 2014 at 3:55 PM
    #12
    Austiegarrett94

    Austiegarrett94 [OP] Member

    Joined:
    Jun 9, 2014
    Member:
    #131650
    Messages:
    7
    Gender:
    Male
    St george utah
    Vehicle:
    98 v6 extra cab
    Stock
    Could it be a tranny going out. My check engine light is now on ?
     
  13. Jun 12, 2014 at 5:15 PM
    #13
    Austiegarrett94

    Austiegarrett94 [OP] Member

    Joined:
    Jun 9, 2014
    Member:
    #131650
    Messages:
    7
    Gender:
    Male
    St george utah
    Vehicle:
    98 v6 extra cab
    Stock
    Okay guys it's misfiring on cylinder 5 code p0305 and also random misfire code p0300 the truck hasn't had a tune up since 2007! I'm doing a tune up tomorrow what's the best spark plugs and wires for a v6 3.4
     
  14. Jun 13, 2014 at 10:09 AM
    #14
    welterbf123

    welterbf123 Well-Known Member

    Joined:
    Jan 9, 2014
    Member:
    #120272
    Messages:
    420
    Gender:
    Male
    Columbus, OH
    Vehicle:
    2017 TRD Off Road
    12voltsolutions.com plug-n-play remote start system. OVTuned OEM Bed lights Underhood and footwell lights Garmin dash-cam Weathertech side vents, bug shield, mud flaps and floor mats Extang Encore tonnau cover OME BP51 Suspension Front & Back / Dakar Leaf Springs Light Racing UCA's XD Holeshot 17" x 9" Wheels Nitto Trail Grapplers 265/70/R17 TRD Pro Grille Raptor Lights iJDMToy 30" LED Hidden Bar Light Toyota Bed Step
    I would go for Denso's or NGK's. But make sure all of your injectors are working. That may be your problem. Missing cylinders are often times due to injector malfunctions...
     
  15. Jun 13, 2014 at 1:05 PM
    #15
    4WD

    4WD cRaZy oLdmAn

    Joined:
    Jul 2, 2009
    Member:
    #19185
    Messages:
    23,974
    Gender:
    Male
    First Name:
    Doug
    Lakeside, Ca / Gardnerville, Nevada
    Vehicle:
    2004 DC TRD 4x
    Grey wire MOD, deck plate, diff breather MOD, 2nd gen. OME 883# on Tundra 5100's, OMD custom 3" leafsprings, rear shock relocation, Ivan Stewart TRD rims w/285/75/16's, '02 bumper MOD, Famous Fabrications sliders , LED interior/exterior lights, bed bar, Custom tube bumper, Old school KC day lighters,Red Ring 8" HID flood, Kenwood vhf 2M.. umm some other shit I'm forgetting right now

    oxygen....:)

    OP, mis fire codes on 3.4 are kinda common I'm finding, probably one of the dental floss sized primary wire off the coil pack, but since you're throwing codes anyway just get it analyzed so you can see all you're dealing with & OEM for 3.4 is Denso dual electrode
     
  16. Jun 13, 2014 at 2:49 PM
    #16
    Austiegarrett94

    Austiegarrett94 [OP] Member

    Joined:
    Jun 9, 2014
    Member:
    #131650
    Messages:
    7
    Gender:
    Male
    St george utah
    Vehicle:
    98 v6 extra cab
    Stock
    Who's sales those
     
  17. Jun 14, 2014 at 5:40 AM
    #17
    lipster

    lipster Well-Known Member

    Joined:
    Jul 20, 2012
    Member:
    #83026
    Messages:
    332
    Gender:
    Male
    First Name:
    Mike
    Northern MN
    Vehicle:
    2004 ext cab 3.4 auto TRD
    License plate frame
    Toyota, NAPA are two.
     
  18. Jun 14, 2014 at 9:54 AM
    #18
    Austiegarrett94

    Austiegarrett94 [OP] Member

    Joined:
    Jun 9, 2014
    Member:
    #131650
    Messages:
    7
    Gender:
    Male
    St george utah
    Vehicle:
    98 v6 extra cab
    Stock
    Got the new wires and plugs in run a lot better no more cutting out check engine light is still on. Thank guys I was thinking about cutting my cataletic converter out cause down where I live we don't do emission what's the pros and cons?
     
  19. Jun 14, 2014 at 5:49 PM
    #19
    chowwwww

    chowwwww Well-Known Member

    Joined:
    Jun 9, 2014
    Member:
    #131583
    Messages:
    1,646
    Gender:
    Male
    Orange County
    Vehicle:
    03 Doublecab 4x4
    Billys 5100/Eibach and Wheelers Progressive 1.5 AAL with overload in
    Was waiting to put more miles on before I reported back. 260mi of mix street, highway, and mountain and the engine has been running smooth. I only changed the fuel and air filter.
     
  20. Jun 14, 2014 at 7:30 PM
    #20
    4WD

    4WD cRaZy oLdmAn

    Joined:
    Jul 2, 2009
    Member:
    #19185
    Messages:
    23,974
    Gender:
    Male
    First Name:
    Doug
    Lakeside, Ca / Gardnerville, Nevada
    Vehicle:
    2004 DC TRD 4x
    Grey wire MOD, deck plate, diff breather MOD, 2nd gen. OME 883# on Tundra 5100's, OMD custom 3" leafsprings, rear shock relocation, Ivan Stewart TRD rims w/285/75/16's, '02 bumper MOD, Famous Fabrications sliders , LED interior/exterior lights, bed bar, Custom tube bumper, Old school KC day lighters,Red Ring 8" HID flood, Kenwood vhf 2M.. umm some other shit I'm forgetting right now

    You might as well change plugs too, it'll amaze you then with how it runs
     

Products Discussed in

To Top