1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Strange sound from engine

Discussion in '1st Gen. Tacomas (1995-2004)' started by dparoskie, Jul 23, 2008.

  1. Jul 23, 2008 at 2:38 PM
    #1
    dparoskie

    dparoskie [OP] Member

    Joined:
    Jul 23, 2008
    Member:
    #8093
    Messages:
    6
    va
    Vehicle:
    01 tacoma
    I have a pinging/ gurgling sound from the engine when it’s under any kind of load. Brought it into the shop and they clean the mass air flow sensor and it helps reduce it a little but it comes right back. Its acts up more on hot days and there is a drop in horsepower. Anybody know what’s going on with it or how to fix this problem?
     
  2. Jul 23, 2008 at 4:21 PM
    #2
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    you may want to try running a tank of mid grade or premium. slunds like its pinging due to fuel grade. you also may want to clean the throttle body and maybe the pcv valve too.
     
  3. Jul 23, 2008 at 4:30 PM
    #3
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,153
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    You also may want to run some Seafoam thru the system. If none of that works, it could be your knock sensor. :)
     
  4. Jul 23, 2008 at 4:33 PM
    #4
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    yeah, and a side note, if you do seafoam, go thru the brake booster line, its alot easier doing it that way, and it'll feed the whole intake and all.:)
     
  5. Jul 23, 2008 at 9:46 PM
    #5
    backwoodking

    backwoodking Well-Known Member

    Joined:
    Jan 18, 2007
    Member:
    #743
    Messages:
    53
    Thousand Oaks/Southern CA
    Vehicle:
    3.4 V6 Deck Plate and Cut Turn-Down
    Deck Plate, Hitch, Cut Turn-Down Exhaust, Tint, Clear Corners, Shell, Full Size bed in the pickup, Hopefully More Soon
    Yeah I would say this sounds like a pinging from carbon deposits on your valves. when they get hot they tend to cause pinging sounds with higher mileage engines. Especially under load or when it is hot. It helps to put better gas in and switch to a lower gear when going up a hill or hauling loads. A fuel injector cleaner might also help
     
  6. Jul 25, 2008 at 10:02 AM
    #6
    Thunder

    Thunder Member

    Joined:
    Jul 8, 2008
    Member:
    #7819
    Messages:
    17
    Portland, Or
    Vehicle:
    Tacoma
    bpu's
    When was last time you did basic maintenance stuff?
    A new cap & rotor, plugs and wires, etc can often bring your rig back to life.
    +1 on trying some premium gas...especially if you've got some substantial mileage on your ride...
     
  7. Jul 25, 2008 at 11:08 AM
    #7
    AFBombdude

    AFBombdude Member

    Joined:
    May 29, 2008
    Member:
    #6953
    Messages:
    24
    Litchfield, AZ
    Vehicle:
    '01 PreRunner SR5
    Bone Stock for now
    +1
     
To Top