1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Supercharger sounds different

Discussion in '2nd Gen. Tacomas (2005-2015)' started by W7ldcard, May 25, 2011.

  1. May 25, 2011 at 9:39 PM
    #1
    W7ldcard

    W7ldcard [OP] Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24593
    Messages:
    54
    Gender:
    Male
    So I am currently in Vegas after a 7 hour drive here. When we went to dinner tonight I noticed that my truck sounded different. I have had my super charger on for about 45000 miles. The truck was being more quite but the supercharger had a much larger grinding sound. Tomorrow I might take it to a dealership and see what they think it might be but I figured I might have more luck on the forum. My gf says the truck sounds more like an RC car. I checked the oil today but nothing else yet.
     
  2. May 25, 2011 at 9:45 PM
    #2
    rcbs204

    rcbs204 Well-Known Member Vendor

    Joined:
    Oct 2, 2009
    Member:
    #23681
    Messages:
    3,756
    Gender:
    Male
    Have you ever changed the gear oil in the nose drive? That is really important.
     
  3. May 25, 2011 at 9:46 PM
    #3
    rcbs204

    rcbs204 Well-Known Member Vendor

    Joined:
    Oct 2, 2009
    Member:
    #23681
    Messages:
    3,756
    Gender:
    Male
    Is this on a 3.4 litre, or a 4.0?
     
  4. May 25, 2011 at 9:48 PM
    #4
    rcbs204

    rcbs204 Well-Known Member Vendor

    Joined:
    Oct 2, 2009
    Member:
    #23681
    Messages:
    3,756
    Gender:
    Male
    Oh thats it your going down man!!
     
  5. May 25, 2011 at 9:50 PM
    #5
    W7ldcard

    W7ldcard [OP] Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24593
    Messages:
    54
    Gender:
    Male
    Any confirmation of this?
     
  6. May 25, 2011 at 9:51 PM
    #6
    W7ldcard

    W7ldcard [OP] Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24593
    Messages:
    54
    Gender:
    Male
    No I heard it has a service life of 100k miles with no service required. its a 4.0 on an 09 tacoma with 60k miles
     
  7. May 25, 2011 at 9:54 PM
    #7
    W7ldcard

    W7ldcard [OP] Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24593
    Messages:
    54
    Gender:
    Male
    Haha okay. Doesnt the air still need to pass through the lobes of the sc to get into the engine? Wouldnt disabling the sc make it impossible to get air to the engine?
     
  8. May 25, 2011 at 10:08 PM
    #8
    W7ldcard

    W7ldcard [OP] Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24593
    Messages:
    54
    Gender:
    Male
    Yea its just specifically the noise. I just need to figure out what the noise is and the issue before I can decide if I am able to drive home. I have work in two days so I need to figure out what to do by then.
     
  9. May 25, 2011 at 10:29 PM
    #9
    W7ldcard

    W7ldcard [OP] Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24593
    Messages:
    54
    Gender:
    Male
    What if my nose is going out would that be safe to drive like 450 miles on?
     
  10. May 26, 2011 at 10:41 AM
    #10
    W7ldcard

    W7ldcard [OP] Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24593
    Messages:
    54
    Gender:
    Male
    Yea after we get cleaned up for the day we are going to take a look at it and determine the exact problem.
     
  11. May 26, 2011 at 12:40 PM
    #11
    W7ldcard

    W7ldcard [OP] Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24593
    Messages:
    54
    Gender:
    Male
    Do you know of a website that has a walk through for this?
     
  12. May 26, 2011 at 2:58 PM
    #12
    Coupe

    Coupe Well-Known Member

    Joined:
    Feb 10, 2009
    Member:
    #13485
    Messages:
    1,645
    Gender:
    Male
    Houston, Texas
    Vehicle:
    08 X-Runner
    Lots baby!
    The gear oil is supposed to be good for 100K miles. The oil can be had at a GM dealer. GM has a lot of S/C vehicles. I believe 4 oz is the magic number.

    I would be more inclined to think the supercharger belt idler bearing is going bad. This happens pretty often. A screw driver to the ear, may help locate the noise.

    The other possibility is there is a spring loaded coupler inside the snout. This couples the pulley to the supercharger. This could be going bad.

    Good Luck.
     
  13. May 26, 2011 at 3:02 PM
    #13
    ktmrider

    ktmrider Senior Member

    Joined:
    Jul 20, 2009
    Member:
    #19933
    Messages:
    4,969
    Gender:
    Male
    Vehicle:
    07 DCLB 4x4 Sport S/C
    Junk
  14. May 26, 2011 at 5:24 PM
    #14
    W7ldcard

    W7ldcard [OP] Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24593
    Messages:
    54
    Gender:
    Male
    Sweet now to do the shopping only have one day to do this and hope thats the problem
     
  15. May 26, 2011 at 7:12 PM
    #15
    RX2RIDE

    RX2RIDE Well-Known Member

    Joined:
    Oct 25, 2009
    Member:
    #24876
    Messages:
    108
    Gender:
    Male
    Everett, WA
    Vehicle:
    09 TRD Tacoma (mine), 08 Sport 4 Runner(Wife)
    On a related note, How do you like you Supercharger( when it works).
     
  16. May 26, 2011 at 7:30 PM
    #16
    W7ldcard

    W7ldcard [OP] Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24593
    Messages:
    54
    Gender:
    Male
    Its awesome. I also have DT LT Headers and the URD High flow y pipe and exhaust. Its mean and fast
     
  17. May 26, 2011 at 7:30 PM
    #17
    W7ldcard

    W7ldcard [OP] Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24593
    Messages:
    54
    Gender:
    Male
  18. May 26, 2011 at 8:20 PM
    #18
    W7ldcard

    W7ldcard [OP] Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24593
    Messages:
    54
    Gender:
    Male
    Were going to dinner then a club tonight so I am going to get the supplies to drain the oil and refill it from the sc tomorrow before we head out.
     
  19. May 26, 2011 at 8:31 PM
    #19
    rcbs204

    rcbs204 Well-Known Member Vendor

    Joined:
    Oct 2, 2009
    Member:
    #23681
    Messages:
    3,756
    Gender:
    Male
    That sounds like a bad bearing, like the rotors are no longer concentric. Did your boost gauge show a decrease? And if you have exhaust temp gauge you could really tell if the EGT's are lower.
     
  20. May 26, 2011 at 8:48 PM
    #20
    W7ldcard

    W7ldcard [OP] Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24593
    Messages:
    54
    Gender:
    Male
    I dont have either :\ it idles fine and doesn't seem like there's any loss of performance. Just sounds MUCH louder and never had that grinding sound
     
To Top