1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

suspension squeek!!!! sooo annoying... help please

Discussion in 'Suspension' started by MMazz365, May 2, 2010.

  1. May 2, 2010 at 6:54 PM
    #1
    MMazz365

    MMazz365 [OP] Well-Known Member

    Joined:
    Nov 7, 2009
    Member:
    #25564
    Messages:
    649
    Gender:
    Male
    First Name:
    Michael
    NY
    Vehicle:
    TRD Off Road
    -flowmaster dual side exit exhaust -3 inch lift -cb radio -scanner -DTRL's -Fogs Anytime -Truxedo Soft Tonnahu Cover -eyelids -grillcraft upper and lower -fogs behind the grill
    Hey my 2010 tacoma trd off roads suspension squeeks so freaking bad.... its ridiculous. it gets me so angry.... im taking it in tomorrow to have rims tires and a lift put on so ill have them look at it but i hope its no big deal thing. any one expierence this? need help
     
  2. May 2, 2010 at 6:56 PM
    #2
    TacoTron

    TacoTron Tacotronn

    Joined:
    Nov 30, 2009
    Member:
    #26782
    Messages:
    2,275
    Gender:
    Male
    First Name:
    Anthony
    Albuquerque, NM
    Vehicle:
    07 Toyota Tacoma
    Fabtech Lift on top of 3 inch body lift. 34s trail grapplers on 18inch eagle alloys. KRFab Rear bumper, BHLM with HIDs, TRD seat covers, Hood scoop, N fab tire carrier, black valence, TRD intake, 40s Flowmasters, Foglight mod, best for last and thats my 4.56 gears, and much more too come.
  3. May 2, 2010 at 6:56 PM
    #3
    Blue

    Blue You're my boy blue

    Joined:
    Mar 14, 2010
    Member:
    #33255
    Messages:
    3,002
    Gender:
    Male
    First Name:
    Dylan
    Sierras
    Vehicle:
    ex 99 current 04 TRD
    No experience with squeaky suspension but I hope you get it all sorted out. Lets see some pics once you get back from the liftologist :D
     
  4. May 2, 2010 at 6:57 PM
    #4
    rmb_crew

    rmb_crew My other ride has 18,400HP!!!!!!

    Joined:
    Jan 21, 2009
    Member:
    #12837
    Messages:
    6,076
    Gender:
    Male
    First Name:
    Ryan
    Jacksonville, FL 30.243103, -81.591007‎
    Vehicle:
    2010 F150 XLT SuperCrew 4X4
    Access larado tonneau, magnaflow exhaust
    You and just about every other tacoma owner have the same problem. Best way to get it to stop is to separate the leafs at the friction pads and than grease them up really good. Will last for 6 months or so and than just regrease them.
     
  5. May 2, 2010 at 6:58 PM
    #5
    1337Taco

    1337Taco Sold all 3

    Joined:
    May 9, 2008
    Member:
    #6504
    Messages:
    7,373
    Gender:
    Male
    First Name:
    Kevin
    NorCal
    Vehicle:
    2012 4x4
    Kings
    Have you wheeled your truck? Might have dirt in between your leaf springs. Might need to grease some joints. But it's a 2010 so I don't know. Is it coming from the front or back?
     
  6. May 2, 2010 at 7:00 PM
    #6
    MMazz365

    MMazz365 [OP] Well-Known Member

    Joined:
    Nov 7, 2009
    Member:
    #25564
    Messages:
    649
    Gender:
    Male
    First Name:
    Michael
    NY
    Vehicle:
    TRD Off Road
    -flowmaster dual side exit exhaust -3 inch lift -cb radio -scanner -DTRL's -Fogs Anytime -Truxedo Soft Tonnahu Cover -eyelids -grillcraft upper and lower -fogs behind the grill
    mainly from the backk... and yeah ive been mudding quite a bit
     
  7. May 2, 2010 at 7:01 PM
    #7
    MMazz365

    MMazz365 [OP] Well-Known Member

    Joined:
    Nov 7, 2009
    Member:
    #25564
    Messages:
    649
    Gender:
    Male
    First Name:
    Michael
    NY
    Vehicle:
    TRD Off Road
    -flowmaster dual side exit exhaust -3 inch lift -cb radio -scanner -DTRL's -Fogs Anytime -Truxedo Soft Tonnahu Cover -eyelids -grillcraft upper and lower -fogs behind the grill

    ohh yeah definitely.... i cant wait
     
  8. May 3, 2010 at 5:16 PM
    #8
    NAYo2002

    NAYo2002 Well-Known Member

    Joined:
    Jan 16, 2009
    Member:
    #12655
    Messages:
    489
    Gender:
    Male
    Great Falls, MT
    Vehicle:
    '09 Tacoma 4x4 TRD Off Road
    Michelin LTX A/T2, TRD Skid Plate, WeatherTech DigiFit Liners, OEM Bed Extender, OEM Bed mat, Advantage TorzaTop Trifold Tonneau, Pop & Lock PL5300
    Used WD40 first year, it worked fine but now it doesnt work anymore.

    Took mine to the dealership today. They were very helpful and told me there's a TSB for the rear springs squeaking. They ordered lubricating pads and are going to install them for me when they come in. I love my dealership, they have never given me any issues when I can replicate problems for them. They usually tell me about TSBs, not the other way around.
     
  9. May 5, 2010 at 9:52 PM
    #9
    NAYo2002

    NAYo2002 Well-Known Member

    Joined:
    Jan 16, 2009
    Member:
    #12655
    Messages:
    489
    Gender:
    Male
    Great Falls, MT
    Vehicle:
    '09 Tacoma 4x4 TRD Off Road
    Michelin LTX A/T2, TRD Skid Plate, WeatherTech DigiFit Liners, OEM Bed Extender, OEM Bed mat, Advantage TorzaTop Trifold Tonneau, Pop & Lock PL5300
    Your is 2010, take it to the dealer and ask to check for service bulletins. There's one on replacing friction pads on springs.
     
  10. May 12, 2010 at 8:18 PM
    #10
    MMazz365

    MMazz365 [OP] Well-Known Member

    Joined:
    Nov 7, 2009
    Member:
    #25564
    Messages:
    649
    Gender:
    Male
    First Name:
    Michael
    NY
    Vehicle:
    TRD Off Road
    -flowmaster dual side exit exhaust -3 inch lift -cb radio -scanner -DTRL's -Fogs Anytime -Truxedo Soft Tonnahu Cover -eyelids -grillcraft upper and lower -fogs behind the grill
    yayyy done :)

    audi taco.jpg
    taco lift.jpg
     
To Top