1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Swi-jack help please

Discussion in 'Audio & Video' started by RDAY, Oct 21, 2009.

  1. Oct 21, 2009 at 11:08 AM
    #1
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    ok so i got it all installed but confused on programming.
    so i turn the key and it blinks 8 or 9 times
    then i hit program immedietly the light goes solid
    then i hold the volume up button until the light goes out and let go and press program agin to move onto volume down? It doesnt seem to be working for me.
     
  2. Oct 21, 2009 at 12:05 PM
    #2
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    ok so it was programmed for 9 not 8 so i got it done for 8
    so i turn it on it blinks 8 times
    then i press the program button it goes solid then i press the volume up button 8 or 9 times and the light goes out but it does not come back on?
     
  3. Oct 21, 2009 at 12:21 PM
    #3
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    anyone? i wanna get my truck closed up.
     
  4. Oct 21, 2009 at 12:31 PM
    #4
    Dark Knight

    Dark Knight Well-Known Member

    Joined:
    Jul 18, 2008
    Member:
    #8006
    Messages:
    9,591
    Gender:
    Male
    First Name:
    Jeff
    NC/SC
    Vehicle:
    4Runner Trail
    Follow this!!

    Current Information selected:
    The information we have on a 2005-2009 Toyota - Tacoma , has been generated below. 1. Quick description before we start wiring the SWI-JACK . The SWI-JACK 's wire color we are going to use is White. This is the White wire on the SWI-JACK , not the vehicle!
    The other wires on the SWI-JACK , green, yellow, orange and blue wires are not used for your Toyota Tacoma.

    This leaves you with a Red, Black and two loop wires. These wires will be discussed down below. 2. Picture of the Toyota Tacoma plug.
    [​IMG]

    The connector is viewed from the pin side not wire side. ​
    Fig. 1
    [​IMG] 3. Connecting the SWI-JACK 's steering wheel control input wire to vehicle plug.

    • Read the note in the chart below. These are the notes found in your instructions (note # 4) included with your SWI-JACK . If the vehicle is equipped with a JBL system the PAC TATO or Peripheral TJA is required.

    Note#​
    4 Connect pin 6 wire to ground. Connect pin 7 to the INTERFACE's White wire. Connect one end of a 560 ohm resistor to pin 8, then connect the other end of the resistor to the INTERFACE's white wire. So basically you will have two wires, one with a resistor in series, connected to the INTERFACE's White wire. Map/Info button is not used. ​
    4. Connecting power and ground wires. Black wire: Connect the SWI-JACK 's black wire to chassis ground. This is usually a black wire on the aftermarket wire kit.
    Red wire: Connect the SWI-JACK 's red wire to a switched +12volt wire. This is usually a red wire on the aftermarket wire kit. 5. Instructions for cutting or not cutting loop wires. Step A: The purple loop wire does not need to be cut.
    Step B: The brown loop wire does not need to be cut. 6. Programming the SWI-JACK with a version number. The SWI-JACK has to be programmed for version # 8. 1. Press and hold the Program Button on the SWI-JACK while turning on the vehicle to the accessory position. The LED will turn on. 2. Release the Program Button and the LED will turn off. 3. Press the Program Button 8 times. Each time you press and release the Program Button, the LED will turn on and off. Once you press the Program Button 8 times, wait for 3 seconds. The LED will flash 8 times indicating it is programmed for version 8. If it flashes the wrong version number, you will have to start all over at step 1 above in this section. Turn the key off. 4. Once you have programmed the correct version number, you will not have to do these steps again. If you need to reprogram the steering wheel control, you can go directly to the next section. 7. Programming the SWI-JACK to learn steering wheel control functions. 1. Turn the key to the accessory position (you do not need to hold the Program Button at this time). The LED will flash 8 times. This indicates it is programmed for version 8. 2. Press the Program Button until the LED turns on, then release the button (This will erase all previous learned steering wheel control functions). The SWI-JACK is now ready to learn a command from the steering wheel.
    3. The SWI-JACK must be programmed in the specific order shown in the chart below. If a function is not needed, it may be skipped. Adjust the Radio Select switch on the side of the SWI-JACK according to the chart. Alpine = 1, JVC = 2, Kenwood = 3, Clarion = 4 and Blaupunkt = 5.
    Alpine​
    JVC​
    Kenwood​
    Clarion​
    Blaupunkt​
    Switch setting for
    SWI-JACK ​
    1​
    2​
    3​
    4​
    5​
    1​
    Volume Up Volume Up Volume Up Volume Up Volume Up
    2​
    Volume Down Volume Down Volume Down Volume Down Volume Down
    3​
    Mute Mute/Power Mute Mute Mute
    4​
    Preset Up Preset Up Source Track Up
    Source
    5​
    Preset Down Source Seek Up Track Down Track up
    6​
    Source Seek Up Track Up Band Track down
    7​
    Track Up Seek Down Track Down Source Disc up
    8​
    Track Down Select Disc Up/FM Disc down
    9​
    Power Band Disc Down/AM OK
    10​
    Ent/Play
    11​
    Band/Program 4. With the LED on, press your steering wheel button until the light goes out and hold for one second more. 5. Release and the LED should come back on. If it does not please double check all connections and verify for correct version programming. 6. Repeat step 4 and 5 to program additional steering wheel buttons in the order corresponding to the chart above for your SWI interface. 7. If you come across a command in the chart that your steering wheel does not have, or you do not want to program, press the Program Button on the side of the SWI interface. 8. The LED will flash once rapidly and then stay on confirming that you have successfully skipped that command and are ready for the next button. 9. When you are done programming all the buttons, wait for about 7 seconds. The LED will flash 3 times indicating it is done programming. The LED will then flash 8 times indicating the version number. 8. Testing the SWI-JACK . 1. Connect the plug to back of radio's steering wheel input jack or harness. 2. With the vehicle on, press a steering wheel button to control the stereo. The SWI-JACK should control the aftermarket stereo with the function you taught it. Test all other buttons. 3. If the interface does not control the radio as the steering wheel indicates, the buttons were either pressed in the wrong order or a step was not skipped properly. Return to category 7 and reprogram. 4. Make sure all unused wires are isolated separately. 5. After all commands are verified to work properly, secure the SWI interface so that tension will not pull either of the connectors loose or apart. 6. That's it! Enjoy!
     
  5. Oct 21, 2009 at 12:31 PM
    #5
    Dark Knight

    Dark Knight Well-Known Member

    Joined:
    Jul 18, 2008
    Member:
    #8006
    Messages:
    9,591
    Gender:
    Male
    First Name:
    Jeff
    NC/SC
    Vehicle:
    4Runner Trail
    oh man that came out alll fudged up hold on....
     
  6. Oct 21, 2009 at 12:34 PM
    #6
    Dark Knight

    Dark Knight Well-Known Member

    Joined:
    Jul 18, 2008
    Member:
    #8006
    Messages:
    9,591
    Gender:
    Male
    First Name:
    Jeff
    NC/SC
    Vehicle:
    4Runner Trail
    go here

    click the bubble for the swi jack, then select toyota from drop down menu.

    now click Tacoma 2005-2009.

    and now your programing direction pop up
     
  7. Oct 21, 2009 at 12:39 PM
    #7
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    yea i have that all done but when it programs and the light goes off it doesnot come back on so i have a problem somewhere i am gonna call them i think
     
  8. Oct 21, 2009 at 12:42 PM
    #8
    Dark Knight

    Dark Knight Well-Known Member

    Joined:
    Jul 18, 2008
    Member:
    #8006
    Messages:
    9,591
    Gender:
    Male
    First Name:
    Jeff
    NC/SC
    Vehicle:
    4Runner Trail
    why are you pressing the volume up button 8-9 times. thats not the directions im pretty sure. you just press and hold it for a second, light blinks to notify it has ben programmed then move on to the next programing function.
     
  9. Oct 21, 2009 at 12:49 PM
    #9
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    hmm maybe i read them wrong i thought it said press the vol up button until the light goes out and then let go and the light will come back on then its programmed.
     
  10. Oct 21, 2009 at 1:33 PM
    #10
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    ok i think im ready to give up on it i tried the change track buttons like u said and it does it immedietly then when i tested the seek up button pauses it the seek down and th mode work fine nd i could not get the volumes to work at all.
     
  11. Oct 21, 2009 at 1:46 PM
    #11
    Dark Knight

    Dark Knight Well-Known Member

    Joined:
    Jul 18, 2008
    Member:
    #8006
    Messages:
    9,591
    Gender:
    Male
    First Name:
    Jeff
    NC/SC
    Vehicle:
    4Runner Trail
    I know its frustrating. All the functions will not work. I programmed volume, track, mute, and function only. It took me atleast 10 tries to get everything perfect
     
  12. Oct 21, 2009 at 4:24 PM
    #12
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    oh u gotta keep trying it if it dont work right?

    shouldnt my volume program tho when i press the volume button the light doesnt blink or go out like it should right away it goes out after holding it for 10 sec. tho and i cant get the light to come back on.
    i kindof wish i would of just forgot about the steering wheel controls because i have wasted so much time on it today and cant get everything to work I really want the volume to work tho.
     
  13. Oct 31, 2009 at 9:00 PM
    #13
    wing103

    wing103 Well-Known Member

    Joined:
    Jul 8, 2008
    Member:
    #7807
    Messages:
    1,130
    Gender:
    Male
    Boston
    Vehicle:
    Tacoma TRD Sport / Dark Gray
    Grill Craft upper & Lower Grill WetOK Seat Cover, Devil Horn, Bug, Windows Deflector, Side step Bar, HID 55W 8000K Headlight, HID 35W 4000K Foglight, Fog Light Mod, Interior LED Map Light Mod, Electric Tail Gate Lock, Leer Cab, Key ring light, Bed LED lights Mod, Kenwood DNX5120, Signal Mirror with Heat
    I still have a question, where is the white wire go from the swi-jack? I know I only have to connect the white to ?, black to ground, and the red to key power. Anything alse?

    Also where I can connect the reverse power ? and the 09 Tacoma back up camera? Please help......
     
To Top