1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Tacoma OEM Roof Rack

Discussion in '2nd Gen. Tacomas (2005-2015)' started by raswank, Mar 30, 2011.

  1. Mar 30, 2011 at 8:51 AM
    #1
    raswank

    raswank [OP] Well-Known Member

    Joined:
    Aug 1, 2010
    Member:
    #41087
    Messages:
    1,130
    Gender:
    Male
    First Name:
    Rick
    Auburn,Ma
    Vehicle:
    2010 Tacoma Double Cab 4x4 6 speed
    Grillcraft, Rear leaf TSB, 5100's at .85, with Eibachs, 265/70/17 BF Goodrich AT/S Tires, Hella 500's behind Grill, Kenwood KDC X995 H/U all Boston Acoustic speakers, JL Audio subs, Kenwood XR5 S amp, ATX Chrome 17x8 wheels
    The rack is on, but for the life of me I can't get the front to sit all the way down in the bracket. I have put a pad over it, and smacked with a mallet, and it will go all the way in. Am I going to have to take it all off gain? Or is there some trick to doing it?
     
  2. Mar 30, 2011 at 8:53 AM
    #2
    BryWi

    BryWi Psalm 109:8

    Joined:
    Dec 5, 2010
    Member:
    #47177
    Messages:
    1,769
    Gender:
    Male
    Earth
    Vehicle:
    2011 TRD off-road DC SB w/JBL
    5100s, black valance
    I read on a thread that if you bend the brackets a little it will sit more flush.

    Unfortunately that may require removal. :(

    I'll see if I can pull up the thread...
     
  3. Mar 30, 2011 at 9:06 AM
    #3
    BryWi

    BryWi Psalm 109:8

    Joined:
    Dec 5, 2010
    Member:
    #47177
    Messages:
    1,769
    Gender:
    Male
    Earth
    Vehicle:
    2011 TRD off-road DC SB w/JBL
    5100s, black valance
  4. Mar 30, 2011 at 9:32 AM
    #4
    Bama_TACO

    Bama_TACO ROLL TIDE!!!!!!!

    Joined:
    Aug 3, 2010
    Member:
    #41157
    Messages:
    1,017
    Gender:
    Male
    Winfield, AL
    Vehicle:
    2006 PreRunner Double Cab TRD SPORT
    Make sure that little yellow plastic clip is on the rack itself before you put it on. When you bump it down it should go into the hole on the mount and stay there. Every time you take the rack off, most likely the plastic clip will stay in the mount and you will have to pull it out and put it back on the rack. You can also push down on the mount to slightly bend it where the bolts go in. But, if you bend it too far you won't be able to start the screws. Mine is flush with the roof on both sides.
     
  5. Mar 30, 2011 at 10:00 AM
    #5
    raswank

    raswank [OP] Well-Known Member

    Joined:
    Aug 1, 2010
    Member:
    #41087
    Messages:
    1,130
    Gender:
    Male
    First Name:
    Rick
    Auburn,Ma
    Vehicle:
    2010 Tacoma Double Cab 4x4 6 speed
    Grillcraft, Rear leaf TSB, 5100's at .85, with Eibachs, 265/70/17 BF Goodrich AT/S Tires, Hella 500's behind Grill, Kenwood KDC X995 H/U all Boston Acoustic speakers, JL Audio subs, Kenwood XR5 S amp, ATX Chrome 17x8 wheels
    Yellow plastic things are all mangled and I would say stripped with no holding teeth. Great now have to go to Toyota and get fucked. Unless I can get new yellow anchors
     
  6. Mar 30, 2011 at 10:09 AM
    #6
    Bama_TACO

    Bama_TACO ROLL TIDE!!!!!!!

    Joined:
    Aug 3, 2010
    Member:
    #41157
    Messages:
    1,017
    Gender:
    Male
    Winfield, AL
    Vehicle:
    2006 PreRunner Double Cab TRD SPORT
    You might be able to grab some of those at Autozone. I know the one in my small hick town have them. They will be white or black instead of yellow.
     
  7. Mar 30, 2011 at 10:18 AM
    #7
    tarandus

    tarandus Well-Known Member

    Joined:
    Sep 29, 2009
    Member:
    #23502
    Messages:
    198
    Gender:
    Male
    Bozeman, MT
    Vehicle:
    '08 TRD SR5 DCab OR
    ToyTec 2.5" Bilstein/Eibach lift w/rear AAL, WeatherTec mats, Leer topper, Sock Monkey decals; Grillcraft
    I had the same problem with mine last fall. I never could make it go all the way down. I just traded mine in for an '08, so will try and get them to fit again. Thanks for the tip on getting the new plastic anchors. I think that was the problem with mine.
     
  8. Mar 30, 2011 at 10:41 AM
    #8
    raswank

    raswank [OP] Well-Known Member

    Joined:
    Aug 1, 2010
    Member:
    #41087
    Messages:
    1,130
    Gender:
    Male
    First Name:
    Rick
    Auburn,Ma
    Vehicle:
    2010 Tacoma Double Cab 4x4 6 speed
    Grillcraft, Rear leaf TSB, 5100's at .85, with Eibachs, 265/70/17 BF Goodrich AT/S Tires, Hella 500's behind Grill, Kenwood KDC X995 H/U all Boston Acoustic speakers, JL Audio subs, Kenwood XR5 S amp, ATX Chrome 17x8 wheels
  9. Mar 31, 2011 at 11:20 AM
    #9
    raswank

    raswank [OP] Well-Known Member

    Joined:
    Aug 1, 2010
    Member:
    #41087
    Messages:
    1,130
    Gender:
    Male
    First Name:
    Rick
    Auburn,Ma
    Vehicle:
    2010 Tacoma Double Cab 4x4 6 speed
    Grillcraft, Rear leaf TSB, 5100's at .85, with Eibachs, 265/70/17 BF Goodrich AT/S Tires, Hella 500's behind Grill, Kenwood KDC X995 H/U all Boston Acoustic speakers, JL Audio subs, Kenwood XR5 S amp, ATX Chrome 17x8 wheels
    In case anyone needs to know Autozone has replacement door panel anchors that are stronger than the oem yellow ones that come with the oem roof rack.
     
  10. Mar 31, 2011 at 11:26 AM
    #10
    Junebug McQuinn

    Junebug McQuinn Well-Known Member

    Joined:
    Dec 9, 2010
    Member:
    #47445
    Messages:
    447
    Gender:
    Male
    Wylie, TX
    Vehicle:
    2011 TRD Off Road Pre-Runner
    Don't smack it with a mallet anymore, I did the same thing and broke the mount that holds the yellow anchors and had to JB Weld it. I never got mine to sit flush either, just one side.
     
  11. Mar 31, 2011 at 11:32 AM
    #11
    757southpaw

    757southpaw Well-Known Member

    Joined:
    Nov 12, 2009
    Member:
    #25845
    Messages:
    1,728
    Gender:
    Male
    First Name:
    Jay
    757
    Vehicle:
    07' DC LB TRD Sport 4x4
    BAK BakFlip Tonneau cover, 30% front tinted windows, AVS vent shades, Black Billet Grill,Pop& Lock, secondary air filter removed, Goodyear Duratrac's, Billies @ 2.5" on front, Billies on back w/ 1.5" AAL, Toytec Diff drop, NOKYA Hyper Yellow fog light bulbs, LaminX Weathertechs, Rear diff breather mod, BHLM
    x2..I never saw mallat in the tools needed list when I installed mine :confused:
     
  12. Mar 31, 2011 at 12:13 PM
    #12
    raswank

    raswank [OP] Well-Known Member

    Joined:
    Aug 1, 2010
    Member:
    #41087
    Messages:
    1,130
    Gender:
    Male
    First Name:
    Rick
    Auburn,Ma
    Vehicle:
    2010 Tacoma Double Cab 4x4 6 speed
    Grillcraft, Rear leaf TSB, 5100's at .85, with Eibachs, 265/70/17 BF Goodrich AT/S Tires, Hella 500's behind Grill, Kenwood KDC X995 H/U all Boston Acoustic speakers, JL Audio subs, Kenwood XR5 S amp, ATX Chrome 17x8 wheels
    Update, none of the plastic interior anchors fit. all to small
     
  13. Mar 31, 2011 at 12:43 PM
    #13
    Derpy Derek

    Derpy Derek Derp

    Joined:
    May 10, 2010
    Member:
    #36868
    Messages:
    4,880
    Gender:
    Male
    First Name:
    Derek
    Lindale, TX
    Vehicle:
    2012 TRD Sport 4x4 DCSB
    Stow-away roof rack, Entune navigation, Aero Turbine 2525 muffler, Tan Softopper.
    I want to punch the guy that designed the front mounting on the rack.. it was a headache for me. I just said fuck it after a point..
     
  14. Mar 31, 2011 at 2:21 PM
    #14
    raswank

    raswank [OP] Well-Known Member

    Joined:
    Aug 1, 2010
    Member:
    #41087
    Messages:
    1,130
    Gender:
    Male
    First Name:
    Rick
    Auburn,Ma
    Vehicle:
    2010 Tacoma Double Cab 4x4 6 speed
    Grillcraft, Rear leaf TSB, 5100's at .85, with Eibachs, 265/70/17 BF Goodrich AT/S Tires, Hella 500's behind Grill, Kenwood KDC X995 H/U all Boston Acoustic speakers, JL Audio subs, Kenwood XR5 S amp, ATX Chrome 17x8 wheels
    I have gotten so many different bags of these clips and none fit. So living in New England sand, salt, water can now get trapped in there. Fucking great.
     
  15. Mar 31, 2011 at 2:24 PM
    #15
    Derpy Derek

    Derpy Derek Derp

    Joined:
    May 10, 2010
    Member:
    #36868
    Messages:
    4,880
    Gender:
    Male
    First Name:
    Derek
    Lindale, TX
    Vehicle:
    2012 TRD Sport 4x4 DCSB
    Stow-away roof rack, Entune navigation, Aero Turbine 2525 muffler, Tan Softopper.
    Just worry about getting the rubber surrounding, I used a sort of silicone that helped keep it down, the screws thankfully keep the cab sealed though
     
  16. Mar 31, 2011 at 3:17 PM
    #16
    raswank

    raswank [OP] Well-Known Member

    Joined:
    Aug 1, 2010
    Member:
    #41087
    Messages:
    1,130
    Gender:
    Male
    First Name:
    Rick
    Auburn,Ma
    Vehicle:
    2010 Tacoma Double Cab 4x4 6 speed
    Grillcraft, Rear leaf TSB, 5100's at .85, with Eibachs, 265/70/17 BF Goodrich AT/S Tires, Hella 500's behind Grill, Kenwood KDC X995 H/U all Boston Acoustic speakers, JL Audio subs, Kenwood XR5 S amp, ATX Chrome 17x8 wheels
    This thing to me is a piece of shit. Why doesn't Toyota sell replacement clips?
     
To Top