1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Techstream Tips and Tricks

Discussion in '3rd Gen. Tacomas (2016+)' started by Totall4285, Mar 10, 2019.

  1. Sep 5, 2020 at 7:01 PM
    #221
    Team Scream

    Team Scream Well-Known Member

    Joined:
    Nov 8, 2019
    Member:
    #310198
    Messages:
    237
    Gender:
    Male
    Los Angeles Kali
    Vehicle:
    2018 TRD DCOR Quicksand 4x4
    Old Man $538.00 Sound System Upgrade w/Kicker DS in the doors, and a Cerwin Vega VPAS10 powered (10") sub under the drivers seat.
    Has anyone been able to use TechStream with one of the Amazon cables by DaigKing where they sell a hacked version of the software with the cable?
    I ordered and received one from Amazon today and have tried version 14.20.019 from @tonered as well as the version that came with the cable.
    I am unable to make a connection to my truck... Keep getting errors... @Shellshock , you have any ideas for me?

    2018 TRD OffRoad 4x

    This is what I ended up with:
    https://www.amazon.com/DIAGKING-Tec...ild=1&keywords=DIAGKING&qid=1599357751&sr=8-1
     
    tonered likes this.
  2. Sep 5, 2020 at 7:11 PM
    #222
    crashdb

    crashdb Dangerous with an angle grinder..

    Joined:
    Aug 16, 2017
    Member:
    #226954
    Messages:
    4,644
    Gender:
    Male
    First Name:
    Dave
    Manassas, VA
    Vehicle:
    2017 TRD Sport 4x4 DC SB
    Stuff that my wife thinks I don't need.
    It took me multiple purchases of the knock-off cables to get one to work. Problem is you may get one to work, but it may be limited in what it can do. I ended up with a VXDIAG cable and it was fine.
     
    tonered likes this.
  3. Sep 5, 2020 at 7:13 PM
    #223
    Team Scream

    Team Scream Well-Known Member

    Joined:
    Nov 8, 2019
    Member:
    #310198
    Messages:
    237
    Gender:
    Male
    Los Angeles Kali
    Vehicle:
    2018 TRD DCOR Quicksand 4x4
    Old Man $538.00 Sound System Upgrade w/Kicker DS in the doors, and a Cerwin Vega VPAS10 powered (10") sub under the drivers seat.
    Where did you get the "VXDIAG" cable?
     
  4. Sep 5, 2020 at 7:26 PM
    #224
    crashdb

    crashdb Dangerous with an angle grinder..

    Joined:
    Aug 16, 2017
    Member:
    #226954
    Messages:
    4,644
    Gender:
    Male
    First Name:
    Dave
    Manassas, VA
    Vehicle:
    2017 TRD Sport 4x4 DC SB
    Stuff that my wife thinks I don't need.
    tonered likes this.
  5. Sep 5, 2020 at 9:54 PM
    #225
    Team Scream

    Team Scream Well-Known Member

    Joined:
    Nov 8, 2019
    Member:
    #310198
    Messages:
    237
    Gender:
    Male
    Los Angeles Kali
    Vehicle:
    2018 TRD DCOR Quicksand 4x4
    Old Man $538.00 Sound System Upgrade w/Kicker DS in the doors, and a Cerwin Vega VPAS10 powered (10") sub under the drivers seat.
    Yeah, so I got it to work with the Amazon cable and the supplied software and I did not have to allow some offshore dude teleport into my system to install it. I used an older WinXP laptop to make it work, so that tells me the drivers are successfully installed and that at least the version of TS that was supplied with the cable can communicate with the ECU through the cable.

    The problem I ran in to, was that the version of TS they supplied only goes up to the model year 2017 and I have a 2018, but I was in and cruising around, although, I could NOT see anything other than diagnostic stuff. In other words, none of the advanced user adjustable features were available. I am assuming that since I could only select the 2017, that there was a mismatch and the 2018 features were just not defined by the version they provided.

    So, at first I just upgraded THAT version, using the 14.20/019 version in @tonered signature, and while the software launched, I could not get the "connect to vehicle" step to engage. Clicking on the button did nothing. SO, I uninstalled everything and installed 20.14.019 by itself, and went through the motions, and while that was seamless, I got the error on connecting as posted by other members, where TS wants a network connection to proceed, and cancelling that request, resulted in a failure to connect error.

    Lastly, I tried activating wireless and connecting to the network, and tried again, with no joy.

    So, my question is this: Is there another version out there besides 20.14.019 that is known to work with the M.Y. 2018 ?

    I feel like I am so close, but I get the impression that the 20.14.019 version and MY truck do not like each other...
     
  6. Sep 5, 2020 at 10:05 PM
    #226
    lapoltba

    lapoltba Full Bridge Rectifier

    Joined:
    Aug 28, 2014
    Member:
    #137089
    Messages:
    3,217
    Gender:
    Male
    CT - 06076
    Vehicle:
    '17 Sport, ACLB, V6,MT, 04B14 OV-Tuned
    Your experience with the earlier version of TS sounds about right, however connection issues can definitely be caused by the cheap cable. This was the issue with someone else in this thread. They are very hit and miss. Some just don't behave nicely. I suspect the drivers are part of the issue, and the newer TS version may not work correctly.

    I am unsure of the compatibility of the newer TS versions with windows XP. I would image it *should* work. After you installed, did you go to Setup>VIM select, and make sure the correct interface is selected?

    Generally the software wants to "phone home" to check for updates, and if you don't allow it do that it will give you a grace period. If you have followed the instructions and have something like below showing, you should be able to let it go online and check with no issues.

    upload_2020-9-6_1-1-57.jpg

    If you can post some pictures or screenshots of the error messages it would help troubleshoot.
     
    Shellshock and tonered like this.
  7. Sep 5, 2020 at 10:34 PM
    #227
    Team Scream

    Team Scream Well-Known Member

    Joined:
    Nov 8, 2019
    Member:
    #310198
    Messages:
    237
    Gender:
    Male
    Los Angeles Kali
    Vehicle:
    2018 TRD DCOR Quicksand 4x4
    Old Man $538.00 Sound System Upgrade w/Kicker DS in the doors, and a Cerwin Vega VPAS10 powered (10") sub under the drivers seat.
    Yes, I went through the same procedure I used when trying the included version of TS, and got nothing. I still see the same "XHorse - MVCI" interface selected. So all good there.

    Yeah, so that is exactly what I did, which was turn on wifi, to try and side step the "you must be connected to a network to use techstream" prompt, but I still got the "you have 24 more uses" or whatever it says pop-up.

    Thats going to be a challenge because this is an older XP lappy, and grabbing screentshots is a bit of a bridge too far... I will see if I can get the XP equivalent of "snip" and try to grab some screenshots tho.... What I really need to know, is what version of TS was the first version to include the 2018 definitions.??
     
  8. Sep 5, 2020 at 10:42 PM
    #228
    lapoltba

    lapoltba Full Bridge Rectifier

    Joined:
    Aug 28, 2014
    Member:
    #137089
    Messages:
    3,217
    Gender:
    Male
    CT - 06076
    Vehicle:
    '17 Sport, ACLB, V6,MT, 04B14 OV-Tuned
    Not sure off the top of my head, but something in the 14's should be fine. Cell phone pictures that aren't potato quality would suffice.
     
    Shellshock likes this.
  9. Sep 5, 2020 at 10:57 PM
    #229
    Team Scream

    Team Scream Well-Known Member

    Joined:
    Nov 8, 2019
    Member:
    #310198
    Messages:
    237
    Gender:
    Male
    Los Angeles Kali
    Vehicle:
    2018 TRD DCOR Quicksand 4x4
    Old Man $538.00 Sound System Upgrade w/Kicker DS in the doors, and a Cerwin Vega VPAS10 powered (10") sub under the drivers seat.
    Well, if you knew where a fella could get a copy of 14.10.028 that would be amazing. That is the only other version I see in the techstream-act.exe where I would be able to seamlessly install it...

    <edit> ooops... The version I found on OBDII365 is corrupt... Got a lead on it by any chance?
     
  10. Sep 5, 2020 at 11:24 PM
    #230
    lapoltba

    lapoltba Full Bridge Rectifier

    Joined:
    Aug 28, 2014
    Member:
    #137089
    Messages:
    3,217
    Gender:
    Male
    CT - 06076
    Vehicle:
    '17 Sport, ACLB, V6,MT, 04B14 OV-Tuned
    The one in my signature is newer, but should work just fine. I think @tonered has the same one in his. I have personally used those files as have several other people, so I do know they work.

    https://mega.nz/#!6dhQ3AxC!86U_-i2UvbMs3TCfF0ZYBsLbkywrbxnqZ5gd6NSVCqo
     
    tonered likes this.
  11. Sep 5, 2020 at 11:32 PM
    #231
    Team Scream

    Team Scream Well-Known Member

    Joined:
    Nov 8, 2019
    Member:
    #310198
    Messages:
    237
    Gender:
    Male
    Los Angeles Kali
    Vehicle:
    2018 TRD DCOR Quicksand 4x4
    Old Man $538.00 Sound System Upgrade w/Kicker DS in the doors, and a Cerwin Vega VPAS10 powered (10") sub under the drivers seat.
    Yeah 14.20.019 is what I have been trying. It's just not working...but like I said, the cracked version that came with my cable DID work, it just maxed out on the 2017 model year..

    In the activation file (.exe) for the one linked in yours and tonered signatures (14.20.019) you either press 1 or 2 to get the activation code for 1 of 2 versions. .019 being #2 and 14.10.028 being #1
    I am on the hunt for #1, now....
     
  12. Sep 5, 2020 at 11:36 PM
    #232
    lapoltba

    lapoltba Full Bridge Rectifier

    Joined:
    Aug 28, 2014
    Member:
    #137089
    Messages:
    3,217
    Gender:
    Male
    CT - 06076
    Vehicle:
    '17 Sport, ACLB, V6,MT, 04B14 OV-Tuned
    I'll be honest, I don't think it's going to matter even if you do find a good installer for 14.10.028. IDK what hardware you are working with, but a clean slate is a really good starting point. One thing I would suggest is to set up a Virtual Machine using something like VMware on your main computer. I us VM's a lot for work to sandbox things, and it makes installing software and reverting back to "vanilla" very easy. It also keeps you in the Windows 10/7 environment with all the modern conveniences.
     
    Shellshock and tonered like this.
  13. Sep 6, 2020 at 12:35 AM
    #233
    Team Scream

    Team Scream Well-Known Member

    Joined:
    Nov 8, 2019
    Member:
    #310198
    Messages:
    237
    Gender:
    Male
    Los Angeles Kali
    Vehicle:
    2018 TRD DCOR Quicksand 4x4
    Old Man $538.00 Sound System Upgrade w/Kicker DS in the doors, and a Cerwin Vega VPAS10 powered (10") sub under the drivers seat.
    Yeah, not going to go the VM route... that is another layer of complexity that I just don't need. For working with external devices, like the Mini VCI, I just don't see an advantage to trying to get a driver to work in a VM, if it wont work on the mothership to begin with.

    It's not like this is rocket science, and I have been tuning cars with Taxtrix cables and open source (RomRaider) for more than a decade. I think I have narrowed it down to a firmware version on the cable I have being 1.4.1 and the newer versions of TS wanting firmware 2.0 on these MiniVCI devices. I stumbled upon a link that solves the 64bit driver installation issue it seems, but as of now, I have a capable enough XP latop that should be able to do this. It's a matter of finding the right VCI cable with the latest firmware that might just be the culprit. If not, I also have a brand new Win10 laptop that will do the trick if I can navigate the x64 driver installation issue using FTDI.

    I found the version of TS I am looking for on another forum, but the .rar file is password protected. I have a PM into the OP requesting the password, so if I get that in the next day or so, then it's a win. If not, I will search for a 2.0 firmware version of the cable and send this one back and start over. What I am not going to do is spend $170.00 on a Tactrix cable just yet. I just don't see the value in that at this point. The dongle you linked is half that, and I may end up there, but as of now, I can stay busy trying to pound a square peg into a round hole for shits and giggles....

    Thanks for the help man, I do appreciate it !!!
     
  14. Sep 6, 2020 at 1:37 PM
    #234
    Team Scream

    Team Scream Well-Known Member

    Joined:
    Nov 8, 2019
    Member:
    #310198
    Messages:
    237
    Gender:
    Male
    Los Angeles Kali
    Vehicle:
    2018 TRD DCOR Quicksand 4x4
    Old Man $538.00 Sound System Upgrade w/Kicker DS in the doors, and a Cerwin Vega VPAS10 powered (10") sub under the drivers seat.
    **** SUCCESS ****

    So after a day of dicking around with a couple different versions of TS, loading, uninstalling, reinstalling another version, I have finally been able to successfully connect with TS to my 2018 TRD OR DCSB AT 4x4

    No matter what I did, I could not make the 14.20.019 version in @tonered signature work for me, it simply would time out and not connect, throwing an error. So I set out to find the earlier version of 14x which was 14.10.028 and I found it over on GarageForum.org.

    Uninstalled 14.20.019.
    Rebooted
    Waited for my aging WinXP laptop to finish ALL hard drive activity (no blinking light).
    Installed TS 14.10.028.
    Used the activation.exe (press ONE) to get THIS versions activation code.
    Applied that activation code with success.
    Plugged in my Amazon Mini-VCI cable, listened for the (USB connected) chime.
    Used the MVCI Firmware Update tool to confirm my cable was alive (it will report back firmware info and serial # if your drivers are installed correctly).
    Went out to the truck, connected it to the OBDII port, and was able to successfully connect to, and modify the custom parameters I wanted, like seat belt warning, half turn signal, etc.

    Hey brother, I am a bit confused on how to query my ECU to determine which ECU ID I am at right now. Assuming I have the 04A60 ID, which update would I grab?
     
    Last edited: Sep 6, 2020
    BigWhiteTRD and tonered like this.
  15. Sep 6, 2020 at 2:13 PM
    #235
    lapoltba

    lapoltba Full Bridge Rectifier

    Joined:
    Aug 28, 2014
    Member:
    #137089
    Messages:
    3,217
    Gender:
    Male
    CT - 06076
    Vehicle:
    '17 Sport, ACLB, V6,MT, 04B14 OV-Tuned
    T-0036-18.cuw

    https://mega.nz/file/OF4jkYgA#acnatJjXYAVejkLJgP5zowCxmOU3FUBnBmHU2yjdPKY

    If you run the CUW file, one of the first things it does is check your current calibration revision.
     
    tonered likes this.
  16. Sep 6, 2020 at 2:21 PM
    #236
    tomwil

    tomwil Well-Known Member

    Joined:
    May 15, 2014
    Member:
    #129887
    Messages:
    8,047
    Gender:
    Male
    East Coast USA
    Vehicle:
    2014 Reg Cab 4x4
    Can you provide the GarageForum.org link to TS 14.10.028?
     
  17. Sep 6, 2020 at 2:25 PM
    #237
    Team Scream

    Team Scream Well-Known Member

    Joined:
    Nov 8, 2019
    Member:
    #310198
    Messages:
    237
    Gender:
    Male
    Los Angeles Kali
    Vehicle:
    2018 TRD DCOR Quicksand 4x4
    Old Man $538.00 Sound System Upgrade w/Kicker DS in the doors, and a Cerwin Vega VPAS10 powered (10") sub under the drivers seat.
    Thank you man, so I downloaded T-0036-18 file and placed it on the desktop. Followed the steps outlined in the OP but I got an error saying it could not read the data.
    So, I cycled everything, replugged in the Mini-VCI cable and launched TS and was able to connect just fine, and do a health check, which after the 29 steps, indicated I am on 04A60 at this point.

    So the cable seems to work for TS, but is there a reason why it may not be working to flash the TSB ?

    One thing I DIDN'T do, was open the hood.... Is that a mandatory step?
     
  18. Sep 6, 2020 at 2:27 PM
    #238
    Team Scream

    Team Scream Well-Known Member

    Joined:
    Nov 8, 2019
    Member:
    #310198
    Messages:
    237
    Gender:
    Male
    Los Angeles Kali
    Vehicle:
    2018 TRD DCOR Quicksand 4x4
    Old Man $538.00 Sound System Upgrade w/Kicker DS in the doors, and a Cerwin Vega VPAS10 powered (10") sub under the drivers seat.
    tomwil likes this.
  19. Sep 6, 2020 at 2:29 PM
    #239
    crashdb

    crashdb Dangerous with an angle grinder..

    Joined:
    Aug 16, 2017
    Member:
    #226954
    Messages:
    4,644
    Gender:
    Male
    First Name:
    Dave
    Manassas, VA
    Vehicle:
    2017 TRD Sport 4x4 DC SB
    Stuff that my wife thinks I don't need.
    Yup. It's why I posted the cable I'm using. Some cables can't do two way comms. If you had to enter your truck information in the beginning you probably don't have a cable that works.
     
  20. Sep 6, 2020 at 2:29 PM
    #240
    lapoltba

    lapoltba Full Bridge Rectifier

    Joined:
    Aug 28, 2014
    Member:
    #137089
    Messages:
    3,217
    Gender:
    Male
    CT - 06076
    Vehicle:
    '17 Sport, ACLB, V6,MT, 04B14 OV-Tuned
    If you can connect in TS, it should connect when you run the CUW file. There is a close to 100% chance that it is a cable issue. I highly recommend not flashing TSBs with cheap cables. You can brick your ECM.
     
    Skydvrr, tonered and Smacky2020 like this.
To Top