1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Techstream Tips and Tricks

Discussion in '3rd Gen. Tacomas (2016+)' started by Totall4285, Mar 10, 2019.

  1. Jul 28, 2020 at 8:50 AM
    #121
    4wdExplorer

    4wdExplorer Well-Known Member

    Joined:
    Dec 31, 2009
    Member:
    #28499
    Messages:
    868
    Gender:
    Male
    Orange County, CA
    I am not asking if anyone is selling. I bought the cable and TIS came with it. I am getting virus alerts when trying to unzip the driver. Just asking if this is normal?
     
  2. Jul 28, 2020 at 8:53 AM
    #122
    tonered

    tonered tacorider

    Joined:
    Sep 25, 2017
    Member:
    #231055
    Messages:
    24,591
    Gender:
    Male
    First Name:
    tony
    Lynnwood, WA
    Yeah. I just realized that and posted an apology above.


    Yes. You will get a virus warning. I have no idea about the particular TS that you bought, but I do know the one in my sig is safe after installing. No one has reported an issue other than the warnings. TS will work with any reliable USB adapter. You just need the drivers, and for cheap ones, some good luck. Don't try doing an ECU flash unless you are absolutely certain that you are getting a solid and stable connection. Even then, be careful.

    Diagnostics and customizations should be okay.
     
    Noch likes this.
  3. Jul 28, 2020 at 8:59 AM
    #123
    4wdExplorer

    4wdExplorer Well-Known Member

    Joined:
    Dec 31, 2009
    Member:
    #28499
    Messages:
    868
    Gender:
    Male
    Orange County, CA
    Thank you! Will try to disable the virus check and install the driver and then TIS.

    I purchased this cable. Since I needed the cable TIS came with it.

    Supposely this generic cable is one of the better ones.

    https://www.ebay.com/itm/License-Ke...e=STRK:MEBIDX:IT&_trksid=p2057872.m2749.l2649
     
  4. Jul 28, 2020 at 9:03 AM
    #124
    tonered

    tonered tacorider

    Joined:
    Sep 25, 2017
    Member:
    #231055
    Messages:
    24,591
    Gender:
    Male
    First Name:
    tony
    Lynnwood, WA
    A person or two has had luck with cheap cables. Although, the Tactrix is the least expensive, reliable cable that is known for flashing ECUs. Diagnostics and customizations do not require as high of a standard if that is your goal.

    TS V14 is good for accessing all Tacos through 2020. TS V15 is needed access 2020 T4Rs.
     
    4wdExplorer and Smacky2020 like this.
  5. Jul 28, 2020 at 9:11 AM
    #125
    Smacky2020

    Smacky2020 Well-Known Member

    Joined:
    May 4, 2020
    Member:
    #326715
    Messages:
    393
    First Name:
    Chris
    Bristol, VA
    Vehicle:
    2020 TRD ORDC - Cement
    Stock wheels and suspension. Random "utilitarian" mods featured on this great forum.
    Good timing, I just got mine working. Huge shout out to @tonered for contributing to the success. My cheap TIS cable came with the driver cd cracked. No response from the seller (no surprise) so scoured the internet for dll and instructions. The 64 bit registry update is a must on newer Win machines along with the driver and location.

    Only have 5200 days left on the registration; need to make it count :). I'm not planning on flashing tabs or doing major programming but having dealer-level tool to have diagnostics and capture a baseline for the car is clutch.

    Confirming that 14.20 TIS works with my 2020 TRD OR.

    20200728_114356.jpg
     
    NEIPA27, cameleon50 and tonered like this.
  6. Jul 28, 2020 at 9:13 AM
    #126
    tonered

    tonered tacorider

    Joined:
    Sep 25, 2017
    Member:
    #231055
    Messages:
    24,591
    Gender:
    Male
    First Name:
    tony
    Lynnwood, WA
    You're welcome! :cheers:
     
  7. Jul 28, 2020 at 9:25 AM
    #127
    907rx7

    907rx7 Well-Known Member

    Joined:
    Jul 1, 2019
    Member:
    #298028
    Messages:
    842
    First Name:
    James
    Vehicle:
    '20 Tacoma DCSB SR 4x4
    Is the virus check popping upon downloading or after running? If it is when running it is probably 'Windows Smart Screen' there should be a little button that says 'more info' click that and you'll have the option to 'proceed/run anyway'. I cannot give guidance on whether or not this is safe.:smash:
     
    AbnMP13 and tonered like this.
  8. Jul 28, 2020 at 9:41 AM
    #128
    tonered

    tonered tacorider

    Joined:
    Sep 25, 2017
    Member:
    #231055
    Messages:
    24,591
    Gender:
    Male
    First Name:
    tony
    Lynnwood, WA
    :rofl:


    The only thing that we have is the aggregate of hundreds of downloads. No one has posted an issue other than warnings, so from that and using this software myself, I can only believe that it safe.
     
    907rx7 likes this.
  9. Jul 28, 2020 at 9:42 AM
    #129
    grubburg

    grubburg Well-Known Member

    Joined:
    Jan 13, 2014
    Member:
    #120579
    Messages:
    2,292
    Gender:
    Male
    Vehicle:
    2019 TRD OR MT
    K & N Intake, Gibson Catback (chopped), Weathertech floormats, 285/70/17 Ridge Grapplers, Black Rhino Glamis wheels, Kicker Key, Kicker Hideaway, Infiniti Speakers, OV Tune, 888's, 5100s X 4, HS 3-leaf, LR SPC UCAs, Diff Drop, Carrier Bearing Drop, OEM Bed Mat, Morimoto HID low beams, Morimoto LED 2 Stroke High Beams, KC 336 LED bar, KC C3 LED pods for rear, KC LED 6'' SlimLites ditch lights, N-Fab Steps, Auxbeam Interior Blue Lights, 7r41lbr34k3r Shift Knob, Wet Okole Seat Covers, Diode Dynamics SAE Pro Fogs, Cali Raised ditch light brackets, hidden light bar brackets, tailgate light brackets.
    I played with TechStream for hours trying to get my PCS TSS off. I uninstalled the front sensor that auto-brakes and I've had an error message and no cruise control ever since. If anyone knows how to turn of the PCS TSS and clear my error message, I've got a hefty reward waiting for you.
     
  10. Jul 28, 2020 at 9:46 AM
    #130
    tonered

    tonered tacorider

    Joined:
    Sep 25, 2017
    Member:
    #231055
    Messages:
    24,591
    Gender:
    Male
    First Name:
    tony
    Lynnwood, WA
    You probably have to find the TSB CUW file that the dealers install for those that do not get the TSS-P recall done. The system remembers the last state set. Default is Off for the folks that are denied the recall.

    If you can post up the applicable TSB number, we might be able to help you find something?
     
    grubburg likes this.
  11. Jul 28, 2020 at 9:49 AM
    #131
    907rx7

    907rx7 Well-Known Member

    Joined:
    Jul 1, 2019
    Member:
    #298028
    Messages:
    842
    First Name:
    James
    Vehicle:
    '20 Tacoma DCSB SR 4x4
    Lol, obligatory disclaimer since I don't know if he's actually using the one in your sig:thumbsup:

    On a side note, I need to put together a garage PC for things like this. Not going to drag my desktop in there lol.
     
    tonered likes this.
  12. Jul 28, 2020 at 9:53 AM
    #132
    tonered

    tonered tacorider

    Joined:
    Sep 25, 2017
    Member:
    #231055
    Messages:
    24,591
    Gender:
    Male
    First Name:
    tony
    Lynnwood, WA
    :hattip: Of course! I was nervy installing TS V12 the first time. But then, all ECU software that I have found kicks off a warning of some type.


    If you pop over to the ECU Update or OVT MT threads, there are a lot of recommendations for cheap laptops.
     
  13. Jul 28, 2020 at 9:57 AM
    #133
    907rx7

    907rx7 Well-Known Member

    Joined:
    Jul 1, 2019
    Member:
    #298028
    Messages:
    842
    First Name:
    James
    Vehicle:
    '20 Tacoma DCSB SR 4x4
    Thanks for the heads-up, I have a nuc floating around here somewhere. Need to look at the specs but I may just hook it up to the garage tv.
     
    tonered likes this.
  14. Jul 28, 2020 at 9:58 AM
    #134
    Smacky2020

    Smacky2020 Well-Known Member

    Joined:
    May 4, 2020
    Member:
    #326715
    Messages:
    393
    First Name:
    Chris
    Bristol, VA
    Vehicle:
    2020 TRD ORDC - Cement
    Stock wheels and suspension. Random "utilitarian" mods featured on this great forum.
    Not Techstream related per se but does anyone know of a more efficient way to see if TSB-0125-18 (engine surge with steering input) could be applied to a 2020? Original one only covers 17-18; haven't seen one for later years. Definitely have this happening and was going to use TIS to get some data points to bring to dealer as this only happens when cold.
     
  15. Jul 28, 2020 at 10:00 AM
    #135
    tonered

    tonered tacorider

    Joined:
    Sep 25, 2017
    Member:
    #231055
    Messages:
    24,591
    Gender:
    Male
    First Name:
    tony
    Lynnwood, WA
    Just about anything that will run Win7 or Win10 is good enough for what is needed. Our old laptop started life right around the time that Win7 happened. It takes 10min at least to boot up, but ran TS and OVT with no problem.
     
  16. Jul 28, 2020 at 10:03 AM
    #136
    tonered

    tonered tacorider

    Joined:
    Sep 25, 2017
    Member:
    #231055
    Messages:
    24,591
    Gender:
    Male
    First Name:
    tony
    Lynnwood, WA
    As far as we know, there is only the 04B90 ECU ID for the 2020 MTs. The ATs have 04B30 and 04B31, but no TSB or reason has been posted for the difference.

    I think a lot of folks are holding their breath after TSB-0043-20 / 04B14 was dropped for the 2016 and 2017 MTs.


    One thing that you could try is hooking up TS and doing the DTC, LV, and AT Resets. It will give you a clean slate for the ECU to learn from.
     
    Smacky2020 likes this.
  17. Jul 28, 2020 at 10:13 AM
    #137
    4wdExplorer

    4wdExplorer Well-Known Member

    Joined:
    Dec 31, 2009
    Member:
    #28499
    Messages:
    868
    Gender:
    Male
    Orange County, CA
    When I try to unzip 'MultiDriverMVCI_X64' it disappears. Then I go to Windows Security and it says there is a 'trogen' in there.

    Seems like this is normal? I went to other sellers and they say to disable any virus program during the install.

    This was the sellers response to why a virus warning pops up during the Driver install.

     
  18. Jul 28, 2020 at 10:29 AM
    #138
    tonered

    tonered tacorider

    Joined:
    Sep 25, 2017
    Member:
    #231055
    Messages:
    24,591
    Gender:
    Male
    First Name:
    tony
    Lynnwood, WA
    Very normal. I know on the Win Defender side, there are three or four switches to throw to fully disable the A/V.
     
  19. Jul 28, 2020 at 10:31 AM
    #139
    4wdExplorer

    4wdExplorer Well-Known Member

    Joined:
    Dec 31, 2009
    Member:
    #28499
    Messages:
    868
    Gender:
    Male
    Orange County, CA
    Alright. I'll turn it off and try again. :fingerscrossed:
     
    tonered likes this.
  20. Jul 28, 2020 at 10:34 AM
    #140
    tonered

    tonered tacorider

    Joined:
    Sep 25, 2017
    Member:
    #231055
    Messages:
    24,591
    Gender:
    Male
    First Name:
    tony
    Lynnwood, WA

    Good luck!
     

Products Discussed in

To Top