1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Theres a knocking sound coming from my 1996 toyota tacoma v6 3.4 litre engine

Discussion in 'Performance and Tuning' started by Drew.Franklin, Jun 5, 2011.

  1. Jun 5, 2011 at 3:20 PM
    #1
    Drew.Franklin

    Drew.Franklin [OP] New Member

    Joined:
    Jun 5, 2011
    Member:
    #57785
    Messages:
    1
    Gender:
    Male
    Fort Campbell Ky
    Ive had all kinds of work done lately. I just got the head gaskets replaced which went beautifully except I stripped the two bolt holes on my i5 cap on my driverside intake cam. Whcih I then took it to the toyota dealership in hopkinsville kentucky to have the holes re-threaded. Inserts were put in and the cap was then screwed down and everything put back together. Went to drive it off the lot and it ran like shit. turns out they mixed up two of my vacume lines. Which i easily corrected but now its making a knocking sound in the upper engine and it really doesnt sound like the cam thing i just fixed so idk. any suggestions would be very helpful.
     
  2. Jun 5, 2011 at 3:54 PM
    #2
    4WD

    4WD cRaZy oLdmAn

    Joined:
    Jul 2, 2009
    Member:
    #19185
    Messages:
    22,316
    Gender:
    Male
    First Name:
    Doug
    Gardnerville, Nevada
    Vehicle:
    No Truck
    Grey wire MOD, deck plate, diff breather MOD, 2nd gen. OME 883# on Tundra 5100's, OMD custom 3" leafsprings, rear shock relocation, Ivan Stewart TRD rims w/285/75/16's, '02 bumper MOD, Famous Fabrications sliders , LED interior/exterior lights, bed bar, Custom tube bumper, Old school KC day lighters,Red Ring 8" HID flood, Kenwood vhf 2M.. umm some other shit I'm forgetting right now
    Theres a thousand things that could cause a "knocking" sound in your top end, any way to narrow it down ? some audio ? Something not tight ?, something left inside accidentally during machining ? cam going bad w/flattening lobe(s) ? Did you change oil after doing all work & before starting up ? (I ask this cause you mentioned head gasket R&R) Theres alot .....:eek:;)
     
To Top