1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Thinking there is something wrong with my truck

Discussion in '1st Gen. Tacomas (1995-2004)' started by slickyd, Mar 18, 2011.

  1. Mar 18, 2011 at 3:12 PM
    #1
    slickyd

    slickyd [OP] Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18130
    Messages:
    303
    Gender:
    Male
    First Name:
    David
    Alex City, AL
    Vehicle:
    03 PreRunner SR5
    My truck has a kind of gas smell coming from the exhaust it puts out white smoke from the exhuast pipe even after the motor has warmed up. And there seems to be a lot of water coming out of it too. My engine is making a "rattling" or like something is loose sound. It was a lot quiter when I first got the truck. thanks for looking.
     
  2. Mar 18, 2011 at 3:13 PM
    #2
    Jester243

    Jester243 mod status????

    Joined:
    Jun 25, 2008
    Member:
    #7552
    Messages:
    10,004
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 Trail Premium 4Runner w/ KDSS
    How is your coolant?
     
  3. Mar 18, 2011 at 3:20 PM
    #3
    joerussell610

    joerussell610 When all else fails read the directions

    Joined:
    Nov 22, 2010
    Member:
    #46553
    Messages:
    739
    Gender:
    Male
    First Name:
    Him
    Making myself at home in your house
    Vehicle:
    2005 DC Sport Edition 4x4
    K&N, fog light mod, remote rear halogen fogs mounted under rear bumper, TRD skid plate, Flux Capacitor, Mr. Fusion upgrade soon
    Check coolant? Check to see if any oil in it? Check to see if coolant and water mixed? HMMMMMM???? Check to see what your credit score is?
     
  4. Mar 18, 2011 at 3:21 PM
    #4
    slickyd

    slickyd [OP] Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18130
    Messages:
    303
    Gender:
    Male
    First Name:
    David
    Alex City, AL
    Vehicle:
    03 PreRunner SR5
    its full no fuild loss
     
  5. Mar 18, 2011 at 3:21 PM
    #5
    Jester243

    Jester243 mod status????

    Joined:
    Jun 25, 2008
    Member:
    #7552
    Messages:
    10,004
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 Trail Premium 4Runner w/ KDSS
    yes
     
  6. Mar 18, 2011 at 3:21 PM
    #6
    Jester243

    Jester243 mod status????

    Joined:
    Jun 25, 2008
    Member:
    #7552
    Messages:
    10,004
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 Trail Premium 4Runner w/ KDSS
    does your oil seem to have any coolant mixed in it?
     
  7. Mar 18, 2011 at 3:23 PM
    #7
    Rucas

    Rucas 1st gen > 2nd gen

    Joined:
    Dec 5, 2009
    Member:
    #27040
    Messages:
    4,032
    Gender:
    Male
    First Name:
    Lucas
    Northern Colorado
    Vehicle:
    1st gen. 4x4 MANual
    sparkles, fairys, and happy things.
    lol at the credit score comment...
     
  8. Mar 18, 2011 at 3:27 PM
    #8
    slickyd

    slickyd [OP] Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18130
    Messages:
    303
    Gender:
    Male
    First Name:
    David
    Alex City, AL
    Vehicle:
    03 PreRunner SR5
    I'll check it put I just changed it a month ago and it didn't seem that way then. How do I need to check the oil. Can you tell by looking on the dip stick if it has water mixed in?
     
  9. Mar 18, 2011 at 3:37 PM
    #9
    Bloodhound

    Bloodhound Space For Rent

    Joined:
    Dec 30, 2010
    Member:
    #48442
    Messages:
    455
    Gender:
    Male
    First Name:
    Greg
    East Moline, IL
    Vehicle:
    '10 TRD O/R DBL-CAB
    Floor-mats, Running Boards, Shorty Antenna, AFE Pro Dry Air Filter, AVS In-Channel VentVisors, Beer cans in the bed

    Normally if water has mixed with oil it will look similar to chocolate milk or "Yoo-Hoo".
     
  10. Mar 18, 2011 at 3:39 PM
    #10
    slickyd

    slickyd [OP] Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18130
    Messages:
    303
    Gender:
    Male
    First Name:
    David
    Alex City, AL
    Vehicle:
    03 PreRunner SR5
    Ok just checked doesn't seem to be mixed the engine didn't sound that bad just then
     
  11. Mar 18, 2011 at 3:41 PM
    #11
    slickyd

    slickyd [OP] Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18130
    Messages:
    303
    Gender:
    Male
    First Name:
    David
    Alex City, AL
    Vehicle:
    03 PreRunner SR5
    Looks like motor oil
     
  12. Mar 18, 2011 at 3:44 PM
    #12
    slickyd

    slickyd [OP] Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18130
    Messages:
    303
    Gender:
    Male
    First Name:
    David
    Alex City, AL
    Vehicle:
    03 PreRunner SR5
    oh yeah I forgot I haven't been getting the gas mileage I use to get either
     
  13. Mar 18, 2011 at 6:33 PM
    #13
    MapleMoose

    MapleMoose Drunk Canadian

    Joined:
    Feb 15, 2011
    Member:
    #51211
    Messages:
    8,589
    Gender:
    Male
    First Name:
    Ian
    West Kootenays
    Vehicle:
    1996 Tacoma SR5
    3" Eibach Coils, 3" AP Springs, AP 6" Shackles Toytec Diff drop, BAMF Sliders, Deck plate mod,Volt meter, Highbeam mod, PIAA fogs, 18" Magnaflow, LED dash swap, Color matched Satoshi Grille, Custom Rear Plate Bumper
    Hey! Just figured it out i think. Its your head gasket. Same problems with the '90-95. Apparently the engines for those years ran too hot and caused the gaskets to go. The water would mix in with the oil and cause your exhaust to blow white smoke. Also check your oil, if its starting to turn milky then thats the problem. And head gaskets are a BIG job! You have to take apart the engine. How this helps.
     
  14. Mar 18, 2011 at 7:05 PM
    #14
    slickyd

    slickyd [OP] Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18130
    Messages:
    303
    Gender:
    Male
    First Name:
    David
    Alex City, AL
    Vehicle:
    03 PreRunner SR5
    Ok just really paid attention to it. The smoke starts after the motor is warm and its not much or very thick but it is constant.
     
  15. Mar 18, 2011 at 7:43 PM
    #15
    MapleMoose

    MapleMoose Drunk Canadian

    Joined:
    Feb 15, 2011
    Member:
    #51211
    Messages:
    8,589
    Gender:
    Male
    First Name:
    Ian
    West Kootenays
    Vehicle:
    1996 Tacoma SR5
    3" Eibach Coils, 3" AP Springs, AP 6" Shackles Toytec Diff drop, BAMF Sliders, Deck plate mod,Volt meter, Highbeam mod, PIAA fogs, 18" Magnaflow, LED dash swap, Color matched Satoshi Grille, Custom Rear Plate Bumper
    Is your engine running fast? Because broken gasket seals will cause your engine to run fast and hot. And that will cause water to get into your engine. That would also cause the white smoke and water coming out of your exhaust. Run your engine for a while and then check your oil or even change it. If it is milky or anything resembling water, your head gasket is probly blown. If thats the case dont drive anymore you could blow your engine.
     
  16. Mar 18, 2011 at 8:09 PM
    #16
    slickyd

    slickyd [OP] Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18130
    Messages:
    303
    Gender:
    Male
    First Name:
    David
    Alex City, AL
    Vehicle:
    03 PreRunner SR5
    Idon't think its the hg from everything I have been reading. I smelled the water that is dropping from the exhaust it just smells bad there is no sweet smell to it. I don't know why the exhaust smells so bad but that doesn't have a sweet smell either. And my oil looks good it has to be something else.
     
  17. May 3, 2012 at 12:26 AM
    #17
    07DblRunner

    07DblRunner Member

    Joined:
    Jul 26, 2009
    Member:
    #20217
    Messages:
    20
    Gender:
    Male
    So Cal
    Vehicle:
    2007 TRD Offroad Prerunner Double Cab
    did you find the issue?
     
  18. May 3, 2012 at 12:32 AM
    #18
    Taco me elmo

    Taco me elmo Here, Eat some paint. Drink some Bleach.

    Joined:
    Sep 17, 2010
    Member:
    #43412
    Messages:
    4,655
    First Name:
    Tophat bobcat
    North of South, East of West
    Vehicle:
    Slow polished TuRD
    Anti theft 5-Speed
    Sounds like a blown out cat converter.
     
  19. May 3, 2012 at 1:04 AM
    #19
    slickyd

    slickyd [OP] Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18130
    Messages:
    303
    Gender:
    Male
    First Name:
    David
    Alex City, AL
    Vehicle:
    03 PreRunner SR5
    No and neither did the dealership. I dont know what the problem is.
     
  20. May 3, 2012 at 2:54 AM
    #20
    stewartx

    stewartx Well-Known Member

    Joined:
    Jan 9, 2012
    Member:
    #70271
    Messages:
    1,812
    Gender:
    Male
    Huntsville AL
    Vehicle:
    2012 Silver DC SB TRD Off-Road
    Winch, front hitch, step bars, bed extender, bed step, gull-wing toolbox, tailgate lock, security system, cb radio, etc.
    Okay, here's a real long shot. Make sure your gas cap is properly tightened. My wife's minivan had similar problems (gas smell, engine slightly rough, small puffs of white smoke, etc). I couldn't find anything until the check engine light eventually came on after about two weeks. The first item in the troubleshooting checklist related to that was the gas cap, which was indeed loose. She simply screwed the gas cap down until she felt resistance, never going beyond that until the cap clicked. I tightened the gas cap and the problems & check engine light went away after driving a couple of miles.
     
To Top