1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

This is probably something I should know but am not sure

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Jason chairs, Apr 11, 2011.

  1. Apr 11, 2011 at 3:37 PM
    #1
    Jason chairs

    Jason chairs [OP] Active Member

    Joined:
    Feb 23, 2011
    Member:
    #51687
    Messages:
    25
    Gender:
    Male
    First Name:
    jason
    Coatesville,pa
    Vehicle:
    2007.
    none yet want many
    The maintenance required light flashes about 4 times when I start my truck should I be concerned or is it to be ignored. I just changed the oil about a 1000 miles ago so it cant be that again. My truck just hit 100000 by the way it is a 07 access cab v6 4wd
    thanks
    jason
     
  2. Apr 11, 2011 at 3:40 PM
    #2
    S.B.

    S.B. Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18838
    Messages:
    3,566
    Gender:
    Male
    First Name:
    Sean
    SD, CA Now in Colorado Springs, CO
    Vehicle:
    08 Taco 4x4 TRD OffRoad Rugged Trail
    SAW 2.0s, Wheeler's 3-leaf AAL, On Board Air, 255/85/16 Cooper Discover S/T, CBI Sliders, Built right UCAs, 6" Harbor Freight Lights (converted to HIDs), KC Slim Lights.
    Did the people reset the light when they changed the oil?
     
  3. Apr 11, 2011 at 3:42 PM
    #3
    06TRDsport

    06TRDsport Well-Known Member

    Joined:
    Sep 10, 2006
    Member:
    #30
    Messages:
    386
    Gender:
    Male
    First Name:
    Chris
    Bend, OR
    Vehicle:
    2007 F250 Diesel and 1999 4Runner
    You need to reset the light. Hold down the trip meter button while you turn the key on and keep holding it down untill all the dashed lines on the odometer go away.
     
  4. Apr 11, 2011 at 3:44 PM
    #4
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,188
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    X2. You will see a few lines and it counts down from there.
     
  5. Apr 11, 2011 at 3:46 PM
    #5
    Jason chairs

    Jason chairs [OP] Active Member

    Joined:
    Feb 23, 2011
    Member:
    #51687
    Messages:
    25
    Gender:
    Male
    First Name:
    jason
    Coatesville,pa
    Vehicle:
    2007.
    none yet want many
    thank you I am gonna try holding down the trip meter tahnk you for your help
     
  6. Apr 11, 2011 at 3:56 PM
    #6
    Jason chairs

    Jason chairs [OP] Active Member

    Joined:
    Feb 23, 2011
    Member:
    #51687
    Messages:
    25
    Gender:
    Male
    First Name:
    jason
    Coatesville,pa
    Vehicle:
    2007.
    none yet want many
    I tried holding the trip reset button down and started it and it did not work maybe I will just change the oil again this upcoming weekend I dont know why its doing this.
     
  7. Apr 11, 2011 at 3:57 PM
    #7
    JDCPA

    JDCPA Well-Known Member

    Joined:
    Nov 15, 2008
    Member:
    #10777
    Messages:
    936
    Gender:
    Male
    First Name:
    Jim
    SW FL
    Vehicle:
    09 5 Lug Access Cab SR5
    Curt Hitch and etrailer.com wiring harness.
    Do not start the truck. Just turn the key to "On" and leave it there until the Maintenance Light resets. When you pass the "On" position on the key lock it stops trying to reset the light.
     
  8. Apr 11, 2011 at 3:58 PM
    #8
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,188
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    Dont start the engine itself, just flip the key over to auxilary mode I believe it was. Try that first.
     
To Top