1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Thought I fixed my miss, ‘97 5VZ

Discussion in '1st Gen. Tacomas (1995-2004)' started by spencerdiesel, Nov 23, 2021.

  1. Nov 23, 2021 at 1:47 PM
    #1
    spencerdiesel

    spencerdiesel [OP] Well-Known Member

    Joined:
    Apr 19, 2017
    Member:
    #216741
    Messages:
    71
    Gender:
    Male
    First Name:
    Spencer
    Vehicle:
    '97 ext cab flat bed 3.4 5 speed
    So while I had the truck down for the timing belt, water pump etc; I put in 2 new OEM Denso 02 sensors. Long story short, the truck barely ran after the TB install and the cause ended up being a broken tooth on the crank cog/ gear (my fault). Got the truck back together again and it ran smoother and stronger than it has for at least the last 8 years it’s been in the family.
    Before the 02 sensors and TB/ WP job, the truck had an intermittent and random miss/ sputter at full throttle. It wouldn’t always miss at WOT, and rarely missed if rpm was between 2000 and 3000 at WOT.
    It was always guaranteed to miss if WOT below 1500 rpm or so. It also almost always missed at WOT above 3500 rpm.
    The CEL was a p0420 02 sensor code.
    So a few days after the 02 sensor replacement (and running so well) I dip heavy into the throttle at 1400 or so and she falls apart missing. It also missed above 3500 once again.
    Truck has new 2 new Denso 02 sensors (correct for manual trans), dual electrode plugs, new plug wires, new fuel filter, new Walbro fuel pump and everything that comes with the TB/ WP job. Do you all have any opinions about other potential causes?
    The truck ran so perfectly after the 02 sensors (old ones were knockoffs AND ancient) at WOT and the CEL went off I just KNEW that fixed the problem. I was very wrong unfortunately. Thanks!
     
  2. Nov 23, 2021 at 1:51 PM
    #2
    JaCado

    JaCado I make bad choices

    Joined:
    Aug 29, 2016
    Member:
    #195947
    Messages:
    39,686
    Clean the MAF and the throttle body.
     
  3. Nov 23, 2021 at 2:23 PM
    #3
    spencerdiesel

    spencerdiesel [OP] Well-Known Member

    Joined:
    Apr 19, 2017
    Member:
    #216741
    Messages:
    71
    Gender:
    Male
    First Name:
    Spencer
    Vehicle:
    '97 ext cab flat bed 3.4 5 speed
    Thanks for the response! I forgot to add the MAF is spotless (hosed it with MAF cleaner a month or so ago), but I haven’t cleaned the throttle body. Could that cause issues at WOT?
     
  4. Nov 23, 2021 at 2:29 PM
    #4
    JaCado

    JaCado I make bad choices

    Joined:
    Aug 29, 2016
    Member:
    #195947
    Messages:
    39,686
    Yes, I believe so.
    Let's get some other opinions
    @gearcruncher
     
    gearcruncher likes this.
  5. Nov 23, 2021 at 7:42 PM
    #5
    JaCado

    JaCado I make bad choices

    Joined:
    Aug 29, 2016
    Member:
    #195947
    Messages:
    39,686
  6. Nov 23, 2021 at 8:32 PM
    #6
    Bishop84

    Bishop84 Well-Known Member

    Joined:
    Dec 17, 2015
    Member:
    #172494
    Messages:
    6,081
    Gender:
    Male
    Sounds like a MAF or a clogged cat.

    Easiest way is to swap with another 5vz if you know anyone with a good maf.

    With clogged cats easiest way to free it up is to remove the 2 up stream o2 sensors and drive it to see how it feels.

    It could be fuel or a number of other items but its where I would start.

    Throttle cable style 5vz's don't really stumble if the plate is dirty.
     
    JaCado likes this.
  7. Nov 24, 2021 at 3:10 AM
    #7
    spencerdiesel

    spencerdiesel [OP] Well-Known Member

    Joined:
    Apr 19, 2017
    Member:
    #216741
    Messages:
    71
    Gender:
    Male
    First Name:
    Spencer
    Vehicle:
    '97 ext cab flat bed 3.4 5 speed
    Thanks you guys! I’ll pull the 02 sensors and zipper them for a test. The only thing that makes me wonder about a clogged cat is when the truck doesn’t miss, it’s got seemingly full power. The 1st day I drove the truck after the new sensors it ran an 8.9 second 0-60.
    It ran that well for about a week before the old miss issue came back. It’s never run that well for that long (without missing) until changing both 02 sensors. It’s bizarre (coincidental?) the truck ran like new for a week after the sensors when it hasn’t run like that for years, but then it suddenly is back to missing.
    Can a clogged cat sometimes allow full power and other times not? I’ll separately swap in the MAF from my ‘02 taco for a test. Thanks again!
     
  8. Nov 24, 2021 at 3:15 AM
    #8
    spencerdiesel

    spencerdiesel [OP] Well-Known Member

    Joined:
    Apr 19, 2017
    Member:
    #216741
    Messages:
    71
    Gender:
    Male
    First Name:
    Spencer
    Vehicle:
    '97 ext cab flat bed 3.4 5 speed
    Do the stock injectors ever wear out or give any issues on these engines?
     
  9. Nov 24, 2021 at 5:06 PM
    #9
    gearcruncher

    gearcruncher Well-Known Member

    Joined:
    Nov 1, 2012
    Member:
    #90305
    Messages:
    6,697
    Gender:
    Male
    First Name:
    Canadain bumper technician
    Great white North 51.0333° N, 93.8333° W
    Vehicle:
    2010.TRD.SportDCLB4x4Limited leather package
    TRD Sport Rally -5 speed automatic Limited ,Factory heated leather seats ,chrome package,Super white with front windows tinted to 35 % Dick Cepek DC-2 wheels Summer tires - Good year silent armor P265/65R17 Winter tires - Good year P265/65R17 Ultra Ice studded Illuminated 4x4 switch TRD 3rd brake light cover ($20) TRD seat belt shoulder protectors (5). ($50) TRD ...B pillar emblems ($20) TRD rear slider sticker with devil horns ( $6) TRD summer floor matts ($60) TRD steering wheel emblem ($20) TRD floor pedals .($95) TRD shorty antenna ($14) TRD front Windshield emblems ($17) TRD head pillows .($60) TRD head rest protectors TRD door scuff protection $20 TRD floor matt emblems ($40) TRD tow plug emblem . ($40) TRD cigarette lighter with LED.($35) TRD tissue dispenser ($12) TRD front bezel emblems ($9) TRD door emblems ($6) TRD lanyards($9) TRD lisence plates with TRD bolts($50) TRD fender emblems TRD center caps Part Number:PT904-35070-CC ($80) TRD cd
    What are you using to scan for codes ?
     
    JaCado likes this.
  10. Nov 25, 2021 at 5:27 AM
    #10
    spencerdiesel

    spencerdiesel [OP] Well-Known Member

    Joined:
    Apr 19, 2017
    Member:
    #216741
    Messages:
    71
    Gender:
    Male
    First Name:
    Spencer
    Vehicle:
    '97 ext cab flat bed 3.4 5 speed
    This is what I’ve used, and before I got it 2 different advance autos scanned and got the same code.
    I will say it misses much less frequently now after the new sensors, made a pull to redline last night with no hiccups. Before this it would miss probably 8 times out of 10 at WOT above 3500

    C2EF4197-0605-4E3E-BDDD-F1BEB27255C5.jpg
     
    JaCado likes this.

Products Discussed in

To Top