1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Throttle Body

Discussion in '1st Gen. Tacomas (1995-2004)' started by crzylee, Oct 28, 2009.

  1. Oct 28, 2009 at 5:18 PM
    #1
    crzylee

    crzylee [OP] Member

    Joined:
    Jul 20, 2009
    Member:
    #19916
    Messages:
    17
    Gender:
    Male
    Brandon, Ms
    Vehicle:
    99 tacoma xcab 4wd 3.4L
    I have a 99 taco and I purchased a replacement throttle body from a 96 4Runner. Got everything replaced and mounted, but went to plug up the TPS and I have a 3 prong harness, and a 4 prong sensor. Has anyone wired this up to work? Check engine light stays on, and its idling near 2k RPM.

    Thanks!
     
  2. Oct 28, 2009 at 6:20 PM
    #2
    george3

    george3 Well-Known Member

    Joined:
    Jun 8, 2008
    Member:
    #7173
    Messages:
    3,552
    new jersey
    Vehicle:
    tacoma
    Seat belt beeper, Cabelas (Weathertech) floor liner gray, Covercraft Seat Savers in Taupe, Protecta Heavy Duty Rubber Truck Bed Mat, Pop n Lock PL5200, Pace Edwards Full Metal JackRabbit, Wolverine oil pan heater, Scangauge2, afe pro dry s filter, Remote Underbody 4 Piece LED Light Kit (White) used as Bed light, DIY Washable Cabin Air Filter, PA15-TOY, 4x4 Illuminated Switch, full synthetic, Redline Tuning Hood Support, Smittybilt Nerf Steps black powder-coated
    Subscribe, just want 2 no the answer 2 this 1
     
  3. Oct 28, 2009 at 6:32 PM
    #3
    crzylee

    crzylee [OP] Member

    Joined:
    Jul 20, 2009
    Member:
    #19916
    Messages:
    17
    Gender:
    Male
    Brandon, Ms
    Vehicle:
    99 tacoma xcab 4wd 3.4L
    I guess I should have put the engine size sorry - its the 3400 V6
     
  4. Nov 1, 2009 at 6:50 AM
    #4
    crzylee

    crzylee [OP] Member

    Joined:
    Jul 20, 2009
    Member:
    #19916
    Messages:
    17
    Gender:
    Male
    Brandon, Ms
    Vehicle:
    99 tacoma xcab 4wd 3.4L
    BUMP!

    Anyone? Someone? Anything!
     
  5. Nov 1, 2009 at 7:00 AM
    #5
    Brunes

    Brunes abides.

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,641
    Gender:
    Male
    First Name:
    Rotorhead
    DC or New Jersey - Depends on the day....
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit
    You might not be getting any answers cause this is in the wrong section...Should be a 1st gen post.

    No idea what you can do...sorry.
     
  6. Nov 1, 2009 at 7:18 AM
    #6
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,156
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    I'lll move it to first gens.
     
  7. Nov 1, 2009 at 7:25 AM
    #7
    xsvtoyz

    xsvtoyz Well-Known Member

    Joined:
    Sep 9, 2008
    Member:
    #9099
    Messages:
    182
    Gender:
    Male
    First Name:
    AL
    Oklahoma
    Vehicle:
    03 Pre-Runner Inprogress
    HID (ACA)/ Web cams/ Header/Full Custom exhaust/ K&N FIPK II/SuperCharger
    well this may sound a little basic but can you swap the TPS? probably the easiest fix
     
  8. Nov 1, 2009 at 10:35 AM
    #8
    wolfgang123

    wolfgang123 Well-Known Member

    Joined:
    Jul 7, 2009
    Member:
    #19369
    Messages:
    1,426
    Gender:
    Male
    First Name:
    Skyler
    Statesboro, GA
    Vehicle:
    1997 TACOMA - 4x4
    could you just splice the wires and hook them us to the correct plug? idk
     
  9. Nov 1, 2009 at 3:17 PM
    #9
    jfr02

    jfr02 Well-Known Member

    Joined:
    Apr 4, 2009
    Member:
    #15567
    Messages:
    233
    Gender:
    Male
    Vehicle:
    2012 dcsb 6spd sport
    yeah what he said or just take it back and get the right one
     
  10. Nov 1, 2009 at 9:15 PM
    #10
    crzylee

    crzylee [OP] Member

    Joined:
    Jul 20, 2009
    Member:
    #19916
    Messages:
    17
    Gender:
    Male
    Brandon, Ms
    Vehicle:
    99 tacoma xcab 4wd 3.4L
    Thanks, thought I had a 2nd Gen, my bad. First time owning a Taco and don't know a whole lot about them.

    Thought about that and started to try it. Realized on the new TB, the butterfly rod isn't the same as the old one. Old one has a single rod, the new one has 3. Weird.

    Heard I could do this, but I'm unsure of what wires from the harness go to what ports on the TPS.

    Can't do that. eBay purchase and it was used. Got it with a cruise control module for $40. New they were $200 +
     
  11. Nov 1, 2009 at 10:47 PM
    #11
    genxer36

    genxer36 Lord of Tomfoolery

    Joined:
    Nov 13, 2007
    Member:
    #3442
    Messages:
    10,581
    Gender:
    Male
    First Name:
    Sean
    Bethlehem,GA
    Tow package, XM Satellite radio, K & N Air filter, & Channel Vent Visors
    Check the junkyard for the correct one & resell that one on ebay. Splicing and rigging it to fit sounds like it could cause more harm than good down the road.

    Welcome to TW!
     
  12. Nov 2, 2009 at 10:49 AM
    #12
    PrezidentRedz

    PrezidentRedz Uncivilized Creations Prez

    Joined:
    Nov 17, 2008
    Member:
    #10820
    Messages:
    3,687
    Gender:
    Male
    First Name:
    Redz
    Owings, MD
    Vehicle:
    00 Taco 4x4 Xtra Cab, Locked and Lifted.
    Custom Everything! WHAT º¿º
    x2, sounds like the wrong TB.
     
  13. Nov 3, 2009 at 4:20 AM
    #13
    crzylee

    crzylee [OP] Member

    Joined:
    Jul 20, 2009
    Member:
    #19916
    Messages:
    17
    Gender:
    Male
    Brandon, Ms
    Vehicle:
    99 tacoma xcab 4wd 3.4L
    Thanks guys! I will do some searching.
     
To Top