1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

too much steering play?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by LVTacoma, Mar 18, 2010.

  1. Mar 18, 2010 at 10:54 AM
    #1
    LVTacoma

    LVTacoma [OP] Well-Known Member

    Joined:
    Jun 28, 2009
    Member:
    #19027
    Messages:
    258
    Gender:
    Male
    Anyone else feel like their Tacoma have too much steering play? Maybe its the spacers or the tires but, it feels like the steering is pretty loose for what it should be. Always feel like the truck is floating on the freeway and by that I mean slight adjustments to the steering wheel with unresponsive steering. Or when I make right or left hand turns, I have to rotate the wheel way more than I should. Am I crazy or does anyone else have that problem with thier Tacomas?
    Specs:
    265/75/16 BFG A/T's
    3" Rough Country lift
    SpiderTrax spacers
    no sway bar
     
  2. Mar 18, 2010 at 11:01 AM
    #2
    borderbrat

    borderbrat Watching Chris4x4 o.O

    Joined:
    Nov 15, 2007
    Member:
    #3480
    Messages:
    2,486
    Gender:
    Male
    First Name:
    Jeremy
    Victoria BC, Canada
    Vehicle:
    2008, Black sand pearl, SR5, 4X4
    PIAA fogs, led "puddle" lights, bed lights, in cab 115V, Toyota Devil emblem, Randy Ellis light bar with Hella Black Magics, OME 885 and Dakar leaf springs OME shock all round, 2.5 Gal OBA system with air horns, iPod adapter, scangauge on blend mount, magnaflow catback, bike fork mounts, tinted 2009 tails.
    mines tight your steering components might have some wear.
     
  3. Mar 18, 2010 at 11:06 AM
    #3
    aficianado

    aficianado Well-Known Member

    Joined:
    Oct 27, 2009
    Member:
    #25015
    Messages:
    5,469
    Gender:
    Male
    bay area, california
    Vehicle:
    2006 access cab. 4x4, TRD-OR
    back to bone stock.
    your 3" lift is messing with your alignment specs. camber is off.
     
  4. Mar 18, 2010 at 11:07 AM
    #4
    Pope953

    Pope953 That's a fact Jack!

    Joined:
    Feb 25, 2010
    Member:
    #32117
    Messages:
    11,731
    Gender:
    Male
    First Name:
    Wesley
    Asheville, NC
    Vehicle:
    SR5 Pickup
    35% up front, 20% in the back window tint, 15" Mickey Thompson bullet hole wheels, with 31x10.5 Firestone Destination A/T tires. Glass Pack, High Flow Cat, S&B CAI, Custom Light Bar with 4 fog lights. 2 10" Rockford Fosgate P2 subs with 1000 watt Rockford Fosgate Amp, CB.
    x2
     
  5. Mar 18, 2010 at 8:25 PM
    #5
    shawnresa

    shawnresa Member

    Joined:
    Mar 18, 2010
    Member:
    #33490
    Messages:
    20
    Gender:
    Male
    First Name:
    shawn
    jashua tx
    Vehicle:
    2009 4x4 prerunner
    3" lift 285/75/16 black procomp wheels
    mine is like that to but my alignment was done o camber and 2.5 caster doesnt fill loose but bumpy in wheel and all over the place
     
  6. Mar 18, 2010 at 8:31 PM
    #6
    fireturk41

    fireturk41 I like to break shit!

    Joined:
    Dec 23, 2008
    Member:
    #11857
    Messages:
    4,805
    Gender:
    Male
    First Name:
    Kevin
    High Point, NC
    Vehicle:
    280k miles
    SAS, Locked front rear, Ufab sliders and bumpers, air compressor, 35" BFG KM2 on steelies and 36" TSLs
    when i replaced my rack and pinion mine corrected
     
To Top