1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Traction, ABS, and 4hi lights on...Help!

Discussion in '2nd Gen. Tacomas (2005-2015)' started by mjcruiser, Mar 22, 2016.

  1. Mar 22, 2016 at 7:50 AM
    #1
    mjcruiser

    mjcruiser [OP] Well-Known Member

    Joined:
    Nov 17, 2014
    Member:
    #142599
    Messages:
    228
    Gender:
    Male
    Vehicle:
    09 TRD OR DCSB
    Bilstein 5100's Toytec Springs OME Dakars Raceline R6 Wheels
    So I've been doing some searching and have kind of concluded that the issue is with one (or more) of my abs sensor wires and possibly my front diff actuator, but I'd like a little more input from anyone with experience with this.

    Some backstory, I have a 2.5 inch lift all around. Never had an issue with abs or traction control post lift, but I've only had it on for about a month.

    Went to Cleghorn on Saturday and all was well. When I turned on my car Sunday morning, the 4Hi light was flashing, but not beeping. Again, after some searching, I figured it may be the front diff actuator and that I would rip it apart next weekend to see if I could repair it.

    I continued to drive it since I did confirm it's in 2WD and I won't be needing 4WD to get to and from work anyway. This morning, on my way to work, the traction and abs lights came on and stayed on.

    Long story short, just looking for someone to point me in the right direction of where to start. My Christmas Tree dashboard has triggered my OCD and now this must be fixed immediately. Guess this would also be a good time to ask if any local SoCal residents have these parts laying around and are looking to offload them.
     
  2. Mar 22, 2016 at 9:13 AM
    #2
    CroResident

    CroResident Well-Known Member

    Joined:
    Oct 15, 2011
    Member:
    #65233
    Messages:
    414
    Gender:
    Male
    First Name:
    Nick B
    Opelousas, Louisiana
    Vehicle:
    2015 4X4 DCSB
    6" Zone lift 35x12.50 Super Swampers
    i ran into the SAME EXACT issues after my lift. not to worry. its a simple fix.
    The ABS light and traction light were both cleared simply by going to the dealership and have them clear the codes.
    the 4wd light on the other hand is a little different.

    i pulled my actuator the other day and soldered the terminals. every once in a while, when i engage my 4wd it will act up and start flashing. i spent an hour talking with a few of the techs at the dealership after i did the actuator job (i did it myself at the house). they advised me to try engaging/disengaging 4hi in different ways to figure out which way the actuator works best. (such as: rolling 10-15 mph with my foot off the gas, rolling forwards and backwards while engaging/disengaging, and the main thing they told me to do was to make sure i engage 4hi more often) i have found much success with these steps alone.
    i would recommend giving that a shot before pulling the actuator.
     
  3. Mar 22, 2016 at 11:06 AM
    #3
    mjcruiser

    mjcruiser [OP] Well-Known Member

    Joined:
    Nov 17, 2014
    Member:
    #142599
    Messages:
    228
    Gender:
    Male
    Vehicle:
    09 TRD OR DCSB
    Bilstein 5100's Toytec Springs OME Dakars Raceline R6 Wheels
    I'll try the reset procedure for ABS and traction when I get home, theres a way to clear codes by jumping some pins on the obd port without going to the dealership. I still have a feeling I may have stretched the wires for the ABS harness. I had the wheels up in the air a bit....
     
  4. Mar 22, 2016 at 7:29 PM
    #4
    CroResident

    CroResident Well-Known Member

    Joined:
    Oct 15, 2011
    Member:
    #65233
    Messages:
    414
    Gender:
    Male
    First Name:
    Nick B
    Opelousas, Louisiana
    Vehicle:
    2015 4X4 DCSB
    6" Zone lift 35x12.50 Super Swampers
    Keep us updated
     
  5. Mar 26, 2016 at 9:04 PM
    #5
    mjcruiser

    mjcruiser [OP] Well-Known Member

    Joined:
    Nov 17, 2014
    Member:
    #142599
    Messages:
    228
    Gender:
    Male
    Vehicle:
    09 TRD OR DCSB
    Bilstein 5100's Toytec Springs OME Dakars Raceline R6 Wheels
    In case anyone was curious, it was the front diff actuator. Looks like sand and water got in. I was able to repair it after cleaning it up, drying it out, and soldering the connections. I'll be ordering a new one anyway since there was a little rust on the motor and I don't trust it.

    ABS and traction lights went off the next startup that same morning, weird.
     
    CementTRDOffRoad and CroResident like this.
  6. Mar 28, 2016 at 4:03 AM
    #6
    CroResident

    CroResident Well-Known Member

    Joined:
    Oct 15, 2011
    Member:
    #65233
    Messages:
    414
    Gender:
    Male
    First Name:
    Nick B
    Opelousas, Louisiana
    Vehicle:
    2015 4X4 DCSB
    6" Zone lift 35x12.50 Super Swampers
    good to hear man thats good news
     

Products Discussed in

To Top