1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

TRD CAI or engine malfunction ?

Discussion in 'Technical Chat' started by tacohei, Nov 22, 2011.

  1. Nov 22, 2011 at 6:55 PM
    #1
    tacohei

    tacohei [OP] New Member

    Joined:
    Nov 22, 2011
    Member:
    #67547
    Messages:
    2
    Gender:
    Male
    Vehicle:
    08 trd sport
    Supercharged
    I just add a trd cai to my 08 supercharged. For 1 week, everything was OK. Then the engine suddenly stop while I was driving, I put the transmission to neutral and it starts again. The check engine light was on.
    I went back to the oem cai and the engine stops again.
    Can you help me on this.
    PS : Forgive me for my english because it's not my spoken language.
     
  2. Jan 5, 2012 at 11:34 AM
    #2
    tacohei

    tacohei [OP] New Member

    Joined:
    Nov 22, 2011
    Member:
    #67547
    Messages:
    2
    Gender:
    Male
    Vehicle:
    08 trd sport
    Supercharged
    Sorry for the late reply.
    Codes are : P0031, 32, 102.
    I've put my old air filter, erase the codes from the ECU and since 1 week, no more engine shutdown.
     
  3. Jan 8, 2012 at 9:25 PM
    #3
    thebottomline

    thebottomline Well-Known Member

    Joined:
    Nov 15, 2010
    Member:
    #46203
    Messages:
    658
    Gender:
    Male
    Pac NW
    Vehicle:
    11 sport
    102 is the mass air flow sensor I believe
     
To Top