1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

TRD S/C + URD 7th Injector = ??AFR??

Discussion in 'Performance and Tuning' started by kckrawford, Mar 22, 2014.

  1. Mar 22, 2014 at 4:59 PM
    #1
    kckrawford

    kckrawford [OP] Well-Known Member

    Joined:
    Sep 29, 2012
    Member:
    #87952
    Messages:
    121
    Gender:
    Male
    First Name:
    Casey
    Longview, TX
    Vehicle:
    01 DC Ltd. TRD 4x4
    I'll try to explain this the best that I can so that maybe someone can explain what is taking place to me.

    I have the TRD Supercharger with the URD 7th Injector kit. Also have the 2.2" pulley, Doug Thorley headers, new cat's, new o2 sensor and afr sensor along with innovate motor sports o2 sensor and a magnaflow cat back exhaust.

    During normal driving, IE: maintaing 70mph i'm running almost exactly 2100 rpm's (automatic) and the AFR on the gauge is showing between 14.6-14.8. Pretty much ideal from my understanding. This is all assuming that I'm running on flat ground. (Also in North Dakota and elevation is approx 2000-2200' on average.)

    The problem that I'm having is that when it comes to a hill, not really anything major, but just a decent incline, as long as i try to maintain 70 the truck seems to do ok. If i give it just a touch of gas, enough to hold the speed the AFR seems to run at 13.0-14.0 Which is still fine. The problem that I have is when i give it enough to gas to pick up speed (to pass someone), but not enough to actually downshift to 3rd (i'm assuming this is the torque converter kicking in/out) I go to about 2800 rpms and the AFR drops to 12.5-13.5 but after about 5-7 seconds the RPM's drop to 2500-2600 and the AFR goes to 15.5-17.0. This is what i'm concerned with. I'm not sure why this happens and the AFR will hold at this lean mixture until i let off the gas completely and then when I get back on the gas it goes back to 14.7. Unless of course i get back to the 2800 rpm area and it drops rpms and leans out again.

    The motor shouldn't be under to much of a load there, not like I've got my foot to the floor during this time. I don't hear any pinging when it leans out, but i do run premium fuel with every tank and it's not like the RPM's are very high.

    I haven't done very much WOT to see if the AFR drops quite a bit because I'm waiting to get the IPT valve body upgrade done so I don't toast the trans. Basically been babying the thing since I put the supercharger on it.

    Is this a normal thing, or do I need to see about going through and tuning it. Is it possible I wired up something wrong on the AIC and it's not working properly? Any way to check this?

    Thanks
     
  2. Mar 22, 2014 at 9:56 PM
    #2
    trdtoy

    trdtoy Well-Known Member

    Joined:
    Sep 8, 2013
    Member:
    #112123
    Messages:
    134
    Gender:
    Male
    North Carolina
    Vehicle:
    02 sr5 4x4 auto v6 turbo (sold)
    Turbo with supporting mods and tranny to hold power.
    First be sure everything is wired corretly. Then go through and tune the aic or 7th ect. Rpm not high enough to where it should go into open loop so must have something to do with closed loop enrichment and tuning in the aic/7th injector you have. You need to check afrs in each pressure and rpm block in tuning software. This can be done by one person but easier to do with two.
    oh and put it in second gear and do a wot run starting say 3k rpm and go to 5.5 k or so an monitor afr. Want it to be high 11's near 12. Tranny will be fine as long as you do not go through a lot of hard shifts. Also second gear should not slip clutches at power levels you are running if you tranny is in remotely good shape.
     
  3. Mar 23, 2014 at 5:52 PM
    #3
    Torspd

    Torspd Tor-nication

    Joined:
    Sep 18, 2009
    Member:
    #22958
    Messages:
    5,642
    Gender:
    Male
    First Name:
    Tor
    Houston
    Vehicle:
    MMVI 4.4L 4x4 Access Cab
    Torspd Custom Turbo kit [] Borg Warner 9180EFR Turbo [] ProEFI Pro128 EMS [] TiAL Q BOV [] TiAL V44 Wastegate @ 15psi [] CP Pistons [] CP Carrillo Rods [] ARP Head studs [] ARP Main Studs [] ARP Header - Head Studs [] Ported Heads w/ 1mm oversized valves intake/exhaust [] Brian Crower Forged Stroker Crank [] Darton M.I.D. Sleeved Block [] Kelford Camshafts [] Torspd 170* T-stat mod [] APR Large Fuel Rail [] Aeromotive Stealth 340 LPH Fuel Pump [] FueLab FPR [] APR T56 Conversion Kit [] KP RACING Built T56 [] McLeod Racing Custom Twin Disk Clutch [] One Piece Aluminum Driveshaft [] MGW Shifter [] Custom lowering kit [] Ohlins Front Coilovers [] QA1rear shocks [] Custom Ron Davis Radiator [] Dual SPAL Electric Fans []
    Why is it that the RPMs drop? From 2800 to 2500? Is that because you let off of the throttle?
     
  4. Mar 23, 2014 at 5:55 PM
    #4
    kckrawford

    kckrawford [OP] Well-Known Member

    Joined:
    Sep 29, 2012
    Member:
    #87952
    Messages:
    121
    Gender:
    Male
    First Name:
    Casey
    Longview, TX
    Vehicle:
    01 DC Ltd. TRD 4x4
    That's the weird part. It's not me letting off the throttle. It just does it. I assumed it was something to do with the torque converter Locking up/releasing. I'm not real familiar with how a auto trans completely works, and this is the first auto tacoma that I've owned. My 96 is a manual.
     
  5. Mar 24, 2014 at 2:42 AM
    #5
    hoenah808

    hoenah808 Well-Known Member

    Joined:
    Jan 26, 2014
    Member:
    #121533
    Messages:
    616
    Gender:
    Male
    Honolulu, HI
    Vehicle:
    '14 AC sr5 4x4
    are you running the stock urd tune? i came from 4runners and on the 4runner forums they got guys using custom maps..maybe you should look into it
     
  6. Mar 24, 2014 at 5:47 AM
    #6
    Lurkin

    Lurkin Well-Known Member

    Joined:
    May 21, 2009
    Member:
    #17497
    Messages:
    4,703
    First Name:
    Rod
    Pearland, TX
    Vehicle:
    09 PreRunner SR5 DC
    After first checking the wiring and the plumbing, I would be getting a scan tool that can tell me if this scenario is happening in closed or open loop. While open loop is normally 3/4-full throttle or so, it can also go into open loop at higher load, but lower rpms. Open vs. closed loop tells me what sensors to focus on.
     
  7. Mar 24, 2014 at 9:39 PM
    #7
    kckrawford

    kckrawford [OP] Well-Known Member

    Joined:
    Sep 29, 2012
    Member:
    #87952
    Messages:
    121
    Gender:
    Male
    First Name:
    Casey
    Longview, TX
    Vehicle:
    01 DC Ltd. TRD 4x4
    Yeah, the stock URD tune that came with the AIC.
     
  8. Mar 24, 2014 at 9:41 PM
    #8
    kckrawford

    kckrawford [OP] Well-Known Member

    Joined:
    Sep 29, 2012
    Member:
    #87952
    Messages:
    121
    Gender:
    Male
    First Name:
    Casey
    Longview, TX
    Vehicle:
    01 DC Ltd. TRD 4x4
    I'll have to get me a PC and get plugged into the AIC so that I can see what's actually going on between closed loop/open loop mode. Can't seem to get the mac to connect to it with the windows 7 running on parallel desktop.
     
  9. Mar 25, 2014 at 6:53 AM
    #9
    Vassily28

    Vassily28 Well-Known Member

    Joined:
    Nov 24, 2011
    Member:
    #67629
    Messages:
    275
    Gender:
    Male
    Quebec, Quebec, Canada
    Vehicle:
    11 TRD SPORT 4x4 Quabcab LB
    TRD supercharger with 2.85" URD stealth pulley and OEM FPR mod. URD fuel pump upgrade, URD TB plate adapter 70mm, FJ/4 runner 70 mm Throttle body, TRD CAI 1st gen. with custom cover (coupe), ProDry S + Filter skin, Doug thorley long tube headers, Doug Thorley Y-pipe, Vibrant Ultra Quiet resonator, Icon LT 2.5 front coilover, Timbren front bumpstops, Total Choas UCA, Deaver custom leafpack 3 inch. lift, Icon 2.5 VS series rear resishocks, Timbren rear bumpstops, ARB front bumper with WARN 8500 lbs winch,Hella 500 blackmagic, AVID rear bumper, Allpro front IFS skid + Trans. skid + Transfercase skid. Total chaos LCA skid, SS braided brake line, URD O2 sims, URD MAF controller, Wetokole front seatcovers, Innovate MTX-L, MTX-D AFR and boost gage.
    Don't know the AIC but does it have a map like a MAF controller with 500 rpm incrementals?

    Saying that cause in this kind of map at from 2501 rpm to 3000 rpm youre in the 3000 rpm cell. So it can be induced by a transition from 2500 to 3000 in your map.

    Like others said you should check if it happens in close or open loop.
    On the 2gen. 2500-3000 rpm is a transition area for close-open loop depending on TPS.
     
  10. Mar 25, 2014 at 7:52 AM
    #10
    StAndrew

    StAndrew Wait for it...

    Joined:
    Feb 8, 2010
    Member:
    #30950
    Messages:
    5,455
    Gender:
    Male
    First Name:
    Chris
    Hampton Roads, Va
    Vehicle:
    SR5 4x4TRD
    Deck Plate Mod; Grey Wire Mod; 1.5" AAL; 1.75" Lift Shackles; Bilstein 5100's; Eiback Coils; LR UCA; Front Diff Drop; Tundra Brake Upgrade; Wheels Offroad Brake Lines; Rear Diff Breather Mod
    Its probably the lock up clutch engaging (feels like a 5th gear sometimes). Do you have a boost gauge? AFR should be rich only in boost however it shouldnt ever be going over 14.8.

    Here's what I think is happening but Im no professional: when you hit the gas and downshift, the boost goes up and the 7th injector starts firing. When the 7th is firing, the ECM is probably decreasing the stock injectors to compensate (need more tuning to eliminate this). When your lock up clutch engages, the 7th turns off due to a drop in boost but the ECM is still firing lean on the stock injectors.

    Just need some tweaks to the tuning I think. For now, be careful and stay out of that lean zone.
     
    Last edited: Mar 25, 2014
  11. Mar 25, 2014 at 5:15 PM
    #11
    kckrawford

    kckrawford [OP] Well-Known Member

    Joined:
    Sep 29, 2012
    Member:
    #87952
    Messages:
    121
    Gender:
    Male
    First Name:
    Casey
    Longview, TX
    Vehicle:
    01 DC Ltd. TRD 4x4
    That damn sure sounds like what is going on.

    As soon as i can get access to a PC, i'll get plugged into the AIC from URD and see if i can't figure out exactly what's going on.

    I do have a boost gauge. During the time that the truck is leaning out, i'm usually only at 1-2 lbs of boost max. max boost i've seen on the truck is around 8-9 and when I'm that high in boost, AFR is usually 11-12. Just seems like the transition from closed to open isn't as defined as it needs to be. There seems to be some cells, or at least some certain conditions to where it needs more fuel.

    Just not getting why the lockout clutch will kick out slightly when holding the same amount of throttle.
     
  12. Mar 26, 2014 at 4:33 AM
    #12
    Lurkin

    Lurkin Well-Known Member

    Joined:
    May 21, 2009
    Member:
    #17497
    Messages:
    4,703
    First Name:
    Rod
    Pearland, TX
    Vehicle:
    09 PreRunner SR5 DC
    The converter lockup will not kick out slightly, it's either locked or not, unless there is a problem with it. If the ECM senses more load, but the same throttle position, the converter may unlock.
     
  13. Mar 26, 2014 at 4:39 AM
    #13
    StAndrew

    StAndrew Wait for it...

    Joined:
    Feb 8, 2010
    Member:
    #30950
    Messages:
    5,455
    Gender:
    Male
    First Name:
    Chris
    Hampton Roads, Va
    Vehicle:
    SR5 4x4TRD
    Deck Plate Mod; Grey Wire Mod; 1.5" AAL; 1.75" Lift Shackles; Bilstein 5100's; Eiback Coils; LR UCA; Front Diff Drop; Tundra Brake Upgrade; Wheels Offroad Brake Lines; Rear Diff Breather Mod
    Edit, quick point on the lock up clutch: Put your truck into "ECT Power" mode (should be a switch left of the steering wheel) and it will offset the shift bias to prefer lower gears. More importantly, its target speed for the lock up clutch is 60 vice 50. You can still engage at 50 if you want by releasing the gas a bit then accelerating slowly (if you want to save gas). If you are accelerating hard enough in 4th gear with ECT Power, the lock up clutch wont engage (acceleration doesnt have to be that hard though). In ECT Normal, it wont engage if you are accelerating hard, but generally, if your pedal isnt halfway down, it will try to engage.

    On the lean out, again Im not an expert (verify with Gadget at URD) but here's what is happening I think.

    When the 7th injector engages to enrich the mixture, the controller is supposed offset the O2 signal to the ECM to make it look like its still running a 14.8 AFR. Otherwise, the ECM will start leaning out the stock injectors to reduce the AFR back to stock. Unfortunately the kit comes with a base tune that is designed to work with all trucks, but as we know, no truck is the same. While it works well enough and is a very good start, you kind of want to tweak the tune to match your particular truck.

    I believe what you are experiencing is the URD controller isnt inputting enough offset into the O2 signal to the ECM so it still reads a bit rich and trims the stock injectors to compensate. Talk to Gadget on how to tweak the O2 signal to make sure the ECM doesnt seen anything lower than 14.8.
     
    Last edited: Mar 26, 2014
  14. Mar 26, 2014 at 9:22 PM
    #14
    kckrawford

    kckrawford [OP] Well-Known Member

    Joined:
    Sep 29, 2012
    Member:
    #87952
    Messages:
    121
    Gender:
    Male
    First Name:
    Casey
    Longview, TX
    Vehicle:
    01 DC Ltd. TRD 4x4
    I will give the ECT Power mode a shot and see how it responds.

    I finally got my mac working with the truck so hopefully in the next day or so i can take a small trip and watch what's going on.

    Your opinion certainly sounds logical on what the truck is doing causing the lean enrichment during the certain rpm range.

    AT least having the base tune will be a big help. I'll just adjust off of there and see what I can figure out. I wish I knew a place local to me that does tuning. I'd just have them do it. It's a long trip to maryland to have gadget do it.
     
  15. Mar 26, 2014 at 9:23 PM
    #15
    kckrawford

    kckrawford [OP] Well-Known Member

    Joined:
    Sep 29, 2012
    Member:
    #87952
    Messages:
    121
    Gender:
    Male
    First Name:
    Casey
    Longview, TX
    Vehicle:
    01 DC Ltd. TRD 4x4
    Got it. I'm assuming there is no problem with the converter. Like you said, it seems i'm in a high load, same throttle and it's unlocking. I'm going to try the ECT button for a bit and see if makes a difference.
     
  16. Mar 26, 2014 at 9:26 PM
    #16
    davidpick

    davidpick Well-Known Member

    Joined:
    Jan 21, 2010
    Member:
    #29760
    Messages:
    1,954
    Gender:
    Male
    First Name:
    David
    Everett, WA
    Vehicle:
    2004 Xcab 4x4 TRD
  17. Mar 27, 2014 at 4:17 AM
    #17
    StAndrew

    StAndrew Wait for it...

    Joined:
    Feb 8, 2010
    Member:
    #30950
    Messages:
    5,455
    Gender:
    Male
    First Name:
    Chris
    Hampton Roads, Va
    Vehicle:
    SR5 4x4TRD
    Deck Plate Mod; Grey Wire Mod; 1.5" AAL; 1.75" Lift Shackles; Bilstein 5100's; Eiback Coils; LR UCA; Front Diff Drop; Tundra Brake Upgrade; Wheels Offroad Brake Lines; Rear Diff Breather Mod
    It will just keep the truck from locking up too early. It wont fix the problem. A con of having a SC is your boost is dependent on RPMs. When your clutch locks up, you lose RPMs and subsequently boost, which is why your 7th injector suddenly cuts off and you get a lean mixture.

    Did you try talking to Gadget yet? He's on here sometimes but the best way to contact is via the support email on URDUSA.com. There should be a way to adjust the calibration to fix the AFR readings.

    He has a controller, he just needs to adjust the tune.
     
  18. Mar 27, 2014 at 6:15 PM
    #18
    kckrawford

    kckrawford [OP] Well-Known Member

    Joined:
    Sep 29, 2012
    Member:
    #87952
    Messages:
    121
    Gender:
    Male
    First Name:
    Casey
    Longview, TX
    Vehicle:
    01 DC Ltd. TRD 4x4
    I haven't talked to gadget yet. I work nights so I'm asleep during the day. And since I live at work (work on a drilling rig in north dakota) I don't have to drive to work once i'm here. Haven't even driven the truck in 5 days.

    I don't have the AFR controller. I have the AIC/Timing Calibrator controller that comes with the 7th injector kit.

    http://urdusa.com/Electronics-Perfo...troller-/-Timing-Calibrator/product_info.html

    This is the one that I have. I know that you can use the AFR controller along with the AIC/timing controller if need be but apparently most people never need it.

    Your statement about it locking up and losing rpm and boost is pretty much exactly what it does on small hills where i don't have to down shift. I'm going to get up early enough tomorrow (or maybe when i get off in the morning) and take the truck for a stroll for a bit with the laptop plugged in to see what i can figure out. I'll try the ECT button and see how much of a difference it makes.
     
  19. Mar 27, 2014 at 7:44 PM
    #19
    StAndrew

    StAndrew Wait for it...

    Joined:
    Feb 8, 2010
    Member:
    #30950
    Messages:
    5,455
    Gender:
    Male
    First Name:
    Chris
    Hampton Roads, Va
    Vehicle:
    SR5 4x4TRD
    Deck Plate Mod; Grey Wire Mod; 1.5" AAL; 1.75" Lift Shackles; Bilstein 5100's; Eiback Coils; LR UCA; Front Diff Drop; Tundra Brake Upgrade; Wheels Offroad Brake Lines; Rear Diff Breather Mod
    Gotcha, good luck. I thought the kit would provide some O2 slewing. Honestly, I dont think you REALLY need it, but it can help. As long as you have a rich AFR in boost you should be good to go. Give Gadget an email and see what he thinks (ref him to this thread so he can chime in. He's a TW member but not on a whole lot). At worst your convo will have 12 hour delays :p
     
  20. Mar 29, 2014 at 2:40 PM
    #20
    kckrawford

    kckrawford [OP] Well-Known Member

    Joined:
    Sep 29, 2012
    Member:
    #87952
    Messages:
    121
    Gender:
    Male
    First Name:
    Casey
    Longview, TX
    Vehicle:
    01 DC Ltd. TRD 4x4
    I did manage to get to drive some today (to the airport to fly home). The truck was still doing the same thing even in ECT mode. I was able to hook the AIC up to the computer as i was driving, but it was hard to see what was really going on and trying to drive at the same time. I'll have to get someone drive the truck while i ride so i can monitor things. I'm going to give gadget a call on monday just to see if he can give me a heads up. Also going to make sure that the tune that's in the truck is what's suppose to be there.

    I pulled the tune from the AIC and copied it into excel. I'm going to email that to him after I talk to him and have him confirm that I have the right setup that they recommend and then go from there.

    Once i get this tuning figured out, i gotta find the damn vibration i've been having.
     
To Top