1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Trouble after 09 radio replacement?

Discussion in '2nd Gen. Tacomas' started by BlackRig, Jun 20, 2009.

  1. Jun 20, 2009 at 12:01 PM
    #1
    BlackRig

    BlackRig [OP] Well-Known Member

    Joined:
    Feb 21, 2009
    Member:
    #13900
    Messages:
    224
    Gender:
    Male
    First Name:
    Craig
    Redwood City, CA
    Vehicle:
    09 TRD O/R AT
    My radio has been acting up. I know there's been a bunch of threads about the stock head units in 09's but have you have trouble since you're replacement from Toyota? I need to take mine in and have them replace it under warranty but I don't want to swap it with another defective.

    Does anyone know if the replacements are updated or still having the same trouble?
     
  2. Jun 20, 2009 at 12:22 PM
    #2
    brian

    brian Another Traitor

    Joined:
    Apr 15, 2009
    Member:
    #16011
    Messages:
    7,568
    Gender:
    Male
    Roseville, CA
    Vehicle:
    2008 F-350 Powerstroke
    Ever considered just putting in an aftermarket? The dash kits are cheap, and you can pick up older model decks for real decent prices. My deck is over 4 years old and it still performs like a champ.
     
  3. Jun 20, 2009 at 1:51 PM
    #3
    Monarch

    Monarch Threadkiller

    Joined:
    Jun 18, 2009
    Member:
    #18635
    Messages:
    169
    Gender:
    Male
    Kitchener, Ontario
    Vehicle:
    09 AC 4X4 2.7L 5 speed SR5 barcelona red
    Readylift, Roadmaster, Bushwacker, Pop & Lock, Redline, Weathertech, Crappy Tire
    Just curious and I haven't done a search yet, but what is the problem?
    The reason I ask is that my volume control on the radio sometimes doesn't work but the steering wheel controls still function. 8K on the truck and it's been doing this intermittently since new. The only solution so far is to turn the radio and the ignition off and then restart. It's not a big deal, but at some point, I'll need to address the problem.


    monarchrifle.com/doug's2009tacoma.html
     
  4. Jun 20, 2009 at 2:11 PM
    #4
    BlackRig

    BlackRig [OP] Well-Known Member

    Joined:
    Feb 21, 2009
    Member:
    #13900
    Messages:
    224
    Gender:
    Male
    First Name:
    Craig
    Redwood City, CA
    Vehicle:
    09 TRD O/R AT
    I have been considering it. Especially because the new iPhone update is supposed to have Bluetooth audio. It would be nice to have a wireless aux and hands free. But it's mostly principle with a new truck and all. Plus selling the stock radio helps to offset the new one.
     
  5. Jun 20, 2009 at 2:39 PM
    #5
    Monarch

    Monarch Threadkiller

    Joined:
    Jun 18, 2009
    Member:
    #18635
    Messages:
    169
    Gender:
    Male
    Kitchener, Ontario
    Vehicle:
    09 AC 4X4 2.7L 5 speed SR5 barcelona red
    Readylift, Roadmaster, Bushwacker, Pop & Lock, Redline, Weathertech, Crappy Tire
    Your stock radio is basically worthless, unless you plan to sell your truck.

    monarchrifle.com/doug's2009tacoma.html
     
  6. Jun 20, 2009 at 5:27 PM
    #6
    kilgoja

    kilgoja Well-Known Member

    Joined:
    Jun 20, 2009
    Member:
    #18685
    Messages:
    593
    Gender:
    Male
    Alabama
    Vehicle:
    2009 regular cab 4x4 2.7L (silver)
    :mudding:
    yeah my stock one would just turn on by itself and then turn off about a min later....only did it every once in awhile not all the time....anyways the dealer ordered me a new one for free so we'll see what happens...they said ever since 05 they have had radio problems on some of the trucks but not all of them...whatever company that makes these newer radios screwed up somewhere...lol...anyways should be fine once it's replaced
     
  7. Jun 20, 2009 at 7:32 PM
    #7
    jiles111

    jiles111 Well-Known Member

    Joined:
    May 27, 2009
    Member:
    #17718
    Messages:
    53
    Gender:
    Male
    Abilene, TX
    Vehicle:
    09 RegCab 4x4 Super White
    I had mine replaced at 1000 miles. The new unit's volume and tuner are tighter. I have not had any trouble with the new one what so ever. It took the dealer about 3 weeks to get it in, and about 30 minutes to replace it. Didn't even have to fuss at them. I just called and said that the volume does not work correctly and it turns it self off and changes channels when it wants to. He said Ok bring it in so I can get the numbers off of it and I will get you a new one ordered.
    :D
     
  8. Jun 23, 2009 at 5:28 PM
    #8
    Monarch

    Monarch Threadkiller

    Joined:
    Jun 18, 2009
    Member:
    #18635
    Messages:
    169
    Gender:
    Male
    Kitchener, Ontario
    Vehicle:
    09 AC 4X4 2.7L 5 speed SR5 barcelona red
    Readylift, Roadmaster, Bushwacker, Pop & Lock, Redline, Weathertech, Crappy Tire
    Thanks for the info. I turned my radio off tonight and about 2 stoplights later, it came back on by itself at the same volume. Startled me, but no harm done and the volume control on the radio worked. I'll wait and take it in before the warranty runs out.

    monarchrifle.com/doug's2009tacoma.html
     
  9. Jun 23, 2009 at 6:23 PM
    #9
    chad68

    chad68 Master Jedi Member I am...

    Joined:
    Oct 28, 2007
    Member:
    #3263
    Messages:
    1,081
    Gender:
    Male
    First Name:
    Chad
    In a (Toyota) van down by the river! Sonoma Cownty
    Vehicle:
    2009 4x4 reg cab. Modded with more to come
    Polished 16x8 Pro Comp 1069's 4" BS Nitto Mud Grapplers 305/70/16 Magnaflow & glasspack muffler Stainless tip K&N 63 series Aircharger Vent visors Autometer volt and dig. temp. gauge custom mounted Factory chrome rear bumper (not black factory, one) TRD pedal covers TRD skid plate Hurst T handle shift knob Rear Tint Clear bra on the sides Chrome extinguisher Icon non resi coilovers, ICON RR shocks, black seat covers. And some other crap
    I was going to post this same question.

    Mine is tweaked out as well. But since the radio sounds like ass even when it works, I'm just going to get an aftermarket one.

    It shuts off and turns on by itself sometimes and refuses to do other functions when it doesn't feel like doing them and once so far the radio stayed on and the lighting went off. Swear it seems like it doe something different and new every other day.
     
  10. Jun 23, 2009 at 8:34 PM
    #10
    Monarch

    Monarch Threadkiller

    Joined:
    Jun 18, 2009
    Member:
    #18635
    Messages:
    169
    Gender:
    Male
    Kitchener, Ontario
    Vehicle:
    09 AC 4X4 2.7L 5 speed SR5 barcelona red
    Readylift, Roadmaster, Bushwacker, Pop & Lock, Redline, Weathertech, Crappy Tire
    I'll let you know how I make out.

    monarchrifle.com/doug's2009tacoma.html
     
To Top